Page 24 of 61 FirstFirst ... 14222324252634 ... LastLast
Results 231 to 240 of 610

Thread: Howto: Fix Windows share browsing issues

  1. #231
    Join Date
    Apr 2008
    Beans
    6

    Re: Howto: Fix Windows share browsing issues

    My years old smb.conf was screwed up by ipv6 and/or security = share issues which were mentioned above. I haven't had any problems with different versions of Windows including Vista and 7, all were working fine before 9.10 upgrade. Gladly it is now working again so I can freeze my config for the next few years or so I wish I just was wise enough not to upgrade perfectly working setup in the future

  2. #232
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Howto: Fix Windows share browsing issues

    Quote Originally Posted by Lvcoyote View Post
    Now I'm totally hosed as far as this Ubuntu box sharing anything with Windows on it.......

    In typical Linux fashion, it seems a concerted effort is made by those doing the development to make things as difficult as possible.....
    Disable any and all firewalls. You don't really need them if your clients are in a trusted network anyway. I have no problems with my Ubuntu 9.10 test machine and my Win7 machine.

  3. #233
    Join Date
    Nov 2008
    Beans
    50

    Re: Howto: Fix Windows share browsing issues

    Quote Originally Posted by Crandes View Post
    Do you still see tcp6 entries when you type netstat -an?

    If not, then I assume you have other issues causing the problem.

    UPDATE: I noticed on my other server that apparently the 9.10 upgrade has changed security setting to 'SHARE' instead of 'user' which was causing the 'More data is available' problem. Changing that back to 'security = user' cleared the problem out.
    Yes, I still see the tcp6 entries. The only difference is I no longer see any entries for port 445. Also, my smb.conf is the same one I was using with 8.04 with no problems and security is already set to user.

  4. #234
    Join Date
    Nov 2007
    Location
    Omak, WA
    Beans
    188
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Howto: Fix Windows share browsing issues

    Quote Originally Posted by dmizer View Post
    Disable any and all firewalls. You don't really need them if your clients are in a trusted network anyway. I have no problems with my Ubuntu 9.10 test machine and my Win7 machine.
    You mentioned trying that several posts back, and I did disable the firewall on both the XP and Win7 machines, still no joy.
    eVGA X58 Classified E759, i7 920, G.Skill Perfect Storm DDR3 2000 3X2gb, 2X eVGA GTX260 SSC SLI, Lian-LI PC75B, Corsair TX850W, 2X WD Black 640gb Raid0 Win7, Seagate 320gb Linux Mint 9, LG GH22LS30 DVDRW

  5. #235
    Join Date
    Nov 2007
    Location
    Omak, WA
    Beans
    188
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Howto: Fix Windows share browsing issues

    This morning I turned the Ubuntu machine on and tried again, now it works perfectly......LOL. I can browse both the XP and Win7 machines......I guess it just needed a good nights sleep. Anyway, thanks for all the help.....seems to be working now!!
    eVGA X58 Classified E759, i7 920, G.Skill Perfect Storm DDR3 2000 3X2gb, 2X eVGA GTX260 SSC SLI, Lian-LI PC75B, Corsair TX850W, 2X WD Black 640gb Raid0 Win7, Seagate 320gb Linux Mint 9, LG GH22LS30 DVDRW

  6. #236
    Join Date
    Jul 2008
    Beans
    68

    Re: Howto: Fix Windows share browsing issues

    Hi,

    I have the dreaded failed to retrieve share list from server error when trying to browse my WORKGROUP. I have made sure that the correct workgroup name is in smb.conf (in the correct case) and have added the UDP/TCP rules to the firewall:
    [CODE]
    sudo ufw allow proto xxx to any port xxx from xxx.xxx.x.x/xx
    sudo ufw allow proto xxx to any port xxx from xxx.xxx.x.x/xx
    sudo ufw allow proto xxx to any port xxx from xxx.xxx.x.x/xx
    sudo ufw allow proto xxx to any port xxx from xxx.xxx.x.x/xx

    I am able to browse to shares in Nautilus by entering smb://192.xxx.x.x.

    The output of findsmb is as follows:
    Code:
        *=DMB
                                    +=LMB
    IP ADDR         NETBIOS NAME     WORKGROUP/OS/VERSION 
    ---------------------------------------------------------------------

    Have also tried copying the smb.conf file from a working Intrepid machine. Am running Karmic, can anybody suggest a resolution please? This is the only problem i've yet to solve.

    Many thanks in advance.

    EDIT - Resolved by doing a full reinstall. Must have been something to do with me upgrading.
    Last edited by Andysan; November 23rd, 2009 at 09:56 AM. Reason: Resolved

  7. #237
    Join Date
    Nov 2009
    Beans
    4

    Re: Howto: Fix Windows share browsing issues

    So many THX

    It solved my one week problem, I mean I was searching solution for about one week.
    Thank God I found your post.
    Ur the Best!

    Linked to http://ubuntuforum-br.org/index.php?...5800#msg335800
    I hope you dont mind!
    Brazil Ubuntu´s forum
    A lot of guys trying to solve this issue
    Didnt have a good post like yours
    Sorry about my poor English

    Thx

    EdioIlha

  8. #238
    Join Date
    Jul 2006
    Location
    United Kingdom
    Beans
    125
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Howto: Fix Windows share browsing issues

    I have been trying to fix this on and off for weeks first on a jaunty machine then on a karmic (same machine just dist upgrade)

    All is fine with the firewall off (which I did not want as computer is a laptop and not always in my nice safe network)

    No samba shares with the firewall
    This did not work
    sudo ufw allow proto udp to any port 137 from 192.168.1.0/24
    sudo ufw allow proto udp to any port 138 from 192.168.1.0/24
    sudo ufw allow proto tcp to any port 139 from 192.168.1.0/24
    sudo ufw allow proto tcp to any port 445 from 192.168.1.0/24

    But this from a post somewhere in the middle of this thread did
    sudo ufw allow proto udp from 192.168.1.0/24 port 137 to any
    sudo ufw allow proto udp from 192.168.1.0/24 port 138 to any
    sudo ufw allow proto tcp from 192.168.1.0/24 port 139 to any
    sudo ufw allow proto tcp from 192.168.1.0/24 port 445 to any

    Thanks for all the time you have put into providing all the information and stimulating others to contribute

  9. #239
    Join Date
    Nov 2008
    Location
    #!
    Beans
    1,749

    Re: Howto: Fix Windows share browsing issues

    Quote Originally Posted by dmizer View Post
    Disable any and all firewalls. You don't really need them if your clients are in a trusted network anyway. I have no problems with my Ubuntu 9.10 test machine and my Win7 machine.
    Dmizer, I appreciate everything you have done on this forum and all the help...

    I have followed everyone of your guides to a T and other suggestions as well and cannot get Ubuntu to connect to the Win 7 share getting the "Failed to retrieve share list from server"

    I have never been able to get Win 7 to see any of the Ubuntu shares in any browse function but I can connect to them via IP \\192.*.*.*\share name

    I am not running any type of firewall

    I have never setup Samba before so this Win 7 machine and my Ubuntu Karmic are all I have ever used Samba with fwiw...

    Not looking for any answer as all I needed was to get Win7 to back up to the Ubuntu machine and I can do that...

    I will say that networking in the Nix world could stand some improvement?!?!? (ducking now)

    smbtree does show all of the Win7 shares including printers
    Last edited by VastOne; November 23rd, 2009 at 06:25 PM. Reason: smbtree update

  10. #240
    Join Date
    Oct 2009
    Location
    East Yorkshire, England
    Beans
    45
    Distro
    Ubuntu Gnome 13.10 Saucy Salamander

    Re: Howto: Fix Windows share browsing issues

    Hi, dmizer and all

    Firstly a big thanks to the author for this tutorial, using it has improved my home network a great deal. I am however left with one irritating issue, which despite re-reading the previous 20+ pages numerous times ( and assorted links) I am unable to resolve -

    I currently have on my home network the following

    Ubuntu 9.10 64 bit pc
    Vista Home premium 32 bit pc
    XP sp3 32 bit pc (laptop wireless)
    Windows 7 Ultimate 64 bit pc

    All Except the Windows 7 pc can view and browse to each other and share files.
    The Windows 7 pc can see and browse / share all other pc`s (including the Ubuntu pc)

    The Ubuntu pc can view and share files with all pc`s except the Windows 7 pc, which is shown in nautilus when browsing the network, but attempting to access it displays a user name / password prompt!

    The Windows 7 pc has firewall off, public folder sharing on, password protected sharing off, Guest account currently on, but have tried it both ways. The Windows 7 pc has only 2 accounts, one of which is the guest account, neither of which require passwords. I have also tried having a password and using this at the username / password prompt from the Ubuntu pc. No combination of username / password will allow the Ubuntu pc access.

    Interestingly if i do the smbtree command from terminal everything shows pretty much as expected on all pc`s except the Windows 7 pc which just shows - \\DYLAN-PC with no shares listed.
    But like i said it`s public plus 1 manually shared folder is/are accessible from all the other Windows pc`s.

    I notice a number of Windows 7 issues throughout this topic and have tried a number of the suggestions but am still left with the impassable username / password prompt.

    If there are any further suggestions or advice i would be very grateful as ive been trying for days on end to resolve this. One simple folder on the Win 7 pc accessible from the Ubuntu pc would be just fine

    Many thanks

    MrGrumpyArse / Mark

Page 24 of 61 FirstFirst ... 14222324252634 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •