Page 2 of 61 FirstFirst 12341252 ... LastLast
Results 11 to 20 of 608

Thread: Howto: Fix Windows share browsing issues

  1. #11
    Join Date
    Jan 2006
    Beans
    141

    Re: Howto: Fix Windows share browsing issues

    Done.
    Attached Files Attached Files

  2. #12
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Howto: Fix Windows share browsing issues

    In pengo, one problem may be this line "wins support = true". Please remove that as it doesn't do what you think it does. Please see: man smb.conf for more information on why.

    Also in pengo, comment or delete this line: "/var/lib/samba -s /bin/false %u"

    In joust, you'll need to add two lines.
    1) name resolve order = lmhosts host wins bcast
    2) netbios name = JOUST

    I think there are other problems as well, but before doing too much editing I'd like to learn a bit more about why you configured these they way you did, since they're quite different. What are you wanting to do with these shares?

  3. #13
    Join Date
    Jan 2006
    Beans
    141

    Re: Howto: Fix Windows share browsing issues

    Pengo is working now and can browse. Pengo was the main focus, but I'll double check all steps on Joust and post results.


    The wild difference in the 2 are pretty simple, Joust was 100% hand written, and Pengo was originally from webmin. Joust isn't actually sharing or mounting anything at all, and only has samba running purely for the purpose of populating itself into the workgroup when browsing it. No real purpose other than an easy to see 'head count' when I browse shares.

    Pengo will have shares soon enough, and will be mounting some other shares. Its config file is overly complicated(as I see now) so I will be trimming it down soon enough.

  4. #14
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Howto: Fix Windows share browsing issues

    Quote Originally Posted by glave View Post
    Pengo is working now and can browse.
    Fantastic. I'll look forward to hearing about Joust now.

  5. #15
    Join Date
    Jan 2006
    Beans
    141

    Re: Howto: Fix Windows share browsing issues

    Joust is now working as well. I hadn't completed the nsswitch.conf step on Joust.

    Kudos on the help, its much appreciated. Is there a single underlying change in Jaunty that caused this to happen? I know absolutely that under Hardy and Ibex I didn't have these issues.

  6. #16
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Howto: Fix Windows share browsing issues

    Quote Originally Posted by glave View Post
    Joust is now working as well. I hadn't completed the nsswitch.conf step on Joust.

    Kudos on the help, its much appreciated. Is there a single underlying change in Jaunty that caused this to happen? I know absolutely that under Hardy and Ibex I didn't have these issues.
    Glad it's working!

    The first post in this thread is the accumulated knowledge of suffering through it myself, as well as helping people with this problem for almost 3 years now, so ... no, it's not a recent development. You've just been lucky I think.

    Here's one from 2007 for example: http://ubuntuforums.org/showthread.php?t=483352

  7. #17
    Join Date
    Jun 2006
    Beans
    2,930

    Re: Howto: Fix Windows share browsing issues

    Quote Originally Posted by dmizer View Post
    mdns4_minimal would be used if you had a local DNS server.
    I thought the mdns was for the avahi daemon (which used to be installed by default). It allowed name resolution in the .local domain
    I could be wrong though, but it is what I always thought.
    Support 7z in default installs!!!: Click Here

    How to use code blocks to post command output: Click Here
    Official Ubuntu Documentation

  8. #18
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Howto: Fix Windows share browsing issues

    Quote Originally Posted by lavinog View Post
    I thought the mdns was for the avahi daemon (which used to be installed by default). It allowed name resolution in the .local domain
    I could be wrong though, but it is what I always thought.
    You're quite right. It's for zero conf networking: http://en.wikipedia.org/wiki/Zeroconf

    I stand corrected.

  9. #19
    Join Date
    May 2009
    Location
    Detroit, Michigan
    Beans
    1
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Howto: Fix Windows share browsing issues

    Dmizer,

    I was having the same problem, but after following the steps in your first post, everything is working great now. I am a Ubuntu noob and I just wanted to say thanks for putting that info together.

  10. #20
    Join Date
    May 2009
    Beans
    6

    Re: Howto: Fix Windows share browsing issues

    Thanks dmizer
    My ubuntu works correctly now!!


Page 2 of 61 FirstFirst 12341252 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •