Page 15 of 61 FirstFirst ... 5131415161725 ... LastLast
Results 141 to 150 of 610

Thread: Howto: Fix Windows share browsing issues

  1. #141
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Howto: Fix Windows share browsing issues

    Quote Originally Posted by Tankerdog2002 View Post
    Hmmmmmmm......your tips wiped out my entire network.
    Rather than uninstalling, it would have been much better to figure out what the problem really was. That way, my advice doesn't do the same thing to someone else.

    By off chance, are you running a static local network?

  2. #142
    Join Date
    Nov 2007
    Location
    Houston/LA/Albuquerque
    Beans
    58
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Howto: Fix Windows share browsing issues

    dmizer,

    No static setup here.

    Sorry that I didn't spend more time trying to find out what went haywire. Time is something I didn't have a lot of. Already wasted half a day. Got a business to run.

    The reinstall fixed my problem. I'm browsing through 7 different windows drives on the network currently.

    Again,
    Thanks anyway.

  3. #143
    Join Date
    Oct 2007
    Location
    New Zealand
    Beans
    71
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Howto: Fix Windows share browsing issues

    hi dmizer

    i have just upgraded to 9.04 and have the usual problem...can't see shares on my XP computer. it all worked fine on 8.04

    i have followed all your instructions to the letter and still cannot resolve the problem. all firewalls disabled. i can see the computer in the network window, but get that dreaded msg "unable to retrieve.." when trying to browse.

    don't know what else to try...

    one question: in smb.conf, should wins support = yes or no?
    Last edited by caddict; September 17th, 2009 at 12:42 AM.

  4. #144
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Howto: Fix Windows share browsing issues

    Quote Originally Posted by caddict View Post
    hi dmizer

    i have just upgraded to 9.04 and have the usual problem...can't see shares on my XP computer. it all worked fine on 8.04

    i have followed all your instructions to the letter and still cannot resolve the problem. all firewalls disabled. i can see the computer in the network window, but get that dreaded msg "unable to retrieve.." when trying to browse.

    don't know what else to try...

    one question: in smb.conf, should wins support = yes or no?
    Please post your entire smb.conf file. Delete or comment any "wins =" line (the default behavior is desireable).

    "Failed to retrieve share list from server" is almost always a firewall problem. Are you sure you have disabled all firewalls on both the client (XP machine) as well as the server?

  5. #145
    Join Date
    Oct 2007
    Location
    New Zealand
    Beans
    71
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Howto: Fix Windows share browsing issues

    thanks dmizer, i wish your problems could be over

    here is the smb.conf file. it has been inherited from earlier ubuntu installs

    Code:
    [global]
        ; General server settings
    	workgroup = HOME
    	netbios name = FOXY
    	announce version = 5.0
    	socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192
    
    	passdb backend = tdbsam
    	security = user
    	null passwords = true
    	username map = /etc/samba/smbusers
    	name resolve order = lmhosts wins bcast host
    
    	wins support = no
    
    ;	printing = CUPS
    	printcap name = CUPS
    
    ;	syslog = 1
    	syslog only = yes
    ;	server string = samba 3.3.2
    ;	encrypt passwords = yes
    ;	guest ok = no
    ;	guest account = nobody
    
    ; NOTE: If you need access to the user home directories uncomment the
    ; lines below and adjust the settings to your hearts content.
    ;[homes]
        ;valid users = %S
        ;create mode = 0600
        ;directory mode = 0755
        ;browseable = no
        ;read only = no
        ;veto files = /*.{*}/.*/mail/bin/
    
    ; NOTE: Only needed if you run samba as a primary domain controller.
    ; Not needed as this config doesn't cover that matter.
    ;[netlogon]
        ;path = /var/lib/samba/netlogon
        ;admin users = Administrator
        ;valid users = %U
        ;read only = no
    
    ; NOTE: Again - only needed if you're running a primary domain controller.
    ;[Profiles]
        ;path = /var/lib/samba/profiles
        ;valid users = %U
        ;create mode = 0600
        ;directory mode = 0700
        ;writeable = yes
        ;browseable = no
    
    ; NOTE: Inside this place you may build a printer driver repository for
    ; Windows - I'll cover this topic in another HOWTO.
    [print$]
    	path = /var/lib/samba/printers
    ;	browseable = yes
    	guest ok = yes
    	writeable = yes
    	write list = root
    	create mask = 0664
    	directory mask = 0775
    
    [printers]
    	path = /tmp
    	printable = yes
    	guest ok = yes
    	browseable = no
    
    ; Uncomment if you need to share your CD-/DVD-ROM Drive
    ;[DVD-ROM Drive]
        ;path = /media/cdrom
        ;browseable = yes
        ;read only = yes
        ;guest ok = yes
    
    [MyFiles]
    	path = /home/samba
    
    ;	writeable = no
    	create mask = 0644
    ;	directory mask = 0755
    	force user = STEVE
    	force group = STEVE
    ;	available = yes
    ;	browseable = yes
    	valid users = nobody, steve
    i have checked often that ufw is disabled both in the terminal and the gui. on xp i am using comodo which is easily disabled. so i am pretty sure

  6. #146
    Join Date
    Sep 2009
    Beans
    2

    Re: Howto: Fix Windows share browsing issues

    Unless I have missed something from all the entries in this and other places I am unable to get this completely working.

    I am running 9.04. Like others I was able to access my box from other machines from other machines on the network with the netbios name until an update and now I can't get it working. I have disabled UFW. I can get it so that I can browse my shares in windows, but I still cannot connect to the box via SSH and HTTP using the netbios name only the IP address.

    I do not have firestarter installed only ufw and when I add wins to nsswitch.conf system boot halts on samba starting, and even with this enabled it still doesn't work after restarting networking.

    I am at a loss after fiddling with this for a couple of days.

    When I issue smbtree -N I get no output.

    I'm sorry to add to the mess, but please help.

    Thank you.

  7. #147
    Join Date
    Oct 2007
    Location
    New Zealand
    Beans
    71
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Howto: Fix Windows share browsing issues

    after trying various options i am now able to ping my windows computer by name and by ip which is big improvement over yesterday, so there is hope. still can't access those windows shares, but one step closer...

  8. #148
    Join Date
    Oct 2007
    Location
    New Zealand
    Beans
    71
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Howto: Fix Windows share browsing issues

    and now i can browse shares on another computer running vista (even with firewalls enabled)

    strange that the shares on the xp computer cannot be reached...

  9. #149
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Howto: Fix Windows share browsing issues

    Quote Originally Posted by caddict View Post
    strange that the shares on the xp computer cannot be reached...
    That would almost certainly point to a problem with the XP computer.

  10. #150
    Join Date
    Aug 2007
    Beans
    38

    Re: Howto: Fix Windows share browsing issues

    First off, thanks for the awesome guide.

    Unfortunately I've checked every step and can't get the list of shares from the server.

    I can go direct (smb://ip/share) but that's only good if I know the share name.

    I've checked all my firewall settings

Page 15 of 61 FirstFirst ... 5131415161725 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •