Results 1 to 8 of 8

Thread: Cannot disable internal microphone

  1. #1
    Join Date
    Jan 2009
    Beans
    50

    Cannot disable internal microphone

    I cannot figure out how to turn off my laptop mic. I dual boot with Windows Vista, and shutting it off in Windows is no problem, but I cannot for the life of me get it turned off in Ubuntu 9.04. I've had this problem since 8.10, so it's not a result of the upgrade. I've done a lot of searching and have found similar cases with no solutions.

    Any help would be greatly appreciated!

    (I've already tried everything as far as using volume control).

    Thanks

  2. #2
    Join Date
    Aug 2005
    Beans
    201

    Re: Cannot disable internal microphone

    In a terminal, type
    Code:
    alsamixer
    Tab across till you reach "mic". Toggle mute using "m".
    hth
    Attached Images Attached Images

  3. #3
    Join Date
    Jan 2009
    Beans
    50

    Re: Cannot disable internal microphone

    I don't actually have a strictly microphone part of alsamixer, I have:

    Master
    Headphones
    PCM
    Front
    Front Mic Boost
    Mic Boost
    Beep

    I've muted Front, Front Mic Boost, and Mic Boost, but it didn't do anything. Only if I mute Master will the internal mic turn off, but of course that shuts off the volume for everything else too.

    Thanks for your reply, though. This is something I haven't tried yet.

  4. #4
    Join Date
    Jan 2009
    Beans
    50

    Re: Cannot disable internal microphone

    bump

  5. #5
    Join Date
    Jan 2009
    Beans
    50

    Re: Cannot disable internal microphone

    bizzump

  6. #6
    Join Date
    Jan 2009
    Beans
    50

    Re: Cannot disable internal microphone

    Nothing?

  7. #7
    Join Date
    Aug 2006
    Beans
    12
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Cannot disable internal microphone

    Did you try changing some of the stuff in the [capture] menu?

    Code:
    alsamixer -V capture

  8. #8
    Join Date
    Aug 2006
    Beans
    12
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Cannot disable internal microphone

    Or, run
    Code:
    gnome-volume-control
    ...click on preferences and check the [input source] box, then switch it to something other than MIC. It's not the 'right' way to fix it, but it could help in a pinch.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •