Page 66 of 100 FirstFirst ... 1656646566676876 ... LastLast
Results 651 to 660 of 991

Thread: Acer Timeline 3810T

  1. #651
    Join Date
    Dec 2006
    Location
    Jacksonville, FL
    Beans
    25
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Acer Timeline 3810T

    I got my 3810T-8737 a few days ago and I love it! The default battery life with Ubuntu is great but I knew it could be better. I've managed to get my laptop down to 7.0-7.3W at idle. Here's how I did it:

    (execute this as root or via sudo)
    Code:
    #!/bin/bash
    # Author: Riskable
    #
    # Description: Enables every power saving feature I know of
    #
    
    # Enable Intel HD Audio power saving
    echo 10 > /sys/module/snd_hda_intel/parameters/power_save
    echo Y > /sys/module/snd_hda_intel/parameters/power_save_controller
    echo 1 > /dev/dsp # Gotta make a sound to turn it on
    
    # Enable various kernel power saving features
    echo 1500 > /proc/sys/vm/dirty_writeback_centisecs
    
    # Enable SATA power management
    for i in /sys/class/scsi_host/*; do echo "min_power" > $i/link_power_management_policy; cat $i/link_power_management_policy; done
    
    # Enable Wifi power management
    /sbin/iwconfig wlan0 power on
    
    # Enable the most aggressive hard drive power savings
    hdparm -B 1 -S 12 /dev/sda # Note: May not work on the Acer Timeline's hard drive
    I also added "usbcore.autosuspend=1" to the GRUB_CMDLINE_LINUX_DEFAULT variable in /etc/default/grub (run 'update-grub' after making that change). I don't think that particular setting makes much of a difference.

    Here's why I think we can't get power usage below 7W in Ubuntu: ACPI fan control. The fan is ALWAYS ON with this laptop--for some reason the BIOS doesn't turn it off on its own (ever). I suspect this problem won't be fixed until Acer releases a BIOS update that fixes whatever the problem is.

    As for getting power usage below 6W, I'm not sure what else can be done. I suspect that Acer did something with its Windows drivers to get it down that low. They need to be more transparent about this so Linux hackers can get these features working as well.
    -Riskable
    http://riskable.com
    "Having someone to blame is not an effective IT strategy."

  2. #652
    Join Date
    Oct 2009
    Beans
    9

    Re: Acer Timeline 3810T

    Still I didn't got any feedback of disabling the HD4330 and using onboard ONLY.
    Isn't there any way to do this?

  3. #653
    Join Date
    Dec 2009
    Beans
    37

    Re: Acer Timeline 3810T

    Powertop tells me around 8,0 W in absolute power saving mode (Wifi/Bluetooth off; all the tweaks from above) with ATI enabled!

    With Wifi and low screen brightness ca. 9 W.

    Disabeling the ATI card:
    - Turn graphics to switchable in BIOS
    - Compile lenovo_acpi module (google!)
    - add to /etc/modules
    - reboot

    I am still not 100% sure, that it is disabled though...

  4. #654
    Join Date
    Feb 2008
    Location
    I'm lost ... HELP!
    Beans
    1,013
    Distro
    Xubuntu

    Re: Acer Timeline 3810T

    Quote Originally Posted by acermobile View Post
    ...

    I am still not 100% sure, that it is disabled though...
    If it's not listed with
    Code:
    lspci
    the card is off.

  5. #655
    Join Date
    Jan 2010
    Beans
    3

    Re: Acer Timeline 3810T

    Is the first time I write anything in a forum, i buy a Acer TimeLine 3810T and I investigated. It's very important for install Ubuntu and Windows 7 (Sorry Linux person for intruducing this in this forum but it is true) update the bios of this computer. because if you dont do this you can't install Ubuntu and Windows 7 apearlish v a blue screen. When I buy this computer have the BIOS version 1.04, you can't update first to 1.20 (the last version), you have to update to 1.10,1.15.1.17 and finally 1.20. When you do this you can install Ubuntu and Windows 7 without problem.
    I hope help all with this comentary.

    Sorry for my english mistakes but I am from Spain and i dont speak and write English very well.

    Good Luck.

  6. #656
    Join Date
    Nov 2009
    Beans
    32

    Re: Acer Timeline 3810T

    Hi to everyone!
    Well i tried the script wrote by Riskable and it works (thank Riskable),i have the same results,only one question,maybe two:
    1)Does your hd completely stop?Mine doesn't.
    2)I can't get under 7.3w even if i switch-off wi-fi,is it normal?
    I think that we should use ram in a better way,using it like a hd,so we could reduce hd-access.

  7. #657
    Join Date
    Oct 2009
    Beans
    9

    Re: Acer Timeline 3810T

    Quote Originally Posted by acermobile View Post
    Powertop tells me around 8,0 W in absolute power saving mode (Wifi/Bluetooth off; all the tweaks from above) with ATI enabled!

    With Wifi and low screen brightness ca. 9 W.

    Disabeling the ATI card:
    - Turn graphics to switchable in BIOS
    - Compile lenovo_acpi module (google!)
    - add to /etc/modules
    - reboot

    I am still not 100% sure, that it is disabled though...
    Some fantastic news. I'll definitly give this a try.
    Oh, another thing comes to mind.
    Does Ubuntu support passiv cooling? The 3810 is quite noisy if active cooling is switched on. (Yeah ; Sorry ; I'm such a noob -_-)

  8. #658
    Join Date
    Jan 2010
    Beans
    21

    Re: Acer Timeline 3810T

    Quote Originally Posted by riskable View Post
    I got my 3810T-8737 a few days ago and I love it! The default battery life with Ubuntu is great but I knew it could be better. I've managed to get my laptop down to 7.0-7.3W at idle. Here's how I did it:

    (execute this as root or via sudo)
    Code:
    #!/bin/bash
    # Author: Riskable
    #
    # Description: Enables every power saving feature I know of
    #
    
    # Enable Intel HD Audio power saving
    echo 10 > /sys/module/snd_hda_intel/parameters/power_save
    echo Y > /sys/module/snd_hda_intel/parameters/power_save_controller
    echo 1 > /dev/dsp # Gotta make a sound to turn it on
    
    # Enable various kernel power saving features
    echo 1500 > /proc/sys/vm/dirty_writeback_centisecs
    
    # Enable SATA power management
    for i in /sys/class/scsi_host/*; do echo "min_power" > $i/link_power_management_policy; cat $i/link_power_management_policy; done
    
    # Enable Wifi power management
    /sbin/iwconfig wlan0 power on
    
    # Enable the most aggressive hard drive power savings
    hdparm -B 1 -S 12 /dev/sda # Note: May not work on the Acer Timeline's hard drive
    I also added "usbcore.autosuspend=1" to the GRUB_CMDLINE_LINUX_DEFAULT variable in /etc/default/grub (run 'update-grub' after making that change). I don't think that particular setting makes much of a difference.

    Here's why I think we can't get power usage below 7W in Ubuntu: ACPI fan control. The fan is ALWAYS ON with this laptop--for some reason the BIOS doesn't turn it off on its own (ever). I suspect this problem won't be fixed until Acer releases a BIOS update that fixes whatever the problem is.

    As for getting power usage below 6W, I'm not sure what else can be done. I suspect that Acer did something with its Windows drivers to get it down that low. They need to be more transparent about this so Linux hackers can get these features working as well.
    WOW !! Thank you. I had 20W before (see my post #642) and now I have 9W when surfing! It's like windows now
    Just one thing, I see this error : Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; Operation not supported.
    How can I fix it ?
    thanks

  9. #659
    Join Date
    Oct 2008
    Location
    Cambrils (Tarragona)
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Acer Timeline 3810T

    install linux-backports-modules-wireless-karmic-generic, reboot and try again
    Busques ajuda? Comença pel wiki de l'equip català!

  10. #660
    Join Date
    Jan 2010
    Beans
    21

    Re: Acer Timeline 3810T

    I've installed this packet now.
    The script above works good with kernel 2.6.31.14. But the wireless power saving doesn't, I still see "SET failed on device wlan0" even with linux-backports-modules-wireless-karmic-generic installed. When screen brightness is at its lowest and wifi off, I see 8 W in powertop.

    With kernel 2.6.31.17, is seems that the script does nothing at all. I see 20W in powertop (with or without the script). However in this kernel I don't see the error "SET failed on device wlan0". Strange ... ?!

    Another question : all these results are with "switchable graphics = discrete" in BIOS.
    If I change to "switchable" I can't boot to ubuntu at all. The screen is blinking and I can't log into X. Any idea ?

Page 66 of 100 FirstFirst ... 1656646566676876 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •