Page 10 of 15 FirstFirst ... 89101112 ... LastLast
Results 91 to 100 of 144

Thread: VirtualBox error: Kernel driver not installed (rc=-1908)

  1. #91
    Join Date
    Feb 2011
    Beans
    1

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    Quote Originally Posted by rinocom View Post
    Try tabbing out the vboxdrv portion of 'sudo /etc/init.d/vboxdrv' and see if it has been moved... I say this because I found that I had a file called '/etc/init.d/vboxdrv.dpkg-bak'. I executed
    Code:
    laptop:~$ sudo cp /etc/init.d/vboxdrv.dpkg-bak /etc/init.d/vboxdrv
    laptop:~$ sudo /etc/init.d/vboxdrv setup
     * Stopping VirtualBox kernel module                                             *  done.
     * Removing old VirtualBox netadp kernel module                                  *  done.
     * Removing old VirtualBox netflt kernel module                                  *  done.
     * Removing old VirtualBox kernel module                                         *  done.
     * Recompiling VirtualBox kernel module                                          *  done.
     * Starting VirtualBox kernel module                                             *  done.
    I seem to be good now.

    Rhino
    Thank you VERY much, Rinocom!
    It finally works for me, after 15 days try...

  2. #92
    Join Date
    Apr 2008
    Location
    New England
    Beans
    41
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    Quote Originally Posted by lin-lin_224 View Post
    I met the same problem after updating UBUNTU9.04 . Now, I found the solution on the following address: https://answers.launchpad.net/ubuntu/+source/virtualbox-ose/+question/64190
    And I just typed the three lines commands one by one, then the Virtualbox worked.

    The commands are:

    sudo aptitude update
    sudo aptitude install dkms
    sudo /etc/init.d/vboxdrv setup



    Try it!
    Good luck!
    works for me also.
    registered linux user #438335

  3. #93
    Join Date
    May 2011
    Beans
    2

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    after updating to ubuntu 11.04, i ran into error posted in previous messages. tried everything above, still got same error. then i re-installed gcc and gcc related packages through synaptic and virtualbox 4.08 now works.

    thank you everybody for posting advice.

  4. #94
    Join Date
    Jun 2006
    Location
    out west
    Beans
    18
    Distro
    Ubuntu Development Release

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    I'm also attempting to install VB 4.08 on Natty 11.04, and I keep getting the kernel diver error discussed above.

    When I run sudo /etc/init.d/vboxdrv setup it returns:
    * Trying to register the VirtualBox kernel modules using DKMS
    Error! Your kernel headers for kernel 2.6.32.26+drm33.12 cannot be found at
    /lib/modules/2.6.32.26+drm33.12/build or /lib/modules/2.6.32.26+drm33.12/source.

    I've tried numerous solutions discussed above, but nothing works. I've installed the generic Natty kernels, DKMS, and re-installed gcc.

    If anyone has advice, or even encouragement, I'd be appreciative! Thank you.

  5. #95
    Join Date
    Jul 2009
    Location
    Indonesia
    Beans
    5
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    I had the same problem. I installed VirtualBox 4.0.8.r71778 Windows XP SP3 as the guest OS and my Ubuntu 10.04 (2.6.32 kernel) as the host OS. After I upgrade the kernel into 2.6.38 my XP on the VirtualBox didn't work, I don't exactly remember the error was. But after I reinstalled the VirtualBox, I found that my XP works normal like before!

  6. #96
    Join Date
    Jun 2006
    Location
    out west
    Beans
    18
    Distro
    Ubuntu Development Release

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    It finally hit me: I'm running Ubuntu 11.04 as a secondary OS on a Cr-48, Google's test Chromebook. The Chrome OS is curently based on Ubuntu's 2.6.32 kernel, which is also the kernel that my installation of Ubuntu is using. When VirtualBox attempts to install, it can't find the kernel headers for my 2.6.32 kernel, because the kernel headers loaded with 11.04 are based on 2.6.38.

    If I was a lot smarter, I'm sure that there's a way to work around the issue. So, it looks like I'm dead in the water until Google begins using the updated kernel.

    I'm not sure how to "force" 11.04 to use/install the necessary 2.6.32 kernel files to make VB install.

  7. #97
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    I'm not sure if you can "force" it either. If you are booted into 2.6.38, it should find the headers for that kernel.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  8. #98
    Join Date
    May 2011
    Beans
    3

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    This Link may be helpfull for you!

    http://ubuntuforums.org/showthread.php?t=1747766

    Franz

  9. #99
    Join Date
    Oct 2007
    Beans
    6

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    Quote Originally Posted by Wangberg View Post
    works for me also.
    As posted above, the following worked with a slight modification - ubuntu natty, vbox 4.1.2

    replace aptitude with apt-get

    sudo apt-get update (OK)
    sudo apt-get install dkms (already latest)
    sudo /etc/init.d/vboxdrv setup (error about conf file not in good format but WORKED)

    Thanks all - HTH

    my level - advanced noob!

  10. #100
    Join Date
    Jul 2009
    Beans
    571
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: VirtualBox error: Kernel driver not installed (rc=-1908)

    Ever since my last post in this thread 5 months ago? I switched to VMware Player (it's also free)
    It's OK, everything we know will become obsolete at some time.

Page 10 of 15 FirstFirst ... 89101112 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •