Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: HOW TO: Get Line6 Guitar Port to work!

  1. #1
    Join Date
    Aug 2008
    Location
    Danville, In. USA
    Beans
    59
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Lightbulb HOW TO: Get Line6 Guitar Port to work!

    How to install a Line6 Guitar Port (and the toneport

    With a very big thanks to Myhrman from Source Forge for helping me get this thing working and a big thanks to Grabner for providing the drivers for something that seems to be non existant for linux! This is to get the Guitar Port to work as a basic USB sound device so you will get a dry signal in and out that will work under Alsa and Jack.

    Note: Myhrman says it should work with most toneports too but neither of us have one to test it out.

    First open your Terminal
    Applications> Accessories> Terminal

    You will need to get Subversion
    PHP Code:
    sudo apt-get install subversion 
    Then you will need to get the source
    PHP Code:
    svn co https://line6linux.svn.sourceforge.net/svnroot/line6linux 
    Change to the directory
    PHP Code:
    cd line6linux/driver/trunk 
    Time to build from the source but first make sure you have the latest build and headers

    PHP Code:
    sudo apt-get install build-essential 
    PHP Code:
    sudo apt-get install linux-headers 
    (Note: You will atlest have version 2.6.27.14. To check your version in terminal type uname -r)

    Now that is updated and you are in the trunk directory
    PHP Code:
    make 
    PHP Code:
    sudo make install 
    Now shutdown and restart with the guitar port (or toneport) connected and you should beable to see it in your
    System> Preferences> Sound
    (Laptop) Toshiba Satellite A215-S7422 AMD Turion 64 x2 1.90GHz, 4 GB RAM ATI X1200 (Desktop) Intel Core 2 Duo 1.89GHz, 2 GB RAM Nvidia GT220

  2. #2
    Join Date
    Feb 2008
    Location
    wouldnt you like to know
    Beans
    57
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOW TO: Get Line6 Guitar Port to work!

    hey trying this on 8.04 with 2.6.24-16 headers (it failed miserably)

    update to 9.04 its so much better then 8.o4
    Last edited by JohnsShadow; July 7th, 2009 at 07:45 PM.

  3. #3
    Join Date
    Feb 2008
    Location
    wouldnt you like to know
    Beans
    57
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOW TO: Get Line6 Guitar Port to work!

    i upgrade to 9.04 so i could get the proper kernal
    it compiled perfectly no errors or nothing
    i rebooted with the toy pluged in and bam there it was under sound

    now to figure out how to get creox to play it

  4. #4
    Join Date
    Jul 2009
    Beans
    1

    Re: HOW TO: Get Line6 Guitar Port to work!

    I got my toneport UX1 to work!! Thank you so much! I used OSS. Had to update from 8.04 to 9.04 but it was worth it.



  5. #5
    Join Date
    Nov 2008
    Beans
    1

    Re: HOW TO: Get Line6 Guitar Port to work!

    Hi, my toneport UX1 is working with everything, except Flash (youtube). Does anybody had a similar problem?

    thank you,

    Fabio

  6. #6
    Join Date
    Feb 2007
    Beans
    11
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: HOW TO: Get Line6 Guitar Port to work!

    Thanks!

    Got it working with my Toneport GX in OSS. ALSA won't work at all.

    Can't get it working with Wine at the moment, so still no Spotify, still it's a vast improvement over nothing.

  7. #7
    Join Date
    Feb 2007
    Beans
    193

    Re: HOW TO: Get Line6 Guitar Port to work!

    Hi,

    I am trying to get my Guitarport to work. when i set it as the output device in system>preferences>sound and then click test i get this error:-

    audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink profile=chat: Could not open audio device for playback.

    can anyone help with this?

    Thanks,
    Alex

  8. #8
    Join Date
    Aug 2009
    Beans
    5

    Re: HOW TO: Get Line6 Guitar Port to work!

    I get the same error message. Installation was no problem. Does anybody know what might be wrong?

  9. #9
    Join Date
    Aug 2009
    Beans
    5

    Re: HOW TO: Get Line6 Guitar Port to work!

    I'm using Ubuntu 9.04 and Toneport UX1. Trying to get sound to work over headphones. Is that my problem? Should I use a different channel?

  10. #10
    Join Date
    Aug 2008
    Location
    Danville, In. USA
    Beans
    59
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: HOW TO: Get Line6 Guitar Port to work!

    After using my Guitar Port for some time now here's the settings that work for me. I don't have any problems with these settings!

    Go to System> Preferences> Sound Preferences and make sure everything is on the Line6 (OSS) and on Default Mixer Select the ALSA version. This Config seems to work for me. Make sure your "Monitor Track" is muted due to some feedback when using Jack.

    When recording with Jack only use "Capture_1" for your recordings. "Capture_2" is used by the Line6 software as the "DI" for the tuner and for some reason it has alot of noise.

    As for the ALSA support I'm clueless! It works under ALSA in Jack, so I don't know about that!

    My only problem is to find a nice amp emulator program for Linux.

    Forge
    (Laptop) Toshiba Satellite A215-S7422 AMD Turion 64 x2 1.90GHz, 4 GB RAM ATI X1200 (Desktop) Intel Core 2 Duo 1.89GHz, 2 GB RAM Nvidia GT220

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •