Results 1 to 4 of 4

Thread: No wifi with Atheros 928X

  1. #1
    Join Date
    Aug 2008
    Beans
    14

    No wifi with Atheros 928X

    After one month of work I am still stuck to connect to wireless.
    Machine Toshiba Satellite Pro. Networkcard Atheros 928X.
    OS Ubuntu 8.10.
    With the WI FI switch in the off position ,the PC loads the ATH9K driver. the Command Iwconfig correctly shows the card. The networking shows correctly and it is correctly grayed out.
    If I put the WIFI switch in the ON position, the networking is no longer grayed out but before connection is established the PC will freeze up completely, a hard reset is the only way out.
    I have tried backports.I have read many how to and blacklisted the ATH9K to load in turn ATH5K , ATH_PCI and Ndiswrapper. With all of these drivers command IWCONFIG does not show the WIFI card.
    Now I have upgraded to the last Ubuntu 9.10. With this release the PC does not freeze anymore regardless of the position of the WIFI switch but the WIFI connection is always grayed out. Iwconfig shows the wireless card.
    WIFI correctly works with windows so HW problems can be ruled out.
    Any ideas

    Thank you.

  2. #2
    Join Date
    Mar 2009
    Beans
    48
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: No wifi with Atheros 928X

    Try disabling bluetooth. This worked for me but the connection is very unstable. It stays connected to the AP but if you put any traffic through it bugs out and drops activity for about 10 seconds. Overall ath9k is a very bad driver.

  3. #3
    Join Date
    May 2007
    Location
    UK near Bedford
    Beans
    3,481
    Distro
    Ubuntu Development Release

    Re: No wifi with Atheros 928X

    Here is a thread that may help

    http://ubuntuforums.org/showthread.php?t=1135445
    PC

    To get a terminal command to put its output into a file use this format
    {terminal command} > {filename}

  4. #4
    Join Date
    Aug 2008
    Beans
    14

    Re: No wifi with Atheros 928X

    Thank you for both your answers. This week end I will try to disable bluetooth. I had already tried the Post from Volanin to no use. I will let you know

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •