Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 33

Thread: Can't connect to SAMBA share via Jaunty

  1. #21
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Can't connect to SAMBA share via Jaunty

    Quote Originally Posted by Peter09 View Post
    Thanks for the correction dmizer
    No problem

    Here's more information on the name resolution problem: http://www.backports.ubuntuforums.or...8&postcount=12

    If none of that works, a firewall (On the server or on the client) may be interfering.
    Last edited by dmizer; May 11th, 2009 at 09:46 AM.

  2. #22
    Join Date
    Nov 2008
    Location
    San Francisco, California
    Beans
    389
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't connect to SAMBA share via Jaunty

    Here are the results, the same for both laptops:

    Code:
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.0.0     *               255.255.255.0   U     2      0        0 wlan0
    link-local      *               255.255.0.0     U     1000   0        0 wlan0
    default         192.168.0.1     0.0.0.0         UG    0      0        0 wlan0
    How can I tell if winbind is running?

  3. #23
    Join Date
    May 2007
    Location
    UK near Bedford
    Beans
    3,481
    Distro
    Ubuntu Development Release

    Re: Can't connect to SAMBA share via Jaunty

    perhaps the easiest way is attempt to restart it with

    Code:
    sudo /etc/init.d/winbind restart
    watch for any messages.
    PC

    To get a terminal command to put its output into a file use this format
    {terminal command} > {filename}

  4. #24
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Can't connect to SAMBA share via Jaunty

    Quote Originally Posted by Nixie Pixel View Post
    I should note that the only WINS server on the network is the Ubuntu Server where I set wins support to be yes in smb.conf.
    In smb.conf, "wins support" should be set to no. This option is only for use when the server is being used as a WINS server across a multi-subnetted network (so names will resolve across different subnets).

    Though, this mistake is probably not hurting anything or preventing you from connecting.

    Can you post your entire smb.conf file?

  5. #25
    Join Date
    May 2007
    Location
    UK near Bedford
    Beans
    3,481
    Distro
    Ubuntu Development Release

    Re: Can't connect to SAMBA share via Jaunty

    Dmizer,
    the thing of interest to me is that when she tries to ping an internal windows machine it goes out to an external DNS server - it seems to come down to name resolution.
    PC

    To get a terminal command to put its output into a file use this format
    {terminal command} > {filename}

  6. #26
    Join Date
    Nov 2008
    Location
    San Francisco, California
    Beans
    389
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't connect to SAMBA share via Jaunty

    The client is a vanilla 9.04 Jaunty Jackalope desktop installation. The server was just installed the other day, Ubuntu Server 8.10. Neither have firewalls running, nor have I messed with the IP tables.

    Trying to start winbind on the "bad" machine returns:
    "sudo: /etc/init.d/winbind: command not found"

    I'll post smb.conf in a few minutes, but I thought I could use SAMBA as a WINS server for a single subnet?

  7. #27
    Join Date
    May 2007
    Location
    UK near Bedford
    Beans
    3,481
    Distro
    Ubuntu Development Release

    Re: Can't connect to SAMBA share via Jaunty

    You need to install winbind - thats most probably it.

    Code:
    sudo apt-get install winbind
    PC

    To get a terminal command to put its output into a file use this format
    {terminal command} > {filename}

  8. #28
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Can't connect to SAMBA share via Jaunty

    Quote Originally Posted by Peter09 View Post
    Dmizer,
    the thing of interest to me is that when she tries to ping an internal windows machine it goes out to an external DNS server - it seems to come down to name resolution.
    Yes, that could be a result of a few things.

    1. Winbind is not actually installed, or is not running on the client.
    2. WINS is not being queried before DNS.
    3. The client is not finding the server because the client and server are not members of the same workgroup (Nautilus GVFS cannot search inside workgroups that it is not a member of).
    4. A firewall is preventing WINS queries.


    When using OpenDNS, this is expected behavior for the above problems (for the reasons I explained earlier).

  9. #29
    Join Date
    Nov 2008
    Location
    San Francisco, California
    Beans
    389
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't connect to SAMBA share via Jaunty

    Thanks very much for your help, I appreciate it very much - I installed winbind on the "bad" laptop (it was already on the "good" one) and now I can connect to the server!

    Since you mentioned it, how can I set the windows workgroup on an Ubuntu machine?

    Thanks again!

  10. #30
    Join Date
    May 2007
    Location
    UK near Bedford
    Beans
    3,481
    Distro
    Ubuntu Development Release

    Re: Can't connect to SAMBA share via Jaunty

    There is a workgroup setting in /etc/samba/smb.conf.
    Almost first line in the configuration
    PC

    To get a terminal command to put its output into a file use this format
    {terminal command} > {filename}

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •