Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Tiny fonts on opera

  1. #11
    Join Date
    Apr 2008
    Beans
    27
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Tiny fonts on opera

    font rendering: I already tried to tweak those settings in a lot of ways but that doesn't change anything regarding font size in Opera

    xcore fonts: it was already unticked... so I tried and ticked it but nothing changed


  2. #12
    Join Date
    Nov 2006
    Location
    Norway
    Beans
    795
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Tiny fonts on opera

    I'll do some more tests when I get home. But I'm afraid I can't help you more. The -personaldir should have shown the page with all the default settings. You didn't edit any of Operas default css files?

    You could try to dl opera in tar.gz format and unpack it. You can then run a completely separate "install" of opera from that folder.

    removing everything Opera-related and reinstall is another option...
    Last edited by .nedberg; May 5th, 2009 at 04:39 PM.
    Open mind, open source!
    Keep control of computer usage with timekpr
    Screensaver for Amarok? AmarokScreenSaver
    My (Norwegian) blog about motorcycles and MotoGP

  3. #13
    Join Date
    Nov 2006
    Location
    Norway
    Beans
    795
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Tiny fonts on opera

    I am now at home and have tested with Opera on Ubuntu and Kubuntu, both pages look fine here.

    Some thoughts:
    -Go to Show->Style, only "Author mode" should be selected
    -opera:config, search for font. In "author mode" author font should be used.
    -Try to dl opera in tar.gz format and test with that version
    -Try a beta version of Opera 10 and see if the problem is still there
    -Go to http://my.opera.com/community/forums/ and ask there
    -It might be some setting in Gnome
    -Tools->Settings->Advanced->Fonts find the one for normal webpages and see what it is set to (mine is times new roman(monotype) size 16)
    Open mind, open source!
    Keep control of computer usage with timekpr
    Screensaver for Amarok? AmarokScreenSaver
    My (Norwegian) blog about motorcycles and MotoGP

  4. #14
    Join Date
    Apr 2008
    Beans
    27
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Lightbulb Re: Tiny fonts on opera

    Okay, solved... This was a complex one.

    1. I've downloaded the tar.gz Opera and tested it: everything was fine.
      So the problem was not with Gnome but only with Opera configuration.

    2. I checked if Show->Style was on Author mode only.
      It was the case.

    3. I checked the Author Display Mode section of the opera:config page.
      Author Font and Colors was checked.

      So was User Font and Colors, too!
      So, I tried and unckeched it: the above mentionned page became readable!

      But it was not perfect, yet: a tad smaller than with fresh tar.gz Opera.

    4. So I checked in Tools->Settings->Advanced->Fonts the normal webpage text font.
      Its its size was 14.
      Changed it to its default of 16 (as in the tar.gz Opera) and ...boom, baby... that was it!


    Many thanks for your help!

    Note that Opera settings always fills the gaps stylewise.
    To see what I mean, have a look at http://www.jthink.net/jaikoz/.
    Its css files only specify the font family to use and let the browser use its default font size.
    That's why it displays a sans font whose size depends on the normal webpage text font setting of Opera, even if this one is a serif font.

  5. #15
    Join Date
    Dec 2004
    Location
    hacking on my Debian box
    Beans
    1,305

    Re: [solved] Tiny fonts on opera

    Can't read the librettos? lol

  6. #16
    Join Date
    Nov 2006
    Location
    Norway
    Beans
    795
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Tiny fonts on opera

    Glad it worked out for you!

    Strange thing that it didn't work with -personaldir...
    Open mind, open source!
    Keep control of computer usage with timekpr
    Screensaver for Amarok? AmarokScreenSaver
    My (Norwegian) blog about motorcycles and MotoGP

  7. #17
    Join Date
    Apr 2008
    Beans
    27
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Tiny fonts on opera

    -personaldir: I don't know why. I've tried it a few times during the whole process and it always showed me the same thing as with my main Opera settings.

  8. #18
    Join Date
    Nov 2006
    Location
    Norway
    Beans
    795
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Tiny fonts on opera

    As long as it worked out for you! I noticed that 'opera -help' lists -pd instead of -personaldir. Might be related, but I don't think so...
    Open mind, open source!
    Keep control of computer usage with timekpr
    Screensaver for Amarok? AmarokScreenSaver
    My (Norwegian) blog about motorcycles and MotoGP

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •