Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Enable WOL in EEEPC - server 12.04

  1. #1
    Join Date
    Mar 2007
    Beans
    4

    Enable WOL in EEEPC - server 12.04

    I have installed ubuntu server 12.04 in an EEEPC 900 but till now i am not able to make it wake on lan.
    I edited /etc/network/interfaces and add the line ethernet-wol g.

    # The primary network interface
    auto eth0
    iface eth0 inet dhcp
    ethernet-wol g

    after that i can see with ethtool eth0
    Supports Wake-on: g
    Wake-on: g


    but after a power off , and send the magic packet, the machine does not power up.

    I also tried to add the following lines in rc.local


    # Allow eth0 to wake up machine
    echo enabled > /sys/class/net/eth0/device/power/wakeup

    # Configure ACPI
    grep `lspci -tv | grep -i ethernet | cut -d- -f2` \
    /proc/acpi/wakeup | cut -d' ' -f1 > /proc/acpi/wakeup



    a new power off , and again machine does not power up after a magic packet.

    I am out of ideas.

  2. #2
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,898
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Enable WOL in EEEPC - server 12.04

    Hi colchaodemola.

    I usually start by checking the BIOS. I've seen that the WOL option (not always called that on the BIOS) it can be set on and off there.

    Just a thought.
    Regards.

  3. #3
    Join Date
    Mar 2007
    Beans
    4

    Re: Enable WOL in EEEPC - server 12.04

    There is no option for wol in bios.
    But since it worked in windows xp i think it should work in linux too.

  4. #4
    Join Date
    Aug 2010
    Location
    hole
    Beans
    415
    Distro
    Ubuntu

    Re: Enable WOL in EEEPC - server 12.04

    Quote Originally Posted by colchaodemola View Post
    There is no option for wol in bios.
    But since it worked in windows xp i think it should work in linux too.
    because EEEPC is not supporting WOL..

  5. #5
    Join Date
    Sep 2006
    Beans
    49

    Re: Enable WOL in EEEPC - server 12.04

    What nic is this? Would you please give us the output of lspci.

  6. #6
    Join Date
    Apr 2007
    Location
    Newburyport, MA
    Beans
    366
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: Enable WOL in EEEPC - server 12.04

    Did you ever solve this? I'm getting the same problem on my eee PC 900. WOL is known to be supported on these netbooks and ethtool confirms that WOL is on, but no matter what I do, the ethernet port powers off (the router's light for it turns off, where other WOL computers aren't doing that) so it just simply can't receive the signal.

    Maybe you're getting the same issue?
    Check out my website for programs and games I made for linux:
    http://zicronsoft.comxa.com

  7. #7
    Join Date
    Jul 2008
    Beans
    76
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Enable WOL in EEEPC - server 12.04

    Have you reviewed these threads?

    http://ubuntuforums.org/showthread.php?t=234588
    http://ubuntuforums.org/showthread.php?t=1855551
    http://ubuntuforums.org/showthread.php?t=814939

    I had to tweak the settings on some intermediate devices in order to get wake-on-LAN working on my system.

  8. #8
    Join Date
    Apr 2007
    Location
    Newburyport, MA
    Beans
    366
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: Enable WOL in EEEPC - server 12.04

    Quote Originally Posted by egpetrich View Post
    Have you reviewed these threads?

    http://ubuntuforums.org/showthread.php?t=234588
    http://ubuntuforums.org/showthread.php?t=1855551
    http://ubuntuforums.org/showthread.php?t=814939

    I had to tweak the settings on some intermediate devices in order to get wake-on-LAN working on my system.
    Yes, I have. They didn't answer my question. I'm just wondering if there's a way to force power to run through ethernet while the computer is off.
    Check out my website for programs and games I made for linux:
    http://zicronsoft.comxa.com

  9. #9
    Join Date
    Jul 2008
    Beans
    76
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Enable WOL in EEEPC - server 12.04

    I haven't looked at the back of my server when it's suspended, so I don't know if the activity lights are running. There's another thread that may give some info:

    http://ubuntuforums.org/showpost.php?p=8863310

    In addition to having wake-on-LAN enabled for your LAN controller, the bus devices above it have to be enabled. I get the impression that this means they'll still have power even when you're in S3.

    First, try these two commands:

    Code:
    lspci -tv
    cat /proc/acpi/wakeup
    The "lspci" dump will show you the PCI device tree. You need to find the devices sitting above your LAN controller. The proc file "/proc/acpi/wakeup" will show you which devices are enabled during suspend and shutdown. Post the output of those commands here, and maybe I or someone will see something amiss.

  10. #10
    Join Date
    Apr 2007
    Location
    Newburyport, MA
    Beans
    366
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: Enable WOL in EEEPC - server 12.04

    Code:
    -[0000:00]-+-00.0  Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller
               +-02.0  Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller
               +-02.1  Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller
               +-1b.0  Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
               +-1c.0-[04]--
               +-1c.1-[03]----00.0  Atheros Communications Inc. L2 Fast Ethernet
               +-1c.2-[01-02]--
               +-1d.0  Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1
               +-1d.1  Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2
               +-1d.2  Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3
               +-1d.3  Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4
               +-1d.7  Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller
               +-1e.0-[05]--
               +-1f.0  Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge
               +-1f.2  Intel Corporation 82801FBM (ICH6M) SATA Controller
               \-1f.3  Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller
    Code:
    Device  S-state   Status   Sysfs node
    P0P3      S4    *disabled  pci:0000:00:1e.0
    P0P4      S4    *disabled  pci:0000:00:1c.0
    P0P5      S4    *disabled  pci:0000:00:1c.1
    P0P6      S4    *disabled  pci:0000:00:1c.2
    P0P7      S4    *disabled  
    MC97      S4    *disabled  
    USB1      S3    *enabled   pci:0000:00:1d.0
    USB2      S3    *enabled   pci:0000:00:1d.1
    USB3      S3    *enabled   pci:0000:00:1d.2
    USB4      S3    *enabled   pci:0000:00:1d.3
    EUSB      S3    *enabled   pci:0000:00:1d.7
    MC97 is onboard audio which I think I currently have disabled, so I'm pretty sure that can be ignored.
    Check out my website for programs and games I made for linux:
    http://zicronsoft.comxa.com

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •