Results 1 to 3 of 3

Thread: cannot boot after upgrading to 8.04

Hybrid View

  1. #1
    Join Date
    Jun 2007
    Beans
    12

    cannot boot after upgrading to 8.04

    Hi, I had Ubuntu 7.04 installed, and I downloaded an image CD of 8.04. I've run the installation but the following message appeared after rebooting:

    Code:
    check root = bootarg cat /proc/cmdline....
    ALERT! /dev/disk/by-uuid/e21..... does not exist. Dropping to a shell!
    
    *(initframs)
    During the installation I've noticed that my hard drive appeared as a SCSI drive instead of an IDE one. Now if I use the new live CD, fdisk -l lists all my partitions as /dev/sdaX instead of /dev/hdaX.

    I managed to edit menu.lst using an old Ubuntu live CD(6.04, wich lists my partitions as /dev/hdaX), and I replaced the following:

    Code:
    root=/dev/disk/by-uuid/310147a9........ ro quiet splash
    
    for
    
    root=/dev/sda3 ro quiet splash
    And all I have now is the same old message but with a different drive:

    Code:
    check root ) bootarg ca /proc/cmdline....
    ALERT! /dev/sda3 does not exist. Dropping to a shell!
    
    *(initframs)
    Any ideas will be appreciated.

    Thanks in advance.

  2. #2
    Join Date
    Jun 2007
    Beans
    12

    Re: cannot boot after upgrading to 8.04

    bump

  3. #3
    Join Date
    Jun 2007
    Beans
    12

    Re: cannot boot after upgrading to 8.04

    I fixed it by adding all_generic_ide to /boot/grub/menu.lst.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •