Results 1 to 8 of 8

Thread: Running Warcraft 3 in Full Screen Mode?

  1. #1
    Join Date
    Apr 2009
    Beans
    2

    Running Warcraft 3 in Full Screen Mode?

    Hi guys, I'm sorry I know this has been discussed before (without success I've noticed from the other threads) but I'm just wondering if anyone knows how to get Warcraft 3 to run in full screen mode using Wine?

    Here is an image of what is happening when I run the game:
    http://imgur.com/1o0e.png

    Essentially, when I am in-game and I try to pan around the map by moving my mouse to the corners of the screen, the mouse leaves the game window and moves onto the desktop, which kills the gameplay.

    I am running the version 1.1.19 of Wine. I am running Ubuntu version 9.04.
    I have tried configuring Wine to run in a virtual desktop which does not work, as well as having it not run in a virtual desktop.

    I have a nVidia Geforce Go 6100 in my laptop, and currently have the nVidia accelerated graphics driver version 180 installed and working.

    The only problem with the game is that it won't run full screen. I've also tried simply switching the game to another workspace to see if it runs full screen, but it does not.

    Anyways, if anyone can help me out here I'd greatly appreciate it.

    Thanks.

  2. #2
    Join Date
    Aug 2006
    Location
    tuesday
    Beans
    6,502
    Distro
    Kubuntu Development Release

    Re: Running Warcraft 3 in Full Screen Mode?

    Have you tried turning off desktop effects?

  3. #3
    Join Date
    Apr 2009
    Beans
    2

    Re: Running Warcraft 3 in Full Screen Mode?

    Hey, that fixed it. Thank you very much.

  4. #4
    Join Date
    Feb 2008
    Beans
    340

    Re: Running Warcraft 3 in Full Screen Mode?

    Wow.. that fixed it? You didn't do anything extra? :O
    Mine doesn't run full screen either, and no effects doesn't help.

    Do I need to run it with opengl to get full screen? and if so, how is that possible? :O

    TFC

  5. #5
    Join Date
    Dec 2006
    Beans
    163
    Distro
    Xubuntu 9.04 Jaunty Jackalope

    Re: Running Warcraft 3 in Full Screen Mode?

    Quote Originally Posted by hungryOrb View Post
    Wow.. that fixed it? You didn't do anything extra? :O
    Mine doesn't run full screen either, and no effects doesn't help.

    Do I need to run it with opengl to get full screen? and if so, how is that possible? :O

    TFC
    Just tack on --opengl at the end of it.
    If I helped you, and you still need more help, free free to contact me on AIM. My Xfire is elitehak.

  6. #6
    Join Date
    Feb 2008
    Beans
    340

    Re: Running Warcraft 3 in Full Screen Mode?

    thanks! didn't get the full screen though.. waaa

  7. #7
    Join Date
    Sep 2007
    Location
    Warsaw, Poland
    Beans
    629
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Running Warcraft 3 in Full Screen Mode?

    Quote Originally Posted by noob_penguin View Post
    Hi guys, I'm sorry I know this has been discussed before (without success I've noticed from the other threads) but I'm just wondering if anyone knows how to get Warcraft 3 to run in full screen mode using Wine?

    Here is an image of what is happening when I run the game:
    http://imgur.com/1o0e.png

    Essentially, when I am in-game and I try to pan around the map by moving my mouse to the corners of the screen, the mouse leaves the game window and moves onto the desktop, which kills the gameplay.

    I am running the version 1.1.19 of Wine. I am running Ubuntu version 9.04.
    I have tried configuring Wine to run in a virtual desktop which does not work, as well as having it not run in a virtual desktop.

    I have a nVidia Geforce Go 6100 in my laptop, and currently have the nVidia accelerated graphics driver version 180 installed and working.

    The only problem with the game is that it won't run full screen. I've also tried simply switching the game to another workspace to see if it runs full screen, but it does not.

    Anyways, if anyone can help me out here I'd greatly appreciate it.

    Thanks.
    I have found the solution. Install compiz settings manager:

    sudo apt-get install compizconfig-settings-manager
    Go into Compiz Settings, then Workarounds and enable Legacy Fullscreen Support.

  8. #8
    Join Date
    Feb 2007
    Location
    Auckland, New Zealand
    Beans
    36

    Re: Running Warcraft 3 in Full Screen Mode?

    I found a solution from Dimitar Boichev which I have blogged on at Full-screen Warcraft under Wine. The solution involves X windows and may have performance benefits as well.

    Here is what worked for me (minor changes from what Dimitar did):

    Code:
    sudo gedit /etc/X11/Xwrapper.config
    Change:

    Code:
    allowed_users=console
    to
    Code:
    allowed_users=anybody
    Then save and quit.

    Applications>Wine>Configure Wine select the game you want under applications and then, under Graphics, make sure you untick “Emulate a virtual desktop”.

    I also copied /etc/X11/xorg.conf as /etc/X11/only_one_monitor.conf so that I could handle my dual monitor setup by playing Warcraft full-screen in one monitor only. I needed to change:

    Code:
    "TwinView" "1"
    to
    Code:
    "TwinView" "0"
    i.e. turn dual (twin) view off

    Then I created a bash script with the following content (NB to use your username and the correct path to your game) and saved it to my desktop:

    Code:
    #!/bin/bash
    X :2 -ac -terminate -config only_one_monitor.conf & sleep 2
    DISPLAY=:2 nice -20 env WINEPREFIX="/home/username/.wine" wine "c:\Program Files\Warcraft III\Warcraft III.exe"
    Then make the bash script executable (under the file’s Properties>Permissions>Execute - tick the tickbox). Double click it and select run to enjoy full-screen Warcraft etc.

    Ctrl+Alt+F7 and Ctrl+Alt+F9 lets you switch between X windows.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •