Page 4 of 4 FirstFirst ... 234
Results 31 to 35 of 35

Thread: PPTP VPN in Jaunty and Intrepid

  1. #31
    Join Date
    May 2008
    Location
    Tokyo
    Beans
    77
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: PPTP VPN in Jaunty and Intrepid

    Quote Originally Posted by Lucky. View Post
    Hey thanks for the post. I'm using Jaunty Desktop, and this information combined with the tutorials on the PPTP client website got me up and going.

    Once again for the record, I'm on Jaunty, and connecting to a Windows 2003 Server VPN.

    After reading through the tutorials of configuring things manually, I got a better feel for the settings I needed in the GUI. I tried them out, and...bam, they worked! Network manager with the PPTP client worked great. Tried it a million times before to no avail. But now it works good, with no need to manually configure stuff. Weird.

    My notes are as follows:

    1. Add a PPTP connection with network manager.

    2. When it comes to typing your username, simply type your username. Don't worry about DOMAIN\USERNAME. Just type the username.

    3. For the domain name, type in the domain name. No slashes or anything crazy.

    4. Click Advanced. Leave all the authentication methods checked, but uncheck EAP.

    5. Check “Use Point-to-Point encryption”.

    6. Connect!

    7. The DNS works fine, but you need to use the fully qualified domain name to get to stuff on the VPN side. For example to remote desktop into my remote computer in the VPN LAN, in Windows XP I could just connect to "mycomputer". In Ubuntu, it's "mycomputer.mydomain.anypossibleotherstuff.bla h"

    It just seems strange that all of this suddenly works now...A few things on my mind about this:

    1. Following your instructions, I tweaked around a number of files in /etc/ppp while doing things manually, so perhaps these led to network manager "appearing" to be working now (since it's fixed under the hood?). I tried putting everything back the way it was, but who knows...maybe I didn't.

    2. I seemed to notice issues while logged in under my normal account. I'd configure a connection, and it wouldn't work. Then I'd change stuff, and it still wouldn't work. Then I'd delete the connection altogether, but it would still appear on the drop down list (Not the configuration list, but the quick-connect list). Sometimes new connections wouldn't show up on the drop-down list. Made me wonder whether things were getting saved correctly. I've noticed some other Jaunty desktop problems that were a result of not being logged in as root, so I logged in as root to ensure my configuration changes were being saved. This seemed to work. Of course I couldn't duplicate the problem after the fact, so maybe root has nothing to do with it, and I finally just got my settings correct.

    I'm going to reformat tomorrow and try these settings out with a fresh install of Jaunty. I'll report back and let you know if it all just "works" with pure GUI.
    Cheers mate, followed the steps above and got VPN working through the GUI with no tweaking.

  2. #32
    Join Date
    Feb 2009
    Beans
    16

    Re: PPTP VPN in Jaunty and Intrepid

    karmic:

    tried gui version fails.

    Tested out cli, but before mucking with routes, i tried to bring up the vpn, and i didn't even get an ip from the vpn, is that normal? I gave up at that point.

    Hints? This is killing me. I've also puttered with my mac to try and get that to connect, since i really need to get to the vpn for a project.

  3. #33
    Join Date
    Feb 2009
    Beans
    16

    Re: PPTP VPN in Jaunty and Intrepid

    Ok, so when I config the network manager(latest from truck to fix the issue where it doesn't preserve settings) on karmic with the following settings

    gateway:set
    username/password set and keep
    no nt domain

    -adv-settings:
    use pptp/allow stateful
    that forces only mschap/chapv2

    nothing else set

    I get the following log:
    Code:
    VPN connection 'Cloud' (IP Config Get) reply received.
    Jan 24 12:40:01 johannt61p NetworkManager: <info>  VPN Gateway: --ip removed-
    Jan 24 12:40:01 johannt61p NetworkManager: <info>  Tunnel Device: ppp0
    Jan 24 12:40:01 johannt61p NetworkManager: <info>  Internal IP4 Address: 172.16.8.52
    Jan 24 12:40:01 johannt61p NetworkManager: <info>  Internal IP4 Prefix: 32
    Jan 24 12:40:01 johannt61p NetworkManager: <info>  Internal IP4 Point-to-Point Address: 172.16.8.2
    Jan 24 12:40:01 johannt61p NetworkManager: <info>  Maximum Segment Size (MSS): 0
    Jan 24 12:40:01 johannt61p NetworkManager: <info>  Internal IP4 DNS: 172.16.0.2
    Jan 24 12:40:01 johannt61p NetworkManager: <info>  Internal IP4 DNS: 172.16.0.3
    Jan 24 12:40:01 johannt61p NetworkManager: <info>  DNS Domain: '(none)'
    Jan 24 12:40:01 johannt61p NetworkManager: <info>  Login Banner:
    Jan 24 12:40:01 johannt61p NetworkManager: <info>  -----------------------------------------
    Jan 24 12:40:01 johannt61p NetworkManager: <info>  (null)
    Jan 24 12:40:01 johannt61p NetworkManager: <info>  -----------------------------------------
    Jan 24 12:40:02 johannt61p NetworkManager: <info>  VPN connection 'Cloud' (IP Config Get) complete.
    Jan 24 12:40:02 johannt61p NetworkManager: <info>  Policy set 'Cloud' (ppp0) as default for routing and DNS.
    Jan 24 12:40:02 johannt61p NetworkManager: <info>  VPN plugin state changed: 4
    Jan 24 12:40:02 johannt61p nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/01ifupdown' exited with error status 1.
    I dug up this thread:
    http://ubuntuforums.org/showthread.php?t=979001 and tried adding a executable script to /etc/ppp/ip-up.d/
    with modified mtu settings which made no difference

    When I follow the script version of this, I get the following log:
    Code:
    CPlugin-Ifupdown: devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
    Jan 24 12:48:35 johannt61p NetworkManager:    SCPlugin-Ifupdown: device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found.
    Jan 24 12:49:07 johannt61p NetworkManager:    SCPlugin-Ifupdown: devices removed (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
    and this in messages
    Code:
    Connect: ppp0 <--> /dev/pts/4
    Jan 23 08:10:02 johannt61p pppd[15729]: LCP: timeout sending Config-Requests
    Jan 23 08:10:02 johannt61p pppd[15729]: Connection terminated.
    I didn't configured the routes via cli as when i tested and didn't see ppp0 getting a 172.*.*.* ip, i assumed it wasn't making the connection.

    Also this file /etc/ppp/chap-secrets, i assume the "Password" there is the password to authenticate to the pptp? not the word "Password"?


    Thanks!

  4. #34
    Join Date
    Dec 2007
    Beans
    61

    Re: PPTP VPN in Jaunty and Intrepid

    I've got a problem with PPTP VPN with multiple user login: some users are receiving the same IP and they are disconnected

    Has someone the same problem?

    I have in pptpd.conf

    localip 10.1.1.45
    remoteip 10.1.1.180,10.1.1.181,10.1.1.182,10.1.1.183,10.1.1 .184,10.1.1.185

    I've tried with the remote ip by writing a range, but still not working well,some users are receiving the same IP.

  5. #35
    Join Date
    Dec 2007
    Beans
    61

    Re: PPTP VPN in Jaunty and Intrepid

    And, another problem I have: sometimes, from time to time, interface ppp0 is missing when I ifconfig the interfaces!

Page 4 of 4 FirstFirst ... 234

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •