Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 35

Thread: PPTP VPN in Jaunty and Intrepid

  1. #21
    Join Date
    May 2009
    Beans
    1

    Re: PPTP VPN in Jaunty and Intrepid

    Quote Originally Posted by area124 View Post
    This has worked for me in jaunty. I had my VPN for work set up and working,
    but all traffic was going though the VPN. I used the following procedure.

    I used the network manager in the upper right hand corner of my desktop.
    Click on "VPN Connections", then "Configure VPN..."
    In the Network Connections window, select your VPN Connection and then click
    the "Edit" button.
    In the "Editing Your_VPN PPTP" window, click on the "IPv4 Settings" and then the "Routes..." button.
    In the "Editing IPv4 routes...." window, check the box for "Use this
    connection only for resources on its network".
    Now click the "Add" button. Note, this kind of works a little funny. as I
    added the Address/Netmask/Gateway information I had to click each box as it
    seemed to loose the curser position. In my case I work address were in the
    XXX.YYY.0.0 range so I used a netmask of 255.255.0.0. I set the Gateway to
    my local router which is 192.168.1.1 (pretty standard). I also used the
    value "1" for the Metric. I had to click the "Add" button. This was the
    only way I could get it to take.

    Here was another little tip. While attempting to use this GUI I ended up
    with several empty routes by accident. The GUI would not let me click on
    "OK" until I deleted all the empty routes. Just try clicking below your
    last route. If you are able to make a selection, you have an empty route.
    Just click the "Delete" button and you should be good.
    Click on "OK", then "Apply", then "Close". Now test your VPN and see if
    it works any better.

    I use "http://www.speakeasy.net/speedtest/" to test my bandwidth before
    and after. My connection though my work VPN is really slow. Using the
    above web site very clearly indicated that all my non-work traffic was no
    longer going over my work VPN.

    I hope that this is helpful for some of you.
    Good luck!
    Thanks! This worked great for me

  2. #22
    Join Date
    Jun 2009
    Beans
    1

    Re: PPTP VPN in Jaunty and Intrepid

    I followed the steps suggested by area124 and it works for about 10 seconds and then I start receiving 100% packet loss over the vpn and to the internet. Anyone have any ideas?

    'Ignore automatically obtained routes' is unchecked.
    'Use this connection only for resources on its network' is checked.

    In the routes listing I have the following:

    address / netmask / gateway /metric
    10.10.0.0 / 255.255.0.0 / 192.168.1.1 / 1

    Again, this works perfectly for about 10 seconds but then the packet loss kicks in and nothing works.

    Any suggestions?

  3. #23
    Join Date
    May 2006
    Beans
    131

    Re: PPTP VPN in Jaunty and Intrepid

    Hey thanks for the post. I'm using Jaunty Desktop, and this information combined with the tutorials on the PPTP client website got me up and going.

    Once again for the record, I'm on Jaunty, and connecting to a Windows 2003 Server VPN.

    After reading through the tutorials of configuring things manually, I got a better feel for the settings I needed in the GUI. I tried them out, and...bam, they worked! Network manager with the PPTP client worked great. Tried it a million times before to no avail. But now it works good, with no need to manually configure stuff. Weird.

    My notes are as follows:

    1. Add a PPTP connection with network manager.

    2. When it comes to typing your username, simply type your username. Don't worry about DOMAIN\USERNAME. Just type the username.

    3. For the domain name, type in the domain name. No slashes or anything crazy.

    4. Click Advanced. Leave all the authentication methods checked, but uncheck EAP.

    5. Check “Use Point-to-Point encryption”.

    6. Connect!

    7. The DNS works fine, but you need to use the fully qualified domain name to get to stuff on the VPN side. For example to remote desktop into my remote computer in the VPN LAN, in Windows XP I could just connect to "mycomputer". In Ubuntu, it's "mycomputer.mydomain.anypossibleotherstuff.bla h"

    It just seems strange that all of this suddenly works now...A few things on my mind about this:

    1. Following your instructions, I tweaked around a number of files in /etc/ppp while doing things manually, so perhaps these led to network manager "appearing" to be working now (since it's fixed under the hood?). I tried putting everything back the way it was, but who knows...maybe I didn't.

    2. I seemed to notice issues while logged in under my normal account. I'd configure a connection, and it wouldn't work. Then I'd change stuff, and it still wouldn't work. Then I'd delete the connection altogether, but it would still appear on the drop down list (Not the configuration list, but the quick-connect list). Sometimes new connections wouldn't show up on the drop-down list. Made me wonder whether things were getting saved correctly. I've noticed some other Jaunty desktop problems that were a result of not being logged in as root, so I logged in as root to ensure my configuration changes were being saved. This seemed to work. Of course I couldn't duplicate the problem after the fact, so maybe root has nothing to do with it, and I finally just got my settings correct.

    I'm going to reformat tomorrow and try these settings out with a fresh install of Jaunty. I'll report back and let you know if it all just "works" with pure GUI.

  4. #24
    Join Date
    May 2006
    Beans
    131

    Re: PPTP VPN in Jaunty and Intrepid

    Sorry it took a few days longer, but indeed it does work purely with network manager and no extra work. The settings I listed get the job done for a Windows 2003 Server VPN.

    Yay!

  5. #25
    Join Date
    Nov 2006
    Location
    Kalmar
    Beans
    17
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: PPTP VPN in Jaunty and Intrepid

    Quote Originally Posted by virkang View Post
    Hi everyone,

    I found a way to make it work in Jaunty (at least for me ...).
    - When you configure the VPN connexion, go to the "advanced" settings"
    - Uncheck "EAP" at the top
    - check the "mppe" parameter
    - Try to connect to your microsoft VPN server, i should work now

    I hope this trick will help you out there ...
    Thank you so much for this tip! I had almost lost hope of getting my vpn connection to work again

  6. #26
    Join Date
    May 2009
    Location
    South Africa
    Beans
    98
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: PPTP VPN in Jaunty and Intrepid

    When I go to VPN connections >Configure VPN and select the VPN connection to edit in network manager applet in Jaunty, I don't see the "Advanced settings" option everyone keeps mentioning in order to change EAP, MMPE settings etc.

    WHAT AM I MISSING HERE?

  7. #27
    Join Date
    May 2009
    Location
    South Africa
    Beans
    98
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: PPTP VPN in Jaunty and Intrepid

    Aaaaah...following on from previous message, I was adding a new VPN connection using the "Cisco compatible" option, not PPT. Duh!

  8. #28
    Join Date
    Feb 2007
    Beans
    164
    Distro
    Ubuntu 6.10 Edgy

    Re: PPTP VPN in Jaunty and Intrepid

    Quote Originally Posted by virkang View Post
    Hi everyone,

    I found a way to make it work in Jaunty (at least for me ...).
    - When you configure the VPN connexion, go to the "advanced" settings"
    - Uncheck "EAP" at the top
    - check the "mppe" parameter
    - Try to connect to your microsoft VPN server, i should work now

    I hope this trick will help you out there ...
    Thanks so much this did the trick. Also for me if anyone else is like I was: You need to make sure under the VPN tab that 'Available to all users' is NOT checked. This made weird errors for me that removed all authentication information and wouldnt connect.

    I also have to agree with the above poster that stated this was just sad. A simple pptp VPN connection should NOT be hard to configure. I know pptp is an MS thing but it's still pretty common.
    I pronounce You-Buntu however I want.

  9. #29
    Join Date
    May 2007
    Beans
    59

    Re: PPTP VPN in Jaunty and Intrepid

    Quote Originally Posted by SabreWolfy View Post
    This worked for me. Use at your own risk. YMMV. Edit: See post #4 below for an important update to this post ...

    I've bleated previously here and on Launchpad about how PPTP VPN worked perfectly under Hardy and was broken under Intrepid and Jaunty. For me, this was a "deal-breaker" because I need PPTP VPN access. I have not upgraded my desktop Hardy machine for this reason. I did upgrade my laptop to Intrepid and now to Jaunty and got around the problem by using PPTP VPN in a Xubuntu Hardy VirtualBox.

    I've spent the evening looking at this again and I've managed to get PPTP VPN working on my Jaunty laptop. I'm not a PPTP or VPN expert by any means.

    I used this post as starting point, so thanks to kryptoz. The problem as I can see it is that Network Manager 0.7 (Intrepid and Jaunty) and the associated PPTP plugin are broken. Under Hardy (Network Manager 0.6.6) everything works. There are many posts detailing the myriad problems with Network Manager 0.7. However, using the Network Manager applet is simply a front-end to calling PPTP and PPPD which actually make the connection (I think).

    My solution does not involve the Network Manager applet at all. The connection is established by calling PPPD. The pptp-linux and ppp (for pppd) package must be installed and the pptpd package as well (I think).

    1. Add the following to /etc/ppp/chap-secrets:

    Code:
    Username   PPTP   Password   *
    2. Create /etc/ppp/peers/vpn1. The 'peers' folder may be owned by group 'dip' so get around that by adding yourself to the group (I have no idea if this is a good solution, but it worked). Add the following to the vpn1 file:

    Code:
    pty "pptp remote.gateway.address.here  --nolaunchpppd"
    name Username
    remotename PPTP
    require-mppe-128
    file /etc/ppp/options.pptp
    ipparam vpn1
    3. Edit the options.pptp file as required. I commented out the 'refuse-chap' and 'refuse-mschap-v2' lines.

    4. Establish the VPN connection with:

    Code:
    sudo pppd call vpn1
    or

    Code:
    sudo pon vpn1
    5. Drop the connection when you're done with:

    Code:
    sudo poff vpn1
    That establishes a VPN connection but I could not get any traffic through it. Therefore, create '/etc/ppp/ip-up.d/route-traffic' as follows. I don't know why the file needs to have that name or be located in that folder, because it does not appear to be executed automatically. Thanks to this site for this information:

    Code:
    #!/bin/bash
    NET="10.0.0.0/8"
    IFACE="ppp0"
    route add -net ${NET} dev ${IFACE}
    Make the file executable.

    Replace the "10.0...." address with the range of addresses you need to access on your remote machine. For me, this was the same range as that which I originally included when setting the VPN up in Hardy. It may look like "10.2.0.0/16" for example. The values don't have to be in the "10" range (mine were not).

    So, to get the VPN up in Jaunty, I did the following (in /etc/ppp/ip-up.d):

    Code:
    sudo pon vpn1
    sudo ./route-traffic
    Edit: See post #4 below for an important update to this post ...
    Thanks a lot to sabrewolfy for this nice solution, I've got it working fine ONLY after I used this method, all the other methods I've found around didn't get me connected to my MS VPN until I tried this one!

    I allowed myself to improve it a little bit adding some more custom stuff for it to be easier to work, always following the example given on the original howto.

    For a person like me, that has a lot of routings to be set to the VPN connection it can be a little tedious to do NET1, NET2, NET3 .... NET20!
    and then a command for each one, so I used an array where all I need is to put every net I want to route, and to change it is as simple as adding or removing a line from the array, always keeping the same format.
    So here's the routing script
    This is the routing script I've wrote
    Create '/etc/ppp/ip-up.d/route-traffic'
    Code:
    gksu gedit /etc/ppp/ip-up.d/route-traffic
    Paste this code and save the file
    Code:
    #!/bin/bash
    IFACE="ppp0"
    NETWORKS=(
    "10.1.0.0/24"
    "10.2.0.0/24"
    "10.3.0.0/24"
    "192.168.123.0/24"
    )
    
    for NET in "${NETWORKS[@]}"
    do
      route add -net $NET dev $IFACE
    done
    
    exit 0
    Make it executable
    Code:
    sudo chmod +x /etc/ppp/ip-up.d/route-traffic
    I've also created a "on/off toggle" script that will connect to the VPN if is disconnected and disconnect if connected.
    Create the file '/usr/local/bin/vpn1'
    Code:
    gksu gedit /usr/local/bin/vpn1
    Paste the following code and save the file
    Code:
    #!/bin/bash
    
    VPN=vpn1
    
    if [ ! "$(pidof pppd)" ]
    then
      sudo pon $VPN
      zenity --info --text="Connected to $VPN" --no-wrap
    else
      sudo poff $VPN
      zenity --info --text="Disconnected from $VPN" --no-wrap
    fi
    Make it executable
    Code:
    sudo chmod +x /usr/local/bin/vpn1
    Now you can create a launcher on desktop if you like, right click on desktop then "Create Launcher"
    Fill the fields as shown here:

    Chose any icon you want and save it.
    Now you'll be able to double click on the desktop icon to connect/disconnect from the VPN
    Hope this helps
    Ziv
    Attached Images Attached Images
    Last edited by zivley; September 26th, 2009 at 10:23 AM.

  10. #30
    Join Date
    Apr 2008
    Beans
    275
    Distro
    Ubuntu 10.04 Lucid Lynx

    Wink Re: PPTP VPN in Jaunty and Intrepid

    Quote Originally Posted by zivley View Post
    <snip>
    @zivley: I'm glad it worked you and thanks for the improvements, especially the last section!
    Last edited by SabreWolfy; August 12th, 2009 at 10:28 PM.

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •