Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Can't upgrade ATI Radeon x1600 drivers

  1. #11
    Join Date
    Apr 2009
    Beans
    37

    Re: Can't upgrade ATI Radeon x1600 drivers

    Yes, because it doesn't let me take advantage of the money I paid for a 256 meg video card. (which at the time, wasn't cheap). Even moving a window in ubuntu had bad graphics on my system

  2. #12
    Join Date
    Oct 2006
    Location
    Pennsylvania
    Beans
    917

    Re: Can't upgrade ATI Radeon x1600 drivers

    Quote Originally Posted by burvowski View Post
    Yeah, it's like Ubuntu took a step backward for us ATI card users, which have to be a pretty sizable chunk. I've heard that the open source drivers are expected to be improved by the end of summer, though, so my fingers are crossed for that. I really did love Ubuntu for the few days I got to try it and would drop OS X and Windows with no hesitation to use it.
    The problem doesn't lie on Ubuntu, it's a fault of ATI for getting rid of support for their cards. In order for Ubuntu to use the newest X Server, it had to include Catalyst 9.4, which drops support for a bunch of cards.

    http://support.amd.com/us/gpudownloa...9&lang=English
    AMD has moved a number of DX9 ATI Radeon™ graphics accelerators products to a legacy driver support structure. This change impacts Windows XP, Windows Vista, and Linux distributions. AMD has moved to a legacy software support structure for these graphics accelerator products in an effort to better focus development resources on future products.

    The following products have been moved to the legacy software support structure (including Mobile and All-in-Wonder Variants):

    ATI Radeon 9500 Series
    ATI Radeon 9550 Series
    ATI Radeon 9600 Series
    ATI Radeon 9700 Series
    ATI Radeon 9800 Series
    ATI Radeon X300 Series
    ATI Radeon X550 Series
    ATI Radeon X600 Series
    ATI Radeon X700 Series
    ATI Radeon X800 Series
    ATI Radeon X850 Series
    ATI Radeon X1050 Series
    ATI Radeon X1300 Series
    ATI Radeon X1550 Series
    ATI Radeon X1600 Series
    ATI Radeon X1650 Series
    ATI Radeon X1800 Series
    ATI Radeon X1900 Series
    ATI Radeon Xpress Series
    ATI Radeon X1200 Series
    ATI Radeon X1250 Series
    ATI Radeon X2100 Series
    I know your pain because I have an X1600 in my laptop and I can't simply upgrade. Fortunately, the open-source driver, radeonhd, is moving at a quick development base and already has some very basic 3D support. I'd expect that in a year or two it should be usable enough to play 3D games with it. In the meantime, you can keep a copy of 8.04 or 8.10 loaded on your computer or just boot into Windows when you need to play a game.

  3. #13
    Join Date
    May 2008
    Beans
    4

    Unhappy Re: Can't upgrade ATI Radeon x1600 drivers

    This is pretty lame

  4. #14
    Join Date
    Apr 2007
    Location
    Hongkong
    Beans
    23
    Distro
    Lubuntu 14.04 Trusty Tahr

    Red face Re: Can't upgrade ATI Radeon x1600 drivers

    Quote Originally Posted by cyberdork33 View Post
    is the open source driver really that bad? I haven't had any issues with it...
    The open source driver does have a few issue for me, despite my games are not really demanding in graphics.

    I used to play civilization 4 (and all expansions) on Wine. After upgrading to 9.04, the game is no longer playable. I can view the menu but not the actual game.

    I am using X1250 chipset, but that is not much difference.

  5. #15
    Join Date
    Apr 2009
    Beans
    37

    Re: Can't upgrade ATI Radeon x1600 drivers

    Does anyone know where I can get a live cd download of 8.04?

    This link http://releases.ubuntu.com/8.10/ does not work for me.

    edit: nevermind, i found it
    Last edited by burvowski; April 27th, 2009 at 05:03 AM.

  6. #16
    Join Date
    Oct 2005
    Location
    Belgium
    Beans
    249
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Can't upgrade ATI Radeon x1600 drivers

    Can anyone tell me if compiz and video accelleration work properly with the FOSS drivers? I don't care about 3D games on this box (this is a work box), but decent compiz is really something I need for productivity and stuff.

    I have a x1600 card, btw.

  7. #17
    Join Date
    Aug 2005
    Location
    Huntsville, AL, USA
    Beans
    7,526
    Distro
    Ubuntu

    Re: Can't upgrade ATI Radeon x1600 drivers

    Quote Originally Posted by Jonne View Post
    Can anyone tell me if compiz and video accelleration work properly with the FOSS drivers? I don't care about 3D games on this box (this is a work box), but decent compiz is really something I need for productivity and stuff.

    I have a x1600 card, btw.
    it works fine on my iMac

  8. #18
    Join Date
    May 2009
    Location
    Spain
    Beans
    2
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Can't upgrade ATI Radeon x1600 drivers

    Does anyone know how to activate the extended desktop (using 2 screens), without the flgrx driver?

  9. #19
    Join Date
    Aug 2005
    Location
    Huntsville, AL, USA
    Beans
    7,526
    Distro
    Ubuntu

    Re: Can't upgrade ATI Radeon x1600 drivers

    Quote Originally Posted by Hakrabim View Post
    Does anyone know how to activate the extended desktop (using 2 screens), without the flgrx driver?
    you should be able to go to System > Preferences > Display

  10. #20
    Join Date
    May 2009
    Location
    Spain
    Beans
    2
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Can't upgrade ATI Radeon x1600 drivers

    Thanks for your answer.

    I tried that, the problem is that if I try to start ubuntu with the S-video cable conected, both of the displays will appear blank; and if I try to plug it afterwards ubuntu will not detect the second screen.

    Any ideas?

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •