Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: oh why does ubuntu hate my resolution

  1. #1
    Join Date
    Jul 2007
    Location
    Tempe, Arizona
    Beans
    409
    Distro
    Ubuntu 9.10 Karmic Koala

    oh why does ubuntu hate my resolution

    I'm sort of frustrated... so if my posts sound condescending, I don't mean to. It's just that ever since I got this graphics card, 8.10 and 9.04 decide to hate me and never give me the resolution I want. And when they do give me the resolution I want, they always throw a fit and give me problems.

    I'm sorry for not doing a comprehensive search on this. The whole nvidia thing has changed since 8.04 especially with the emphasis on the new xservers to not rely on the xorg.conf. I don't want to do any outdated fixes for my problem.

    Details:
    Video card: nVidia GeForce 9500GT
    Resolution desired: 1680x1050
    Version of Ubuntu: 9.04 32-bit
    nVidia driver installed: 180.44
    Problem: I can get 1360x768 (very distorted), 1152x864 (workable, this is the resolution I'm using), 1024x768, and other resolutions that are irrelevant. I can't find a way to manually tell Ubuntu that I want a resolution of 1680x1050; I edited the xorg.conf, but the usual Ctrl+Alt+Backspace to kill the xserver and restart it didn't work.

    Help?

    Thanks.

  2. #2
    Join Date
    May 2007
    Location
    UK near Bedford
    Beans
    3,475
    Distro
    Ubuntu Development Release

    Re: oh why does ubuntu hate my resolution

    Xorg is now sort of redundant.

    It sounds like it does not identify your screen as a wide screen and so is applying the wrong format.
    PC

    To get a terminal command to put its output into a file use this format
    {terminal command} > {filename}

  3. #3
    Join Date
    May 2007
    Location
    UK near Bedford
    Beans
    3,475
    Distro
    Ubuntu Development Release

    Re: oh why does ubuntu hate my resolution

    In System->administration do you see the nvidia setting application.

    If not try installing it (use synaptic)
    PC

    To get a terminal command to put its output into a file use this format
    {terminal command} > {filename}

  4. #4
    Join Date
    Jul 2007
    Location
    Tempe, Arizona
    Beans
    409
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: oh why does ubuntu hate my resolution

    Yeah I think you're right. Unfortunately I'm looking around and I don't see a solution. I was really looking forward to Ubuntu too... oh well.

  5. #5
    Join Date
    Oct 2005
    Location
    UK
    Beans
    1,026
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: oh why does ubuntu hate my resolution

    http://ubuntuforums.org/showthread.php?t=977798
    post 5 might help.
    Is your nvidia driver being 'used' ?
    Have you read the xorg log to see what is happening ?

    Is the card supported by the driver you are using?

  6. #6
    Join Date
    Sep 2008
    Location
    Philadelphia, PA
    Beans
    5,192
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: oh why does ubuntu hate my resolution

    Quote Originally Posted by akiratheoni View Post
    Yeah I think you're right. Unfortunately I'm looking around and I don't see a solution. I was really looking forward to Ubuntu too... oh well.
    Do as peter09 said. Use Synaptic to install nividia-settings. I had the same problem when I got my new Acer widescreen. Ubuntu didn't recognize it, but once I installed the above all was fine. Sounds like a trivial reason to give up on Ubuntu, especially if you don't try the solution suggested. Unless you already have your mind made up!
    Multi-boot: Arch linux, Ubuntu 12.04, Windows 7 & Windows 8

  7. #7
    Join Date
    Jul 2007
    Location
    Tempe, Arizona
    Beans
    409
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: oh why does ubuntu hate my resolution

    @Peter09: I didn't see your post, I guess we posted at the same time. The nVidia settings is in System -> Administration. The problem is that while I can choose different resolutions, widescreen resolutions don't appear.

    I also added the thing to the xorg.conf... but the traditional Ctrl+Alt+Backspace to kill the xserver isn't working. How do I restart the xserver?

  8. #8
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    5,409
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: oh why does ubuntu hate my resolution

    Normally, resolution problems are caused by one of the monitor, the graphics card, or the graphics driver not passing the EDID information to X that lets it automatically set the correct refresh rate, and so it defaults to really low values that won't damage any monitors. You can manually set the values for your monitor by putting the VertRefresh and HorizSync ranges in your xorg.conf. You should be able to get these numbers from the manual or specifications for your monitor. These values go in the "Monitor" Section of xorg.conf.

    You can edit xorg.conf with
    Code:
    sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
    gksudo gedit /etc/X11/xorg.conf
    Code:
    Section "Monitor"
            Identifier      "Configured Monitor"
            HorizSync       aa-bb
            VertRefresh     cc-dd
    EndSection
    You'll need to replace aa-dd with the values for your monitor.


    Quote Originally Posted by akiratheoni View Post
    I edited the xorg.conf, but the usual Ctrl+Alt+Backspace to kill the xserver and restart it didn't work.
    They disabled Ctrl-Alt-Backspace, because apparently new users kept pressing it by accident. It's pretty easy to turn it back on, but logging into a virtual console and running
    Code:
    sudo /etc/init.d/gdm stop
    sudo /etc/init.d/gdm start
    will probably do.
    None but ourselves can free our minds

  9. #9
    Join Date
    Apr 2008
    Beans
    138
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: oh why does ubuntu hate my resolution

    The Ctrl+Alt+Backspace combo has been disabled in Jaunty, if that's what you're using now (sidebar still says Hardy).

    You can logout and login in to restart x as well.

  10. #10
    Join Date
    Apr 2009
    Location
    Burnham, England
    Beans
    48
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: oh why does ubuntu hate my resolution

    Hello there, I hope I am not offending protocol by putting this here. I have been trying to get twinview configured, and, looking at this thread thought I had the answer. I found and installed the Nvidia X server settings tool and installed it, and got twinview working - sort of - but when I selected the Save to X configuration file I get an error message "Unable to remove old X config backup file '/etc/X11/xorg.conf.backup'

    I created the backup file in an ill advised attempt at setting up twinview using nvidia.config, from the root terminal.

    Can anyone tell me what to do?

    Do I need to log on as root or administrator or whatever, and if so, how do I do that?

    Any advice would be very welcome!

    Barry

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •