Results 1 to 3 of 3

Thread: keyboard issue on login screen

  1. #1
    Join Date
    Oct 2008
    Location
    Cambridge, GB
    Beans
    57

    keyboard issue on login screen

    Hi all

    When i set up my ubuntu 9.04, i must have selected the wrong keyboard layout. Not to worry, preferences>keyboard>layouts>change layout>apply system-wide.... right?

    Wrong - my password has a # in it, but this is shift-3 on a USA keyboard setup, and has its own key on UK keyboards.

    The issue is i can't change the keyboard layout for the login screen - i got quite worried when i couldnt log in!

    How can i change keyboard layout for the login screen?
    Intel Core i7 950, XFX Radeon HD 6850 1GB, 6GB PC3-10600U, Windows 7 Pro x64, SyncMaster 2243SW, Dell E2210H; Intel Core 2 Quad Q9550, 8GB PC2-6400U, Windows Server 2008 running ADDS, File Services, DNS and DHCP

  2. #2
    Join Date
    Apr 2009
    Beans
    174
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: keyboard issue on login screen

    .
    Last edited by mprince; April 24th, 2009 at 03:02 AM.

  3. #3
    Join Date
    Apr 2009
    Beans
    174
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: keyboard issue on login screen

    Can you login at all? If so you could change the keyboard layout in xorg.
    Code:
    sudo gedit /etc/X11/xorg.conf

    Change this:
    Code:
    Option "XkbLayout" "us"

    To this:
    Code:
    Option "XkbLayout" "gb"

    You'd think it would be uk, but it's gb...
    Last edited by mprince; April 24th, 2009 at 03:03 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •