Page 3 of 8 FirstFirst 12345 ... LastLast
Results 21 to 30 of 79

Thread: cannot shutdown / reboot laptop on 9.04

  1. #21
    Join Date
    Jan 2009
    Beans
    3

    Re: cannot shutdown / reboot laptop on 9.04

    My Dell 1720 has the same problem on a fresh 9.04 64bit install.................

    ACPI=force acpi=off did not work..
    Last edited by Dallco; April 26th, 2009 at 07:00 AM.

  2. #22
    Join Date
    Aug 2007
    Beans
    26

    Re: cannot shutdown / reboot laptop on 9.04

    I was having the same problem. If the laptop's wireless card was "on" at shutdown, it would hang and I'd get that blinking cursor in the top left corner. If the laptop's wireless card was "off" at shutdown, no problems at all.

    So here's how I fixed it ...

    Abstract: Add a short script to the init.d directory that uses "modprobe -r" to remove the wireless driver. Then add symbolic links to that script in both rc0.d and rc6.d directories.

    Details:

    1. Open a terminal and become super-user (yeah, this is a bad security practice, but I'm too lazy to type sudo before everything).
    Code:
    su
    2. Navigate to the init.d directory.
    Code:
    cd /etc/init.d
    3. Touch and edit your new wireless shutdown script. I use "vi," but feel free to use "gedit" if you like.
    Code:
    vi killwlan
    4. Add line(s) that "modprobe -r" your wireless driver module(s). In MY case, I remove both "ipw3945" and "iwl3945" modules. In YOUR case, you'll need to find out the module names being used by your wireless device.
    Code:
    modprobe -r iwl3945
    modprobe -r ipw3945
    5. Save the script and exit the text editor.
    Code:
    [ESC] :wq [ENTER]
    6. Navigate to the rc0.d directory.
    Code:
    cd /etc/rc0.d
    7. Create a link to your killwlan script.
    Code:
    ln -sT /etc/init.d/killwlan S16killwlan
    8. Navigate to the rc6.d directory.
    Code:
    cd /etc/rc6.d
    9. Create a link to your killwlan script.
    Code:
    ln -sT /etc/init.d/killwlan S16killwlan
    10. Now try to shutdown or restart.
    Code:
    init 6
    This worked for me. If it works for you, great! If not, sorry for having wasted your time. Good luck!
    Last edited by hesapotman; April 26th, 2009 at 08:04 AM.

  3. #23
    Join Date
    Apr 2009
    Location
    Prague, Czech Republic
    Beans
    4
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: cannot shutdown / reboot laptop on 9.04

    Quote Originally Posted by hesapotman View Post
    I was having the same problem. If the laptop's wireless card was "on" at shutdown, it would hang and I'd get that blinking cursor in the top left corner. If the laptop's wireless card was "off" at shutdown, no problems at all.

    So here's how I fixed it ...

    Abstract: Add a short script to the init.d directory that uses "modprobe -r" to remove the wireless driver. Then add symbolic links to that script in both rc0.d and rc6.d directories.

    Details:

    1. Open a terminal and become super-user (yeah, this is a bad security practice, but I'm too lazy to type sudo before everything).
    Code:
    su
    2. Navigate to the init.d directory.
    Code:
    cd /etc/init.d
    3. Touch and edit your new wireless shutdown script. I use "vi," but feel free to use "gedit" if you like.
    Code:
    vi killwlan
    4. Add line(s) that "modprobe -r" your wireless driver module(s). In MY case, I remove both "ipw3945" and "iwl3945" modules. In YOUR case, you'll need to find out the module names being used by your wireless device.
    Code:
    modprobe -r iwl3945
    modprobe -r ipw3945
    5. Save the script and exit the text editor.
    Code:
    [ESC] :wq [ENTER]
    6. Navigate to the rc0.d directory.
    Code:
    cd /etc/rc0.d
    7. Create a link to your killwlan script.
    Code:
    ln -sT /etc/init.d/killwlan S16killwlan
    8. Navigate to the rc6.d directory.
    Code:
    cd /etc/rc6.d
    9. Create a link to your killwlan script.
    Code:
    ln -sT /etc/init.d/killwlan S16killwlan
    10. Now try to shutdown or restart.
    Code:
    init 6
    This worked for me. If it works for you, great! If not, sorry for having wasted your time. Good luck!

    Good point! When I turn off wifi manually (pressing the button for wifi card), I can reboot/shutdown perfectly. I tried your solution, with "iwlagn" and "iwlcore" instead of your modules, but it doesn't work. Maybe I cose wrong modules. Is there a way how I could find out exactly which modules are connected with wifi card?
    I tried "sudo lspci -v" and that gave me this:
    Code:
    ...
    05:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
        Subsystem: Intel Corporation Device 1301
        Flags: bus master, fast devsel, latency 0, IRQ 2296
        Memory at f9efe000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: [c8] Power Management version 0
        Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
        Capabilities: [e0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting <?>
        Capabilities: [140] Device Serial Number 12-6e-5d-ff-ff-ea-16-00
        Kernel driver in use: iwlagn
        Kernel modules: iwlagn
    ...
    Thanks for any advice.

    Edit: when i run "sudo modprobe -r iwlagn" manually before I actually click on shutdown, everything (I mean shutdown/reboot) works fine, so i expect my problem to be the location and linking of the script. I'll play around for a while and if I find any results, I'll post them here.
    Last edited by Dalgaim; April 26th, 2009 at 12:14 PM.

  4. #24
    Join Date
    Apr 2009
    Location
    Prague, Czech Republic
    Beans
    4
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: cannot shutdown / reboot laptop on 9.04

    Quote Originally Posted by Dalgaim View Post
    Good point! When I turn off wifi manually (pressing the button for wifi card), I can reboot/shutdown perfectly. I tried your solution, with "iwlagn" and "iwlcore" instead of your modules, but it doesn't work.

    Edit: when i run "sudo modprobe -r iwlagn" manually before I actually click on shutdown, everything (I mean shutdown/reboot) works fine, so i expect my problem to be the location and linking of the script. I'll play around for a while and if I find any results, I'll post them here.
    I foud the cause of the problem - i forgot to change file permissions to enable executing.
    Code:
    cd /etc/init.d/
    sudo chmod 755 killwlan
    Everything else is as hesapotman posted, except the kernel modules, of course.

  5. #25
    Join Date
    Apr 2009
    Beans
    1
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: cannot shutdown / reboot laptop on 9.04

    I'm having the same problem on my System 76 Pangolin (panp4n). Will give this a try.
    Last edited by tsuanmi-dream; April 26th, 2009 at 07:01 PM.

  6. #26
    Join Date
    Apr 2009
    Beans
    4

    Re: cannot shutdown / reboot laptop on 9.04

    its an error in the boot sector, try a bios update

  7. #27
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: cannot shutdown / reboot laptop on 9.04

    Quote Originally Posted by w3wsrmn View Post
    I too experience this issue.

    If you press Ctrl+Alt+F7, does the last line say Deconfiguring network interfaces by chance?
    Quote Originally Posted by lisati View Post
    Occasional similar problem on a Toshiba m200 laptop running 64-bit 9.04: seems to do pretty much everything it should and then when it's at the stage when you'd expect the power to go off, there's a blinking cursor at the top left of a blank screen. I haven't noticed any error messages, and the system seems to respond to Ctrl+Alt+Del by restarting the system.

    BTW, using EXT3 in preference to EXT4
    Update on personal situation: have a fresh install of the 64-bit of Ubuntu studio (that's what I got the laptop for, to help with video stuff when I'm out and a bout)
    Seems to be hung on the "deconfiguring netowrk interfaces", which kinda makes sense: the networking on the studio edition seems a little weird, I can use the wired connection if I restart networking manually through the terminal, but the network manager (manually installed) reckons eth0 isn't managed!
    Also have "killing all remining processes.... [fail]" and a few lines above, "Pidfile not found! Is jackd running?"



    Quote Originally Posted by regisinferni View Post
    Thanks.



    EDIT: grumble grumble where did I put my 64-bit disks?
    Last edited by lisati; April 27th, 2009 at 04:52 AM.
    Forum DOs and DON'Ts
    Never assume that information you find using a search engine is up-to-date.

  8. #28
    Join Date
    Jan 2005
    Beans
    6

    Re: cannot shutdown / reboot laptop on 9.04

    Same for me. HP pavlion 6680ev

  9. #29
    Join Date
    Apr 2009
    Beans
    130

    Re: cannot shutdown / reboot laptop on 9.04

    Quote Originally Posted by hesapotman View Post
    3. Touch and edit your new wireless shutdown script. I use "vi," but feel free to use "gedit" if you like.
    Code:
    vi killwlan
    I don't see a file "killwlan" in the /etc/init.d/ directory. I'm on Jaunty.

  10. #30
    Join Date
    Mar 2009
    Location
    Southport
    Beans
    3
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: cannot shutdown / reboot laptop on 9.04

    I don't know if this is a red herring, however, in another thread there are complaints that laptops will not shut down or boot up when the computer is running on battery power. When plugged in to mains power there is no problem.

Page 3 of 8 FirstFirst 12345 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •