Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31

Thread: Jaunty Jackalope upgrade + ATI X1650 Driver?

  1. #11
    Join Date
    Jan 2009
    Location
    czech
    Beans
    10
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Lightbulb summary

    ATI X1600 mobility:

    9-1: glx ABI fglrx errors, aticonfig --initial -f works
    modprobe fglrx doesn't work ( permission denied, while root ?!? )
    after reboot, fails into lowgraphics
    9-2: glx fglrx errors, aticonfig --initial -f works
    modprobe fglrx works
    after reboot, fails into lowgraphics
    9-3: (8.593) glx fglrx errors, aticonfig --initial -f works
    after reboot, fails into lowgraphics
    9-4: (8.602) aticonfig --initial -f says no supported addapter
    after reboot, broken graphics, keyboard not responding
    ???: (8.600) aticonfig --initial -f says no supported addapter
    after reboot, broken graphics, keyboard not responding

    .. maybe this is a reason, why automatic installing restricted drivers was disaster for my computer ... X1600 seems to be no longer supported since 9-4

  2. #12
    Join Date
    Feb 2009
    Beans
    72

    Re: Jaunty Jackalope upgrade + ATI X1650 Driver?

    Quote Originally Posted by kshane View Post
    Just did the upgrade myself. I have the same card (X1650Pro). I am unable to use Jaunty, at this point. My system slows to a crawl and is unusable.

    So, in a nut shell, I'd wait for the new ATI driver.

    Kevin
    Thanks, I think I will do just this. I'm kind of new to Ubuntu/Linux so how to fix an issue is something I'm still learning and I'm not confident to try fixing these big problems just yet.

  3. #13
    Join Date
    Jan 2009
    Location
    czech
    Beans
    10
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Jaunty Jackalope upgrade + ATI X1650 Driver?

    Quote Originally Posted by BubuXP View Post
    Reinstalled a clean copy of Jaunty.
    After applying updates, I opened Synaptic and removed all xserver-xorg-* useless packages (related to other VGA). Here's the list:
    xserver-xorg-video-all
    xserver-xorg-video-apm
    xserver-xorg-video-chips
    xserver-xorg-video-cirrus
    xserver-xorg-video-intel
    xserver-xorg-video-mga
    xserver-xorg-video-neomagic
    xserver-xorg-video-nv
    xserver-xorg-video-openchrome
    xserver-xorg-video-rendition
    xserver-xorg-video-s3
    xserver-xorg-video-s3virge
    xserver-xorg-video-savage
    xserver-xorg-video-siliconmotion
    xserver-xorg-video-sis
    xserver-xorg-video-sisusb
    xserver-xorg-video-tdfx
    xserver-xorg-video-trident
    xserver-xorg-video-tseng
    xserver-xorg-video-voodoo

    After, I installed the xorg-driver-fglrx package and all dependencies, via Synaptic.
    Next step, opened a terminal and typed:
    sudo aticonfig --initial -f
    Finally, I crossed my fingers and reboot. And I'm still here

    Compiz works fine and also Google Earth 5 from Medibuntu repository runs smooth (but with compiz or minimal effects enabled the earth start to flash and is unusuable).

    Remember that I have an integrated HD 3200 VGA.
    Hope will work with someone else.
    Have you any errors/warnings in logs?

    please attach output of

    Code:
     dpkg --list | grep glx

  4. #14
    Join Date
    Apr 2009
    Location
    Oriental Sicily
    Beans
    31

    Re: summary

    your problem is that your VGA is supported until version 9.3 of fglrx.
    Version 9.4 won't work with your VGA.

    Then, in Jaunty, there is the new X.Org server 1.6 that is compatible only with fglrx from version 9.4+.
    So, older version of fglrx will not work on jaunty.

    Your only chanche is to install some open source driver. My only reference to these drivers is Wikipedia:
    http://en.wikipedia.org/wiki/Graphic...FOSS#ATI.2FAMD
    but some expert user can tell you more.

  5. #15
    Join Date
    Apr 2009
    Location
    Oriental Sicily
    Beans
    31

    Re: Jaunty Jackalope upgrade + ATI X1650 Driver?

    Quote Originally Posted by plysovej_kaktus View Post
    Have you any errors/warnings in logs?
    no errors, I followed the packages installation from the Synaptic terminal window and nothing was wrong.

    here's the output:

    dpkg --list | grep glx

    ii libgl1-mesa-glx 7.4-0ubuntu3 A free implementation of the OpenGL API -- G
    ii libglitz-glx1 0.5.6-1 Glitz OpenGL library GLX backend
    ii rss-glx 0.8.2-1ubuntu3 Really Slick Screensavers GLX Port
    Last edited by BubuXP; April 23rd, 2009 at 05:48 PM.

  6. #16
    Join Date
    Jan 2009
    Location
    czech
    Beans
    10
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: summary

    Quote Originally Posted by BubuXP View Post
    your problem is that your VGA is supported until version 9.3 of fglrx.
    Version 9.4 won't work with your VGA.

    Then, in Jaunty, there is the new X.Org server 1.6 that is compatible only with fglrx from version 9.4+.
    So, older version of fglrx will not work on jaunty.

    Your only chanche is to install some open source driver. My only reference to these drivers is Wikipedia:
    http://en.wikipedia.org/wiki/Graphic...FOSS#ATI.2FAMD
    but some expert user can tell you more.
    ughhg... my only dream about opengl3 has gone with my old computer. It seems only solution is stay with ibex, open source drivers doesn't support gl2, which i'm developing in. ... it's time for new computer.

  7. #17
    Join Date
    Apr 2009
    Location
    Oriental Sicily
    Beans
    31

    Re: Jaunty Jackalope upgrade + ATI X1650 Driver?

    Quote Originally Posted by BubuXP View Post
    Reinstalled a clean copy of Jaunty.
    After applying updates, I opened Synaptic and removed all xserver-xorg-* useless packages (related to other VGA). Here's the list:
    xserver-xorg-video-all
    xserver-xorg-video-apm
    xserver-xorg-video-chips
    xserver-xorg-video-cirrus
    xserver-xorg-video-intel
    xserver-xorg-video-mga
    xserver-xorg-video-neomagic
    xserver-xorg-video-nv
    xserver-xorg-video-openchrome
    xserver-xorg-video-rendition
    xserver-xorg-video-s3
    xserver-xorg-video-s3virge
    xserver-xorg-video-savage
    xserver-xorg-video-siliconmotion
    xserver-xorg-video-sis
    xserver-xorg-video-sisusb
    xserver-xorg-video-tdfx
    xserver-xorg-video-trident
    xserver-xorg-video-tseng
    xserver-xorg-video-voodoo

    After, I installed the xorg-driver-fglrx package and all dependencies, via Synaptic.
    Next step, opened a terminal and typed:
    sudo aticonfig --initial -f
    Finally, I crossed my fingers and reboot. And I'm still here

    Compiz works fine and also Google Earth 5 from Medibuntu repository runs smooth (but with compiz or minimal effects enabled the earth start to flash and is unusuable).

    Remember that I have an integrated HD 3200 VGA.
    Hope will work with someone else.
    While I'm at it, I'm trying the 64 bit version of Jaunty.
    Repeated the same as above and it works well also on 64 bit.


    The aticonfig command could help someone:

    sudo aticonfig --initial=check
    will check if the configuration file have the fglrx section.
    Running this command right after the driver installation tells me that the section is absent.

    sudo aticonfig --initial -f
    will write the fglrx section on the configuration file. The -f option needs to force the writing

    if you need the full list of option:
    aticonfig > /eventualpath/textfile.txt
    and read the text file created, because the list is bigger than the terminal buffer.
    P.S.: the boot time on the 64bit version is even smaller than 32bit

  8. #18
    Join Date
    Feb 2009
    Location
    Barrie Ontario Canada
    Beans
    172
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Jaunty Jackalope upgrade + ATI X1650 Driver?

    ho well is my x1650 pro card in desktop computer supported in jaunty? right now im just using the defaults

  9. #19
    Join Date
    May 2008
    Location
    Deutschland
    Beans
    5
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Jaunty Jackalope upgrade + ATI X1650 Driver?

    Ok guys, just surfing through the web I found this link in the ATI web page. The problem, according to this article, is that the driver 9.3 from AMD is not compatible with X.org 1.6. ATI offers support for this version of X.org but only to newest hardware (you can see the list of no longer supported hardware in the first link).

    As I see it know, we have to either create a new driver, or conform with the slow and "open" ati driver or not update at all.

  10. #20
    Join Date
    Apr 2009
    Beans
    1,173

    Re: Jaunty Jackalope upgrade + ATI X1650 Driver?

    Quote Originally Posted by sansa dude View Post
    ho well is my x1650 pro card in desktop computer supported in jaunty? right now im just using the defaults
    X series cards are not supported in Catalyst 9.4, according to the ATI documentation at http://en.wikipedia.org/wiki/Fglrx (nor is the Xpress 200m in my Dell Inspiron 1501).

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •