Page 13 of 47 FirstFirst ... 3111213141523 ... LastLast
Results 121 to 130 of 470

Thread: HOWTO: Installing Neverwinter Nights Platinum

  1. #121
    Join Date
    Apr 2006
    Beans
    72

    Re: HOWTO: Installing Neverwinter Nights Platinum

    I m having problems with movies bit of your guide leech:
    I installed nwn using the 1 gig resource file from bioware. Then I installed Shadows if undrentide and hordes of the underdark.

    I ve got everything up to date with most recent patch. (one with the cloaks). Everything seemed to work.

    I followed the bit of your guide about getting the movies to work.

    The movies bit in the menu isn't greyed out any more and the movies play, except they have no sound! Also all the in game music doesn't play at all either now!

    The movies do play with sound however outside the game e.g:
    Code:
    ./BinkPlayer /home/bbyrne/nwn/movies/XP2_Intro.bik
    works fine.

    Any ideas?


    Im thinking of trying to install everything using the cds and your guide if I cant figure this out. Thanks for making for making the guide in the first place!
    Last edited by bplus; September 13th, 2006 at 08:15 PM.

  2. #122
    Join Date
    Oct 2004
    Beans
    Hidden!

    Re: HOWTO: Installing Neverwinter Nights Platinum

    Quote Originally Posted by leech View Post
    That's quite odd, I have a 6800GT and don't suffer that problem. At least that I can recall, I haven't played it in a while though.

    It's easy enough to disable movies without uninstalling. Simply put a # in front of the line for exporting the nwmovies.so in your nwn start up script.

    Leech
    What's really strange is that after I disabled the movies, the game still ran extremely slow. This was under GNOME, so I tried something different and ran the game under XFCE. With XFCE, the game ran flawlessly, with and without movies. I reinstalled Dapper AGAIN so now I'm going to attempt another installation of NWN. I'll report back when it's finished.

  3. #123
    Join Date
    Sep 2006
    Beans
    1

    Re: HOWTO: Installing Neverwinter Nights Platinum

    Ok, so I got through the installation and go to my nwn directory and sh nwn. I get this in response:


    mcop warning: user defined signal handler found for SIG_PIPE, overriding
    Creating link /home/darren/.kde/socket-Hobbiton.
    can't create mcop directory

    any ideas what this is all about? I have an Nvidia card and all else is good--running dapper.

  4. #124
    Join Date
    Aug 2006
    Beans
    1

    Re: HOWTO: Installing Neverwinter Nights Platinum

    On. Clarkii

    All you have to is create the directory yourself, i.e.

    mkdir /home/darren/.kde/socket-Hobbiton

    This has happened to me twice (with GAIM and NWN) when I installed KDE once and then removed it.

  5. #125
    Join Date
    Sep 2006
    Location
    Western New York, USA
    Beans
    14
    Distro
    Xubuntu 8.04 Hardy Heron

    Re: HOWTO: Installing Neverwinter Nights Platinum

    Quote Originally Posted by Artificial Intelligence View Post
    Well I just put everything down from CD to harddrive. Easy solution.
    and it just ran after that? Silly me! I thought it would be harder than that. I'll give that a try. Thanks!

  6. #126
    Join Date
    Aug 2006
    Beans
    26

    Re: HOWTO: Installing Neverwinter Nights Platinum

    I installed NWN Diamond using this HOWTO, and it works great for me so far. The only problem is that, as I installed it in /usr/local/games, I have to run it using gksudo, otherwise I get an error when I try to create a character ("unable to load module"). I've done "chmod 777 -R *" in the nwn directory, that made fonts actually show up, but still the module error. Other than that it runs great using gksudo, there was only some strange flickering in the textures of characters that I fixed by tweaking the video settings in the game. Thanks for this great HOWTO.

  7. #127
    Join Date
    Aug 2006
    Beans
    7

    Re: HOWTO: Installing Neverwinter Nights Platinum

    I tried installing it this way, but it didnt work 4 me. I installed it with wine, and it installed great! One problem... I opened nwn, pressed play, and a message popped up saying "insert nwn disk" the disk was inserted. what do I do!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    BTW what is a no-cd crack, and would it help? if so, where do I get one?

    I am new to linux.

  8. #128
    Join Date
    Dec 2004
    Beans
    744
    Distro
    Edgy Eft Testing

    Re: HOWTO: Installing Neverwinter Nights Platinum

    I'll try to answer what I can in one post...

    @ bplus;

    The sound problem could be related to the version of libsdl you have, make sure you're running the alsa version. Or 'sudo apt-get install alsa-oss' may also help. That's kind of an odd issue that the music worked before but doesn't after putting in the movies.

    @ Carbon Based;

    Strange, usually that'll work. I generally just install nwn in the home directory, it isn't really programmed for multi-user set ups anyhow. There is a hack for setting it up with multi-users, but I've never attempted it myself.

    @ bob3000;

    What exactly does not work with the method put forth in my how to? You'll be better off running the native version, and not through Wine. A No-CD crack is in essence something that removes a CD check that most games have. Unfortunately Wine itself doesn't really provide the wrapper for this sort of software, due to copyright and IP issues. The Native version of Neverwinter Nights has never asked for the CD to be inserted.

    Leech
    Wah! Wah! Life was more entertaining when I had 64KB of RAM in my computer.
    Neverwinter Nights Platinum HowTo

  9. #129
    Join Date
    Apr 2006
    Beans
    72

    Re: HOWTO: Installing Neverwinter Nights Platinum

    firstly thanks for the response leech!

    Howeve I ve just switched to 64 bit ubuntu. Again Im trying to get the movies in working in neverwinter, but now I cant even get bink player working!
    if I ./BinkPlayer <some nwn movie file> I get the following error:

    ./BinkPlayer: error while loading shared libraries: libvorbisfile.so.3: cannot open shared object file: No such file or directory
    also when I run nwmovies_install.pl these errors appear at the end:
    nwmovies/nwmovies_link.S:17: Error: `pusha' is not supported in 64-bit mode
    nwmovies/nwmovies_link.S:19: Error: `popa' is not supported in 64-bit mode
    then when running the actual games (./nwn) i get:

    ERROR: ld.so: object './nwmovies.so' from LD_PRELOAD cannot be preloaded: ignored.
    is there a way to get nwmovies working on ubuntu 64?

    thanks in advance!
    Last edited by bplus; September 17th, 2006 at 02:35 PM.

  10. #130
    Join Date
    Oct 2004
    Location
    Denmark - Scandinavia
    Beans
    17,626

    Re: HOWTO: Installing Neverwinter Nights Platinum

    Quote Originally Posted by Carbon Based View Post
    I installed NWN Diamond using this HOWTO, and it works great for me so far. The only problem is that, as I installed it in /usr/local/games, I have to run it using gksudo, otherwise I get an error when I try to create a character ("unable to load module"). I've done "chmod 777 -R *" in the nwn directory, that made fonts actually show up, but still the module error. Other than that it runs great using gksudo, there was only some strange flickering in the textures of characters that I fixed by tweaking the video settings in the game. Thanks for this great HOWTO.
    You can't install as root (well you can, but then you'll taking a security risk if you play nwn with sudo).
    Instead install in your home folder.
    I usually installs game in /home/<username>/.Games (hidden) and makes shortcut to them.
    elementary OS Luna
    My Screenshot

Page 13 of 47 FirstFirst ... 3111213141523 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •