Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Wireless half of what it was in Intrepid.

  1. #11
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,554
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wireless half of what it was in Intrepid.

    I guess Im more confused. Your dmesg states you have an internet connection:

    [ 52.572995] wlan0: authenticate with AP 00:14:bf:10:e3:4a
    [ 52.574493] wlan0: authenticated
    [ 52.574497] wlan0: associate with AP 00:14:bf:10:e3:4a
    [ 52.576539] wlan0: RX AssocResp from 00:14:bf:10:e3:4a (capab=0x411 status=0 aid=1)
    [ 52.576542] wlan0: associated


    I'm not sure what to suggest since some of the output you give us is conflicting. In some cases you have a connection, in others you do not! Have you tried unloading and reloading the driver (modprobe statements) and then making a manual connection? A helpful link may be found in my signature. Its also possibly a driver problem. I dont know a lot about the ath5k_pci driver -- Have you found more info on this driver on google or the linuxwireless.org website?

  2. #12
    Join Date
    Apr 2008
    Location
    North Canton, OH
    Beans
    101
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Wireless half of what it was in Intrepid.

    Thanks for the help kevdog. One more question: Why would my wireless connection be fine in Intrepid but have a problem in Jaunty? How could I have messed up a driver (or something else) just by doing an install?

  3. #13
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,554
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wireless half of what it was in Intrepid.

    Here is what I suspect -- the ath5k open source driver contained within the newer Jaunty kernel is different than that contained in the Intrepid kernel. The ath5k is an internal kernel module compiled into the kernel (if you ever compile your own kernel you have the option to include support for ath5k or not!). My suspicion is that the ath5k driver was updated with the new kernel, possibly causing problems. You can always recompile the ath5k from source and try this version if you need to. I would definitely do a search for problems related to ath5k and your kernel version -- which can be found by typing
    uname -r
    at the command line. Hopefully with the mainline Jaunty release in a few days, this problem will be explored and a solution found. Its difficult for me to support you on this problem since I don't own that chipset or a similar chipset supported by ath5k and Im not currently running Jaunty. Ill upgrade after a week or two after the release when all the activity settles down.

  4. #14
    Join Date
    Apr 2008
    Location
    North Canton, OH
    Beans
    101
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Wireless half of what it was in Intrepid.

    Quote Originally Posted by kevdog View Post
    Here is what I suspect -- the ath5k open source driver contained within the newer Jaunty kernel is different than that contained in the Intrepid kernel. The ath5k is an internal kernel module compiled into the kernel (if you ever compile your own kernel you have the option to include support for ath5k or not!). My suspicion is that the ath5k driver was updated with the new kernel, possibly causing problems. You can always recompile the ath5k from source and try this version if you need to. I would definitely do a search for problems related to ath5k and your kernel version -- which can be found by typing
    uname -r
    at the command line. Hopefully with the mainline Jaunty release in a few days, this problem will be explored and a solution found. Its difficult for me to support you on this problem since I don't own that chipset or a similar chipset supported by ath5k and Im not currently running Jaunty. Ill upgrade after a week or two after the release when all the activity settles down.
    Thanks a lot for the info. I'll probably just go back to 8.10 if I can't figure it out after a few weeks.

  5. #15
    Join Date
    Dec 2005
    Location
    Western Australia
    Beans
    11,478
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wireless half of what it was in Intrepid.

    I don't know for certain if that chipset is supported by the procedure, but a lot of people eschew the "ath5k" driver in favour of compiling the latest version of "madwifi".
    I try to treat the cause, not the symptom. I avoid the terminal in instructions, unless it's easier or necessary. My instructions will work within the Ubuntu system, instead of breaking or subverting it. Those are the three guarantees to the helpee.

  6. #16
    Join Date
    Mar 2007
    Location
    Denver, CO
    Beans
    7,554
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wireless half of what it was in Intrepid.

    Compiling a patched version of madwifi (need the patch due to the particular chipset) is definitely an option. There are instructions somewhere on this forums and also out in the wild on many internet sites how to do this. Its not too hard, but if you have never compiled anything before, this method is slightly intimidating.

  7. #17
    Join Date
    Aug 2008
    Location
    Washington DC
    Beans
    2,186
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Wireless half of what it was in Intrepid.

    what does

    Code:
    iwconfig wlan0
    tell you about your connect speed? ie the "Bit Rate="

    does the connection improve with:

    Code:
    sudo iwconfig wlan0 rate 54M

  8. #18
    Join Date
    Apr 2008
    Location
    North Canton, OH
    Beans
    101
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Wireless half of what it was in Intrepid.

    Quote Originally Posted by 3rdalbum View Post
    I don't know for certain if that chipset is supported by the procedure, but a lot of people eschew the "ath5k" driver in favour of compiling the latest version of "madwifi".
    Oh, this post was really helpful. I'm not too savvy on all this stuff! I believe that's the problem. In 8.10 I used madwifi. In Jaunty I just let the OS pick up the wireless connection after plugging in the wep key and just assumed it did automatically what I had done manually before.

    Hope that makes sense!

    I'm gonna give the madwifi thing a go. I feel pretty confident that should help.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •