Results 1 to 10 of 247

Thread: Jaunty 9.04 Sound Solutions

Threaded View

  1. #1
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Jaunty 9.04 Sound Solutions

    Jaunty 9.04 Sound Solutions

    This guide is based on a clean install of Jaunty Jackalope 9.04rc amd64. It is geared towards getting the basic sound scheme properly set up for optimum use.

    It is assumed that your sound device is properly recognized and configured and you have at least a login sound. This is not for basic troubleshooting of no sound problems or issues with your laptop speakers, headphones etc. There are links at the bottom of the post for that.

    The sound scheme in Jaunty has some important changes that you need to be aware of. Alsa 1.0.18 and Pulseaudio 0.9.14 are implemented in Jaunty. The new ALSA provides more support and greater functionality for more sound devices than previous versions. Pulseaudio 0.9.14 does some of the same on the sound server side.

    The first thing you should check is the volume control on the panel. It has a new Sound Theme tab. You can set the theme for your system sounds there. If you wish to disable system sounds set Sound Theme: No Sounds.

    Next, check out System/Preferences/Sound. It has only two tabs, Devices and Sounds. The Devices tab is where you choose the device to play your sounds. We will return to this later. In the Sounds tab there are numerous sound preferences that can be set for everything from button clicks to email alerts. You can change the default sound or disable it by double clicking on Default.

    Necessary Packages
    As with Hardy and Intrepid, some important packages necessary for optimal sound set up are missing. Open System/Adminstration/Synaptic package manager and search pulse. This is the easiest way to find and install all the packages we need. Select the following packages

    padevchooser -this will pull in all the pulseaudio guis and their dependencies

    if you plan on using vlc or xmms2 or 32 bit or libao apps etc, you can get those packages now too. If you are not constrained on disk space it is a good idea to get all of the following

    vlc-plugin-pulse -this also pulls in a lot of libs that vlc will need
    xmms2-plugin-pulse -this also pulls in the xmms2 core
    pulseaudio-module-lirc - this is to use lirc and your infrared remote with pulse
    libsdl1.2debian-all -this wil replace the alsa version with all available drivers
    lib32asound2-this is the 32 bit library for 64 bit installs
    lib32asound2-plugins -this is the 32 bit plugins for 32 bit apps
    libao2 - you need this for apps using the libao cross platform library
    asoundconf-gtk -applet for default alsa sound card
    audacious-plugins-extra -plugins for audacious for many codecs like MP3, aac, FLAC, WMA, etc

    The gnome-volume-control-pulse is somewhat broken so I do not recommend installing or using it yet. If you are using skype or wine then installing the lib32asound2-plugins will remove them and installing wine or skype will remove the lib32asound2-plugins. I don't use either skype or wine so I was unaware of this issue, sorry. You can still install lib32asound2 but not the lib32asound2-plugins. Other applications that depend on the lib32asound2-plugins may not work after you do this so be aware of that. Hopefully this will be fixed soon.

    Search alsa and select the following

    gnome-alsamixer - this mixer is far easier to use than the alsamixer
    alsa-oss - this is the alsa wrapper for oss apps

    Click apply and the packages will download and install themselves

    Also select the following

    ubuntu-restricted-extras

    Click apply. This download may take a while, the ubuntu-restricted-extras package is quite large but installs almost all the codecs and java and flash 10.0.22.87 and a bunch of other stuff that you will be needing. It also updates the gstreamer packages and some other stuff.

    A window will pop up during the installation asking you to agree to the sun-java6-jre license terms, click the little box and then Forward.

    In System/Adminstration/Users and Groups check that your users and root are members of the following groups. (This is supposed to be taken care of by Policykit and hal but users have reported messages in their logs relating to lack of permission for pulse to gain rt priority so.....)
    pulse
    pulse-access
    pulse-rt

    Reboot

    (This may not be totally necessary but I always reboot after installing a bunch of packages just to ensure that everything is cleaned up in the file system.)

    Setup

    System/Preferences/Sound, change everything to PulseAudio Sound Server except Default Mixer tracks which you should change to you hardware playback device like Playback: HDA ATI SB ALC888 Analog..... or something like that. Default Mixer tracks is where you set what your multimedia keys to control the hardware device. If your keys are controlling PCM volume and you want to control the Master or something like that, you need to change the selection in the panel volume control/preferences.

    Click Applications/Sound and Video/PulseAudio Device Chooser.(padevchooser) The icon should appear in the panel. Click on it, choose Preferences/Start Applet on session login so it stays in your panel when you reboot. Choose it again, click Volume Control.

    In Playback you will notice System Sounds. You can set the volume of your system sounds here or mute them with the mute button. In the Output Devices tab you will see your sound device(s). if you right click on the volume bars you can make it the default. If you have already opened an application and it plays on another device this will have no effect and you will need to move the stream manually next time you open it.

    Lets' play something. Start Rythmbox and play one of the radio stations. Rythmbox should show up in the Playback tab with the volume bar moving with the sound. Click Output Devices, you should see the same thing in your output device. You can adjust the volume or mute the individual stream in Playback or the entire device in Output Devices

    If you have more than one device and rythmbox is playing in the wrong one go back to the playback tab, right click on the volume bars and choose move stream to move it to the correct device. You can also go back to the padevchooser and open Configure Local Sound Server/Simultaneous Output and check the box. That will create a new Simultaneous output.... Virtual Stream in Output Devices. You can move any playing stream to the new device and have sound everywhere all at once.

    Lets check if we can record. Leave rythmbox playing.
    Open Applications/Sound and Video/Sound Recorder. Click the record button. In the PA volume control recording tab you should now see

    gnome-sound-recorder: Record Stream.

    right click on the volume bar and choose move stream and move it to the monitor of the output device you are using. Click stop in sound recorder and then record. Sound recorder should now be recording from rythmbox. Click stop. Change to the playback tab in the pavolume control. click the speaker on the rythmbox stream to mute it. click play on sound recorder. You should now see stream recorder in playback and hear what you just recorded.

    Let's try recording from the microphone. Go back to the recording tab. click record on stream recorder and move the stream to the device instead of the monitor. Click stop. Click record again and make some noise into the microphone. You should see the volume bars move. Congratulations, you are now a recording genius.

    You can make a device or monitor the default for new applications by right clicking on it like with playback.

    If your microphone does not seem to be working Open the Volume Control from your panel ( the little speaker icon) and check that it is set to the proper device (your hardware). Click Preferences and make sure that the boxes for Microphone Capture and Mic Boost Capture are checked, close the box. In the Volume Control/ Switches check the Mic Boost Capture box. In /Recording make sure the Microphone is not muted (no red x on the mic icon) and turned up. (Some devices do not have a mic boost option).

    If your microphone volume is very low even turned up all the way, click padevchooser/Manager. In the devices tab find under Sources alsa_input.pci........alsa_capture_0 or alsa_input_usb.... if you are using are usb device, click the Properties button. A new window will pop up. Try adjusting the volume to 150% or so. (This is a common problem with many dell laptops and others.)

    Try recording again. If it still does not work check for any other mic switches or controls and play around with them.

    Remember, it is the capture/recording settings that are important for recording. Playback settings get your mic to your speakers.

    If you are still having problems with your mic it is most likely a problem with the alsa driver. This is a very common issue for laptop users and fixes are very hardware specific. You should try the first link in the troubleshooting section below or a forum or google search for your specific hardware.

    Now you know how to use all the basic tools. There will be some updates along shortly so if your sound stops working after an update, check the basics, like the volume controls and switches and stream locations first before taking any more drastic steps.

    If flash stops working or you want all the non-free codecs etc you can follow the Comprehensive Multimedia and Video How To here (I always do this after every new install):

    http://ubuntuforums.org/showthread.php?t=1130384


    Basic Sound Troubleshooting

    If you are having problems getting the sound to work on your laptop go here

    http://ubuntuforums.org/showthread.php?t=1043568

    If your sound is not working at all or you need some help with your mic or want to enable surround sound or are having other sorts of trouble or have questions about anything else sound wise go here

    http://ubuntuforums.org/showthread.php?t=843012

    KDE/Kubuntu Jaunty
    If you are using KDE4.x or Kubuntu Jaunty with Pulseaudio you should read this

    http://ubuntuforums.org/showthread.php?t=1055591


    Well, that is the basics of getting your sound working in Jaunty.
    Feel free to post comments or suggestions.

    regards,
    mark
    Last edited by markbuntu; August 22nd, 2009 at 03:15 PM.
    PMs will be ignored.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •