Page 4 of 4 FirstFirst ... 234
Results 31 to 40 of 40

Thread: "CIFS VFS" Error stalling/breaking shutdown - simple fix!

  1. #31
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: "CIFS VFS" Error stalling/breaking shutdown - simple fix!

    Quote Originally Posted by AlexanderDGreat View Post
    Help, there's no K15umountnfs.sh in my /etc/rc0 and /etc/rc6
    See post seven: http://ubuntuforums.org/showpost.php...97&postcount=7

  2. #32
    Join Date
    Jul 2009
    Beans
    571
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: "CIFS VFS" Error stalling/breaking shutdown - simple fix!

    Hey dmizer, thanks for that link, I solved my problem now.

    My situation: Ubuntu 9.04 simple file server to Windows, Ubuntu, and Mac boxes, 10 cpus in our network.

    I would just like to tell you to keep up your good work, helping average people solve problems in Ubuntu.

    Your work is very much appreciated.

    Thanks! =)
    It's OK, everything we know will become obsolete at some time.

  3. #33
    Join Date
    Oct 2009
    Beans
    16

    Re: "CIFS VFS" Error stalling/breaking shutdown - simple fix!

    I found a fix that works on Karmic and wireless (WPA). I posted the fix here:
    http://ubuntuforums.org/showthread.p...27#post8449027

  4. #34
    Join Date
    Dec 2009
    Beans
    9

    Re: "CIFS VFS" Error stalling/breaking shutdown - simple fix!

    Hello

    For me these fixes didn't work either. But I did find something strange.. at least imo...

    I have 9.10 in both my desktop and media pc. In media pc for some reason there haven't been any freezes in shutdownt. For desktop I keep having this error and it's annoying. Only thing that basically is different with these pc's is the media pc has eth/wlan converter and the desktop pc has direct wlan.

    So I switched the eth/wlan converter to my desktop pc and... the unmount problem disappeared! Ubuntu shuts down perfectly... But this isn't a long term solution...

    All my sources locate in linkstation nas. I have mounted them under home folder; Documents, Music, Pictures etc... (finnish names). So both pc's use same files.

    I'm a noob, do you have any idea or fix for this...

    My fstab:
    Code:
    # /etc/fstab: static file system information.
    #
    #  -- This file has been automaticly generated by ntfs-config -- 
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    
    proc /proc proc defaults 0 0
    # Entry for /dev/sdb6 :
    UUID=c2008c0c-4bff-405b-b759-a228f7f3671e / ext3 relatime,errors=remount-ro 0 1
    # Entry for /dev/sdb7 :
    UUID=70984964-1dc9-4936-a302-6260742740c0 none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
    /dev/sdb1 /media/MEDIA ntfs-3g defaults,locale=fi_FI.UTF-8 0 0
    /dev/sda2 /media/BACKUP ntfs-3g defaults,locale=fi_FI.UTF-8 0 0
    //192.168.11.2/Kuvat      /home/kari/Kuvat      cifs credentials=/home/.smbcredentials,dir_mode=0777,file_mode=0777  0  0
    //192.168.11.2/Mp3        /home/kari/Musiikki   cifs credentials=/home/.smbcredentials,dir_mode=0777,file_mode=0777  0  0
    //192.168.11.2/Email      /home/kari/Email      cifs credentials=/home/.smbcredentials,dir_mode=0777,file_mode=0777  0  0
    //192.168.11.2/Asiakirjat /home/kari/Asiakirjat cifs credentials=/home/.smbcredentials,dir_mode=0777,file_mode=0777  0  0
    //192.168.11.2/Video      /home/kari/Videot     cifs credentials=/home/.smbcredentials,dir_mode=0777,file_mode=0777  0  0
    /etc/gdm/PostSession/Default file:
    Code:
    #!/bin/sh
    /etc/init.d/umountnfs.sh
    
    exit 0

  5. #35
    Join Date
    Dec 2009
    Beans
    9

    Re: "CIFS VFS" Error stalling/breaking shutdown - simple fix!

    seems that no one's interested of this thread anymore... :/

  6. #36
    Join Date
    Nov 2008
    Location
    Munich, Germany
    Beans
    3
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: "CIFS VFS" Error stalling/breaking shutdown - simple fix!

    I have been repairing this NM mess in every release since 8.04; every new release meant doing it all again.

    And finally - the end solution is so simple:

    Install WICD to replace NM (gets dumped automatically)

    That`s it !!!!

  7. #37
    Join Date
    Dec 2009
    Beans
    9

    Re: "CIFS VFS" Error stalling/breaking shutdown - simple fix!

    Quote Originally Posted by Glasairman View Post
    I have been repairing this NM mess in every release since 8.04; every new release meant doing it all again.

    And finally - the end solution is so simple:

    Install WICD to replace NM (gets dumped automatically)

    That`s it !!!!

    Well yes, WICD seems to help as you said. Now I just have a problem connecting to wlan with WICD. It was working for some time, but now it can't find network suddenly after switching pc on this morning.. I have ndiswrapper for buffalo g pci card (broadcomb43). Well, this is linux.. have to seek for wicd threads then...

  8. #38
    Join Date
    Dec 2009
    Beans
    9

    Re: "CIFS VFS" Error stalling/breaking shutdown - simple fix!

    Quote Originally Posted by Glasairman View Post
    I have been repairing this NM mess in every release since 8.04; every new release meant doing it all again.

    And finally - the end solution is so simple:

    Install WICD to replace NM (gets dumped automatically)

    That`s it !!!!
    I got it. I had to play a bit with packages, don't remember what it was exactly, but the shutdown goes ok now (1.6.1). Definetily the nm has a major bug init. How noob is that.

    A new problem occurred with WICD though, and this is a bit funny I think. Now the startup doesn't work. I think the fstab mounts are done before the actual network connection to wlan host has been established. So I have to manually do sudo mount -a.

    What to do? Somehow adjust the startup priorities or what?

  9. #39
    Join Date
    Aug 2006
    Location
    Canberra, Australia
    Beans
    89
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: "CIFS VFS" Error stalling/breaking shutdown - simple fix!

    Quote Originally Posted by dmizer View Post
    Edit /etc/gdm/PostSession/Default and add /etc/init.d/umountnfs.sh to the top of the file like so:

    Code:
    #!/bin/sh
    /etc/init.d/umountnfs.sh
    }
    exit 0
    The above fix worked for me with Karmic (9.10, i386 version). The commonly quoted fix of renumbering file K15umountnfs.sh had worked for me on earlier versions but not on Karmic.

    Many thanks to dmizer for this.
    Tony
    --
    Linux Mint 14, Linux user 456436

  10. #40
    Join Date
    Dec 2009
    Beans
    9

    Re: "CIFS VFS" Error stalling/breaking shutdown - simple fix!

    Quote Originally Posted by tonywhelan View Post
    The above fix worked for me with Karmic (9.10, i386 version). The commonly quoted fix of renumbering file K15umountnfs.sh had worked for me on earlier versions but not on Karmic.

    Many thanks to dmizer for this.
    Doesn't work for me. Sorry for yelling, BUT GETTING SO SICK'N TIRED for this...

    1. Network manager hanging problem in shutdown when using wlan (with eth0 works like a charm) but when I disconnect eht/wlan converter cpu will hang with wlan...
    2. WICD connecting to WLAN AFTER mount of network drives, so THIS ISN'T WORKING EITHER... This has been known and reported in 2008 already (https://bugs.launchpad.net/wicd/+bug/179654), but no fix for this in WICD... In that launchpad site, why not just run sudo mount -a instead of difficult looking and long script ???

    http://ubuntuforums.org/showthread.php?t=1072265 this might work, but first would have to learn what they mean by executables, and how to run that as root.. BUT, there's also some other problems in WICD, sometimes looses connection and only reboot helps.. don't want that either.

    Loosing my head.

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •