Results 1 to 8 of 8

Thread: Can't enable 3d acceleration in Sketchup

  1. #1
    Join Date
    Sep 2008
    Beans
    89

    Can't enable 3d acceleration in Sketchup

    Hi there folks,
    I've got a Windows xp guest running in Virtualbox 2.2 (with Ubuntu 8.10 as host), one of the main reasons for this is I need sketchup for my job, so then I went on and checked the 3d acceleration option under the general settings of vbox.
    I went on and installed sketchup 7, went to the preferences window and the 3d acceleration is not even available, meaning it's shaded.

    If you know sketchup, then you will know that w/out 3d acceleration the program will become horribly sluggish with an elaborate file.

    Please help if you can!

    Thanks!

  2. #2
    Join Date
    Jun 2007
    Location
    Neverland
    Beans
    894
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Can't enable 3d acceleration in Sketchup

    Did you install the guest addons first?
    Dedoimedo
    Linux Systems Expert / Systems Programmer, LPIC-1, LPIC-2(WIP), GSEC, CCHD, CCHA
    http://www.dedoimedo.com - A place to learn a lot about a lot!

    Pangolin Review | Ringtail Review | Linux Games | My books

  3. #3
    Join Date
    Sep 2008
    Beans
    89

    Re: Can't enable 3d acceleration in Sketchup

    Hi Dedoimedo,

    I have read your tutorials by the way, very good ones I must say. To answer your question, yes, guest addons were installed previously and then I enabled 3d acceleration, and then I installed Sketchup.

    Does the problem lie there you think?

  4. #4
    Join Date
    Jun 2007
    Location
    Neverland
    Beans
    894
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Can't enable 3d acceleration in Sketchup

    No problem then ... simply 3d acceleration in virtual machines is not up to the level you need ... But it will be soon, in a year or so.
    Dedoimedo
    Linux Systems Expert / Systems Programmer, LPIC-1, LPIC-2(WIP), GSEC, CCHD, CCHA
    http://www.dedoimedo.com - A place to learn a lot about a lot!

    Pangolin Review | Ringtail Review | Linux Games | My books

  5. #5
    Join Date
    Sep 2008
    Beans
    89

    Re: Can't enable 3d acceleration in Sketchup

    will try running it under wine I suppose...

    thanks for the help!

  6. #6
    Join Date
    Aug 2008
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Can't enable 3d acceleration in Sketchup

    I have to ask this!
    Did you install the "new" guest additions?
    If so are you able to turn on enhanced graphics in Ubuntu?

  7. #7
    Join Date
    Sep 2008
    Beans
    89

    Re: Can't enable 3d acceleration in Sketchup

    Wow!!!

    I reinstalled the guest addons, that did the trick, now the 3d acceleration works!!!

    Thanks a lot!!!

  8. #8
    Join Date
    Jun 2007
    Location
    Neverland
    Beans
    894
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Can't enable 3d acceleration in Sketchup

    Sorry, I should have mentioned it, both 2.1 and 2.2 require new addons to get things going properly. Good one, Perryg.
    Dedoimedo
    Linux Systems Expert / Systems Programmer, LPIC-1, LPIC-2(WIP), GSEC, CCHD, CCHA
    http://www.dedoimedo.com - A place to learn a lot about a lot!

    Pangolin Review | Ringtail Review | Linux Games | My books

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •