Page 12 of 32 FirstFirst ... 2101112131422 ... LastLast
Results 111 to 120 of 320

Thread: HowTo: NViDIA 185.18 Drivers in Ubuntu

  1. #111
    Join Date
    Jun 2009
    Beans
    1

    Re: HowTo: NViDIA 185.18 Drivers in Ubuntu

    Thank you so much for this guide. Now no more screen flickering issues.
    I have gtx280 running on ubuntu 9.04 x64

  2. #112
    Join Date
    Apr 2005
    Beans
    432
    Distro
    Ubuntu

    Re: HowTo: NViDIA 185.18 Drivers in Ubuntu

    Quote Originally Posted by jaysingh View Post
    Thank you so much for this guide. Now no more screen flickering issues.
    I have gtx280 running on ubuntu 9.04 x64
    Is Powermizer actually fixed now? I haven't seen anything in the release notes about the never-ending Powermizer flickering issues.

  3. #113
    Join Date
    Jun 2007
    Location
    Rio de Janeiro - Brasil
    Beans
    319
    Distro
    Kubuntu Development Release

    Re: HowTo: NViDIA 185.18 Drivers in Ubuntu

    I can't get compiz to work with the latest drivers =/

    Here's the terminal output:

    wingnux@wingnux-desktop ~ $ compiz --replace &
    [1] 7181
    Checking for Xgl: wingnux@wingnux-desktop ~ $ not present.
    xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
    Detected PCI ID for VGA:
    Checking for texture_from_pixmap: present.
    Checking for non power of two support: present.
    Checking for Composite extension: present.
    Checking screen 1Comparing resolution (1152x864) to maximum 3D texture size (8192): Passed.
    Checking for Software Rasterizer: Not present.
    Checking for nVidia: present.
    Checking for FBConfig: present.
    running under gnome seesion, checking for gnomecompat
    Checking for Xgl: not present.
    /usr/bin/compiz.real (core) - Error: Could not acquire compositing manager selection on screen 0 display ":0.0"
    /usr/bin/compiz.real (core) - Fatal: No manageable screens found on display :0.0
    Window manager warning: "“space”" found in configuration database is not a valid value for keybinding "run_command_1"

    wingnux@wingnux-desktop ~ $
    And here's my xorg.conf:


    Section "Monitor"
    Identifier "Monitor0"
    Vendorname "Unknown"
    Modelname "Samsung S/M 550v"
    Horizsync 28.0 - 55.0
    Vertrefresh 50.0 - 120.0
    Option "CalcAlgorithm" "CheckDesktopGeometry"
    Option "DPMS"
    Usemodes "Modes[0]"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    Option "RenderAccel" "True"
    Option "AllowGLXWithComposite" "True"
    Option "TwinView" "1"
    Option "TwinViewXineramaInfoOrder" "CRT-0, TV"
    Option "metamodes" "1152x864_62 +0+0; 1024x768_60 +0+0"
    Option "AddARGBGLXVisuals" "True"
    Option "Coolbits" "1"
    Defaultdepth 24
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "XkbRules" "xorg"
    Option "XkbModel" "abnt2"
    Option "XkbLayout" "br"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    screen 0 "Screen0" 0 0
    Inputdevice "Generic Keyboard" "CoreKeyboard"
    Inputdevice "Configured Mouse"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    Vendorname "NVIDIA Corporation"
    Boardname "GeForce 6100 nForce 405"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    modeline "1280x960" 99.9 1280 1376 1488 1800 960 961 962 980 +hsync +vsync
    modeline "1280x1024" 99.0 1280 1328 1440 1800 1024 1025 1028 1066 -hsync -vsync
    modeline "1152x864" 88.8 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
    modeline "1024x768" 72.7 1024 1064 1176 1328 768 769 772 798
    modeline "800x600" 36.9 800 832 912 1024 600 601 604 621
    modeline "800x600" 44.1 800 840 920 1040 600 601 604 624
    modeline "800x600" 51.7 800 840 928 1056 600 601 604 628
    modeline "800x600" 56.5 800 840 928 1056 600 601 604 630
    modeline "640x480" 23.1 640 656 720 800 480 481 484 497
    modeline "640x480" 27.7 640 664 728 816 480 481 484 500
    modeline "640x480" 32.6 640 672 736 832 480 481 484 503
    modeline "640x480" 37.0 640 672 736 832 480 481 484 505
    modeline "640x480" 42.2 640 680 744 848 480 481 484 508
    modeline "640x480" 45.4 640 680 744 848 480 481 484 510
    EndSection

    Section "ServerFlags"
    Option "Xinerama" "0"
    Option "DontZap" "False"
    EndSection

    Thanks in advance!

  4. #114
    Join Date
    Jan 2008
    Beans
    4,757

    Re: HowTo: NViDIA 185.18 Drivers in Ubuntu

    Quote Originally Posted by wingnux View Post
    I can't get compiz to work with the latest drivers =/

    Here's the terminal output:

    And here's my xorg.conf:

    Thanks in advance!
    Try running Compiz-check first, that should point you in the right direction (hopefully) of what is going wrong.

    Site here: http://forlong.blogage.de/entries/pages/Compiz-Check

    If it returns successfully, will have to look into what may be causing it.

    Regards
    Iain
    Last edited by ibuclaw; June 20th, 2009 at 08:33 AM.

  5. #115
    Join Date
    Apr 2006
    Beans
    189

    Re: HowTo: NViDIA 185.18 Drivers in Ubuntu

    Quote Originally Posted by tinivole View Post
    Hmm, I can't see anything that would strike me as odd initially after a quick scan of that report. If you followed the "mv xorg.conf xorg.conf.original" step in the guide, do you still have that backupfile? Have you tried using that instead?

    Regards
    Iain
    On nvnews.net, someone else is experiencing the same problem, and he has tracked down the problem to a specific kernel patch: link. SO, I think I'll have to wait until nVidia fixes this problem, or until the patch is removed from the kernel (which seems unlikely to me, as the problems are caused by a close source driver).

  6. #116
    Join Date
    Jan 2008
    Beans
    4,757

    Re: HowTo: NViDIA 185.18 Drivers in Ubuntu

    Quote Originally Posted by ernstblaauw View Post
    On nvnews.net, someone else is experiencing the same problem, and he has tracked down the problem to a specific kernel patch: link. SO, I think I'll have to wait until nVidia fixes this problem, or until the patch is removed from the kernel (which seems unlikely to me, as the problems are caused by a close source driver).
    That is an interesting problem. I suppose you have disabled PAT in the bootup options?

  7. #117
    Join Date
    Apr 2006
    Beans
    189

    Re: HowTo: NViDIA 185.18 Drivers in Ubuntu

    Quote Originally Posted by tinivole View Post
    That is an interesting problem. I suppose you have disabled PAT in the bootup options?
    Yes, the behavior is the same if I add the boot option 'nopat'.

  8. #118
    Join Date
    Jun 2006
    Location
    $ pwd _
    Beans
    3,999
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: HowTo: NViDIA 185.18 Drivers in Ubuntu

    @tinivole:
    You might also want to add how to use dkms with nvidia drivers installed manually so people don't have to deal with broken X on kernel upgrades. There is another thread posted on 'nvidia + dkms' in the Tutorials section.

    EDIT: Found it

  9. #119
    Join Date
    Jun 2007
    Location
    Rio de Janeiro - Brasil
    Beans
    319
    Distro
    Kubuntu Development Release

    Re: HowTo: NViDIA 185.18 Drivers in Ubuntu

    Quote Originally Posted by tinivole View Post
    Try running Compiz-check first, that should point you in the right direction (hopefully) of what is going wrong.

    Site here: http://forlong.blogage.de/entries/pages/Compiz-Check

    If it returns successfully, will have to look into what may be causing it.

    Regards
    Iain
    Thank you VERY MUCH for telling me about compiz-check, a nice script that indeed solved my problem. I seems that compiz couldn't be enabled because I had gnome compositing activated =) Now everything works just fine!

  10. #120
    Join Date
    Jan 2008
    Beans
    4,757

    Re: HowTo: NViDIA 185.18 Drivers in Ubuntu

    Quote Originally Posted by wingnux View Post
    Thank you VERY MUCH for telling me about compiz-check, a nice script that indeed solved my problem. I seems that compiz couldn't be enabled because I had gnome compositing activated =) Now everything works just fine!
    Awesome! and Ouch! Yeah, Metacity's new compositing features kinda disrupt Compiz a bit.

    It's the /apps/metacity/compositing_manager key in gconf-editor, isn't it? (Make sure that is disabled before you start compiz).

    Regards
    Iain

Page 12 of 32 FirstFirst ... 2101112131422 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •