Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 34

Thread: Xpress 200M is very slow

  1. #11
    Join Date
    Mar 2007
    Beans
    676
    Distro
    Ubuntu Development Release

    Re: Xpress 200M is very slow

    Quote Originally Posted by Pro75357 View Post
    Hello,

    I have the same card and the same problem. I used fglrx in 8.10 because it enabled the capability to suspend to ram. I tried installing fglrx in 9.04 and X wouldn't start. So, I'm stuck with shutting down all the time. HOWEVER, compiz seems to work much nicer with this open source driver. With fglrx, firefox would scroll painfully slow and use 100% cpu if compiz was enabled- this being fixed is a step in the right direction for me. Now, if they could only get s2r to work...
    I have an ATI Radeon Xpress 200M, and am experiencing similar slowness in jaunty.

    I have, however, dealt with a screen re-draw failure with compositing window managers and Wine (by forcing XAA acceleration in xorg.conf)

    AND got suspend to ram (and waking up again!) to work by removing ALL video quirks. They are now specified in a HAL fdi file, but my machine was not included in the file provided. I added a suitable matching protocol and set power_management.quirk.none to true. The file is 20-video-quirk-pm-hp.fdi in /usr/share/hal/fdi/information/10freedesktop/

    HTH
    Sony vaio vgn-fw235j; Synaptics touchpad; triple boot: mint 12 64-bit; Precise 64-bit & Saucy 64-bit. 2TB external USB drive with more...

  2. #12
    Join Date
    Jul 2008
    Beans
    1,491

    Re: Xpress 200M is very slow

    I have the Xpress 200M card using the radeon open source driver in my laptop. Output of "sudo lshw -C display" is as follows:
    Code:
      *-display UNCLAIMED
           description: VGA compatible controller
           product: RC410 [Radeon Xpress 200M]
           vendor: ATI Technologies Inc
           physical id: 5
           bus info: pci@0000:01:05.0
           version: 00
           width: 32 bits
           clock: 66MHz
           capabilities: pm msi bus_master cap_list
           configuration: latency=64 mingnt=8
    I have Kubuntu Jaunty (as well as the Gnome environment off the same installation), and I can run a whole bunch of desktop effects just fine. Yes, glxgears shows
    Code:
    1610 frames in 5.0 seconds = 321.850 FPS
    1686 frames in 5.0 seconds = 337.112 FPS
    1768 frames in 5.0 seconds = 353.551 FPS
    I have an ASUS X51RL laptop with 2GB of "DIMM DDR Synchronous" (from lshw) and a "Intel(R) Pentium(R) Dual CPU T2310 @ 1.46GHz" (also verbatim from lshw). (Originally 1GB of RAM, but I added one way back on Intrepid along with a better wifi card.)

  3. #13
    Join Date
    Sep 2007
    Beans
    27

    Re: Xpress 200M is very slow

    There is a solution to this problem. Alex Deucher provided me with this link:http://www.nabble.com/R300-regression-td23108996.html
    I patched r300_context.c, re-compiled the mesa and now I am back:
    glxgears
    5655 frames in 5.0 seconds = 1130.871 FPS
    5656 frames in 5.0 seconds = 1131.106 FPS
    5654 frames in 5.0 seconds = 1130.648 FPS

    The solution is preliminary, though. It may result in lockups on some systems.
    Have not seen any so far with my 200m.
    Last edited by sergks; April 21st, 2009 at 08:37 AM.

  4. #14
    Join Date
    Apr 2008
    Location
    Romania
    Beans
    94
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Xpress 200M is very slow

    Same problem here the 200M video card is weary slow whi 9.04.
    And some bad news ati is not making drier fol old video cards for ubuntu 9.04
    And when i will extend the desctop too on an external monitor on both the displays i can see nothing
    Last edited by hgergo; April 21st, 2009 at 09:23 AM.

  5. #15
    Join Date
    Mar 2009
    Location
    USA
    Beans
    538

    Re: Xpress 200M is very slow

    Quote Originally Posted by sergks View Post
    There is a solution to this problem. Alex Deucher provided me with this link:http://www.nabble.com/R300-regression-td23108996.html
    I patched r300_context.c, re-compiled the mesa and now I am back:
    glxgears
    5655 frames in 5.0 seconds = 1130.871 FPS
    5656 frames in 5.0 seconds = 1131.106 FPS
    5654 frames in 5.0 seconds = 1130.648 FPS

    The solution is preliminary, though. It may result in lockups on some systems.
    Have not seen any so far with my 200m.
    Thanks. Can you give us some info on the instructions you used to compile mesa? What sources did you grab, etc?

    It looks pretty complicated.
    100% Microsoft Free Since April 2, 2009

  6. #16
    Join Date
    Sep 2007
    Beans
    27

    Re: Xpress 200M is very slow

    I did this in a very stupid way (i am not a developer):
    1) download mesa_7_4.tar.gz from here: http://cgit.freedesktop.org/mesa/mesa/;
    2) unpack the archive;
    3) modify r300_context.c file (/src/mesa/drivers/dri/r300/r300_context.c) - you have to move 'ctx->VertexProgram._MaintainTnlProgram = GL_TRUE;' to another location (see the patch);
    4) sudo apt-get build-dep mesa;
    5) ./autogen.sh (if you do not have autoconf: sudo apt-get install autoconf);
    autoconf will show you any other dependencies you need - install them;
    6) make;
    7) backup r300_dri.so in /usr/lib/dri (r300_dri.so -> r300_dri.so.bak), you can do this with sudo nautilus;
    8.) move r300_dri.so from your build (should be in /lib) to /usr/lib/dri;
    9) restart your system;
    10) check glxgears.

    The idea is to re-place r300_dri.so with modified one. I know this is not the best way but worked for me.

  7. #17
    Join Date
    Sep 2007
    Beans
    27

    Re: Xpress 200M is very slow

    The patch command did not work for me. So, I modified r300_context.c file manually.

  8. #18
    Join Date
    Mar 2009
    Location
    USA
    Beans
    538

    Re: Xpress 200M is very slow

    Quote Originally Posted by sergks View Post
    I did this in a very stupid way (i am not a developer):
    1) download mesa_7_4.tar.gz from here: http://cgit.freedesktop.org/mesa/mesa/;
    2) unpack the archive;
    3) modify r300_context.c file (/src/mesa/drivers/dri/r300/r300_context.c) - you have to move 'ctx->VertexProgram._MaintainTnlProgram = GL_TRUE;' to another location (see the patch);
    4) sudo apt-get build-dep mesa;
    5) ./autogen.sh (if you do not have autoconf: sudo apt-get install autoconf);
    autoconf will show you any other dependencies you need - install them;
    6) make;
    7) backup r300_dri.so in /usr/lib/dri (r300_dri.so -> r300_dri.so.bak), you can do this with sudo nautilus;
    8.) move r300_dri.so from your build (should be in /lib) to /usr/lib/dri;
    9) restart your system;
    10) check glxgears.

    The idea is to re-place r300_dri.so with modified one. I know this is not the best way but worked for me.
    Thanks, I appreciate it. I will give it a go tonight and report back. I'm thinking this still should work even though I upgraded my kernel to 2.6.30rc2 because I also installed the proper headers and kernel source.

    edit: Just to confirm and looking at the patch provided in the link:

    Code:
    diff --git a/src/mesa/drivers/dri/r300/r300_context.c b/src/mesa/drivers/dri/r300/r300_context.c
    index 12bee1a..4de95f1 100644
    --- a/src/mesa/drivers/dri/r300/r300_context.c
    +++ b/src/mesa/drivers/dri/r300/r300_context.c
    @@ -374,7 +374,6 @@ GLboolean r300CreateContext(const __GLcontextModes * glVisual,
      ctx->Const.FragmentProgram.MaxNativeTexIndirections =
         PFS_MAX_TEX_INDIRECT;
      ctx->Const.FragmentProgram.MaxNativeAddressRegs = 0; /* and these are?? */
    - ctx->VertexProgram._MaintainTnlProgram = GL_TRUE;
      ctx->FragmentProgram._MaintainTexEnvProgram = GL_TRUE;
     
      driInitExtensions(ctx, card_extensions, GL_TRUE);
    @@ -421,7 +420,8 @@ GLboolean r300CreateContext(const __GLcontextModes * glVisual,
      }
      TCL_FALLBACK(r300->radeon.glCtx,
          RADEON_TCL_FALLBACK_TCL_DISABLE, 1);
    - }
    + } else
    + ctx->VertexProgram._MaintainTnlProgram = GL_TRUE;
     
      return GL_TRUE;
     }
    It appears that there is actually more than just the one line changed.

    You did all of the above changes manually, right?
    Last edited by paradigm2; April 21st, 2009 at 06:17 PM.
    100% Microsoft Free Since April 2, 2009

  9. #19
    Join Date
    Sep 2007
    Beans
    27

    Re: Xpress 200M is very slow

    Quote Originally Posted by paradigm2 View Post
    It appears that there is actually more than just the one line changed. You did all of the above changes manually, right?
    You are right. I did all changes as suggested in the patch. Minus means remove the line, plus means add the line. The locations were different, though, and I do not know why (most probably, they wrote this patch for the git version). So, you have to find the locations.
    After that:
    1) remove this line: ctx->VertexProgram._MaintainTnlProgram = GL_TRUE;
    2) remove this line: }
    3) add these two lines:
    } else
    ctx->VertexProgram._MaintainTnlProgram = GL_TRUE;

    Four changes only.
    Good luck.
    Last edited by sergks; April 21st, 2009 at 07:29 PM.

  10. #20
    Join Date
    Aug 2006
    Location
    New Haven, CT, USA
    Beans
    198
    Distro
    Ubuntu Development Release

    Re: Xpress 200M is very slow

    Quote Originally Posted by sergks View Post
    I would like to try your options. Thank you in advance.
    From 'man radeon':
    Option "EnablePageFlip" "on"
    Option "AccelDFS" "on"
    Option "FBTexPercent" "0"

    From 'man exa':
    Option "EXAOptimizeMigration" "true"
    Option "MigrationHeuristic" "smart"
    (experiment with "greedy" as well)

    Server options:
    Option "BackingStore" "true"

Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •