Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: ATI Catalyst 9.4 Not supporting <R6xx series, and Mobility? / RadeonHD problems

  1. #1
    Join Date
    Jul 2005
    Location
    The Netherlands
    Beans
    209
    Distro
    Ubuntu 13.10 Saucy Salamander

    Exclamation ATI Catalyst 9.4 Not supporting <R6xx series, and Mobility? / RadeonHD problems

    Now, that Jaunty is running X 1.6. Seeing that it will only be supported by Fglrx 9.4 which in it self doesn't support anything older than the R6xx series (the HD series?), I was wondering where the Mobility GPUs fall into. I myself have a X2300 which is an M64 chip (rebranded x1350, M52). Is my M64 part of the R5xx or R6xx, or below?

    Also, running, glxgears with RadeonHD completely hangs my PC.
    Laptop: i7 4800MQ 2.7GHz (~3.7GHz); 2x 4GB Kingston HyperX Genesis 1600MHz; Nvidia 780M 4GB; Crucial M4 256GB SSD; Ubuntu 13.10 x64 and Windows 8.1 x64.
    Ubuntu #8076 / Linux #429448

  2. #2
    Join Date
    Oct 2005
    Beans
    36

    Re: ATI Catalyst 9.4 Not supporting <R6xx series, and Mobility? / RadeonHD problems

    yes. i have toshiba notebook with ati mobility radeon hd 2600. but this model doesn't support by latest fglrx driver. this is an important problem. and must be fixed quickly..

  3. #3
    Join Date
    Oct 2004
    Location
    Albuquerque New Mexico, U
    Beans
    712
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: ATI Catalyst 9.4 Not supporting <R6xx series, and Mobility? / RadeonHD problems

    Have you tried the xserver-xorg-video-radeon driver? Withe the latest support packages in Jaunty it should be full-function for pre R6XX chipsets.
    regards

  4. #4
    Join Date
    Oct 2005
    Beans
    36

    Re: ATI Catalyst 9.4 Not supporting <R6xx series, and Mobility? / RadeonHD problems

    yes. i installed xserver-xorg-video-radeon and xserver-xorg-video-radeonhd. but my problem not solved. "Desktop effects could not be enabled"

    glxinfo :
    name of display: :0.0
    display: :0 screen: 0
    direct rendering: Yes

    i don't understand.^^..

    lspci:

    00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
    00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)
    00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
    00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
    00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
    00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
    00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
    00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
    00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
    00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
    00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
    00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
    00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
    00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
    00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
    00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
    00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
    00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
    00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
    01:00.0 VGA compatible controller: ATI Technologies Inc M76 [Radeon Mobility HD 2600 Series]
    01:00.1 Audio device: ATI Technologies Inc RV630/M76 audio device [Radeon HD 2600 Series]
    04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
    05:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
    0c:04.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
    0c:04.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
    0c:04.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
    0c:04.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller

  5. #5
    Join Date
    May 2007
    Location
    Vermont
    Beans
    869
    Distro
    Ubuntu

    Re: ATI Catalyst 9.4 Not supporting <R6xx series, and Mobility? / RadeonHD problems

    I also have the mobility 2600 and the fglrx driver does "work" compiz is EXTREMELY slow (was fine in 9.2) is therew a way to get compiz with the opensource driver?
    Desktop: Windows 8 x64 | Intel Core i5-2500 | 16 GB DDR3 1333 | ATI 6950 2gb | 64gb Vertex 2/320gb/750gb/1tb hdd
    Laptop: System76 Lemur Ultra | Xubuntu 13.04 x64 | 2.5Ghz Intel Core i5-3210m | 8GB DDR31600 | Intel HD4000 | 500GB 7200rpm hybrid hdd

  6. #6
    Join Date
    Oct 2004
    Location
    Albuquerque New Mexico, U
    Beans
    712
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: ATI Catalyst 9.4 Not supporting <R6xx series, and Mobility? / RadeonHD problems

    Quote Originally Posted by rbmorse View Post
    Have you tried the xserver-xorg-video-radeon driver? Withe the latest support packages in Jaunty it should be full-function for pre R6XX chipsets.
    My error. HD2600 is an RV630. FGLRX should work. Have you tried installing the repository version via restricted driver manager? Note that the version in repository is a special beta version with xserver 1.6 support and differs from the drivers available directly from ATI.
    regards

  7. #7
    Join Date
    May 2007
    Location
    Vermont
    Beans
    869
    Distro
    Ubuntu

    Re: ATI Catalyst 9.4 Not supporting <R6xx series, and Mobility? / RadeonHD problems

    Quote Originally Posted by rbmorse View Post
    My error. HD2600 is an RV630. FGLRX should work. Have you tried installing the repository version via restricted driver manager? Note that the version in repository is a special beta version with xserver 1.6 support and differs from the drivers available directly from ATI.
    AFAIK the mobility radeon 2600 is different and is based on R520 though. Although jaunty's FGLRX does work with it it works pretty poorly for me.
    Desktop: Windows 8 x64 | Intel Core i5-2500 | 16 GB DDR3 1333 | ATI 6950 2gb | 64gb Vertex 2/320gb/750gb/1tb hdd
    Laptop: System76 Lemur Ultra | Xubuntu 13.04 x64 | 2.5Ghz Intel Core i5-3210m | 8GB DDR31600 | Intel HD4000 | 500GB 7200rpm hybrid hdd

  8. #8
    Join Date
    Mar 2008
    Location
    India
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: ATI Catalyst 9.4 Not supporting <R6xx series, and Mobility? / RadeonHD problems

    I do have to say that ATI support has gone down hill in 9.04...even the open source drivers. I mean I had no issues with open source drivers in 8.10, they seemed to work as good as fglrx. But in 9.04, there seems to lots of issues with redraw...may its compiz but it's really slow.

  9. #9
    Join Date
    Jun 2007
    Location
    Charlotte, NC, USA
    Beans
    3,121
    Distro
    Ubuntu Development Release

    Re: ATI Catalyst 9.4 Not supporting <R6xx series, and Mobility? / RadeonHD problems

    I have to chime in and say that ATI has abandoned too many of it's slightly dated cards. I'm about to remove Jaunty and go back to Hardy (AGAIN). The open source drivers are good to have, but just too darned slow for me.

    What really bothers me is that only Intrepid/Jaunty will work out of the box with many mobile broadband USB dongles. I use these at work and have to boot into windows if I want decent responsiveness and mobile broadband.

    Hardy is responsive but mobile networking just isn't there.
    Mac Pro 5,1 6-Core@3.33 GHz, 48 GB, ATI HD 5870
    Optical-Apple Super Drive & MCE Internal Blu-ray
    1 TB WD, 5 TB Barracuda(s), 500 GB Hitachi RAID0
    HP RocketU 1144C USB 3.0 Raid / Inateck USB 3.0

  10. #10
    Join Date
    Jul 2005
    Location
    The Netherlands
    Beans
    209
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: ATI Catalyst 9.4 Not supporting <R6xx series, and Mobility? / RadeonHD problems

    Can't play True Combat: Elite, Can't watch Videos with OpenGL rendering (all other outputs do terrible scaling), can't play Stepmania, it all either hangs after a while or doesn't start at all with the Radeon drivers (xf86-video-ati).
    Laptop: i7 4800MQ 2.7GHz (~3.7GHz); 2x 4GB Kingston HyperX Genesis 1600MHz; Nvidia 780M 4GB; Crucial M4 256GB SSD; Ubuntu 13.10 x64 and Windows 8.1 x64.
    Ubuntu #8076 / Linux #429448

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •