Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Nvidia display help

  1. #11
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: Nvidia display help

    nvnews.net run some good forums too.

  2. #12
    Join Date
    Apr 2009
    Beans
    11

    Re: Nvidia display help

    Quote Originally Posted by nickrout View Post
    nvnews.net run some good forums too.
    Cool, thanks!

  3. #13
    Join Date
    Apr 2009
    Beans
    11

    Re: Nvidia display help

    Solved it! Here's how in case anyone wants to know.

    The Nvidia drivers where picking the wrong settings for the TV. What I did was switched to the Nouveau drivers. These, of course, didn't work for the onboard 9400, but what they did do was give me the correct Modeline for my TV (in the Xorg.0.log file). I then used that Modeline with the official Nvidia driver. Success!

  4. #14
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: Nvidia display help

    Quote Originally Posted by KeefTM View Post
    Solved it! Here's how in case anyone wants to know.

    The Nvidia drivers where picking the wrong settings for the TV. What I did was switched to the Nouveau drivers. These, of course, didn't work for the onboard 9400, but what they did do was give me the correct Modeline for my TV (in the Xorg.0.log file). I then used that Modeline with the official Nvidia driver. Success!
    For future reference you should share your modeline with the forum!

    Perhaps too the steps to get that modeline (your description is a little vague).

  5. #15
    Join Date
    Apr 2009
    Beans
    11

    Re: Nvidia display help

    Quote Originally Posted by nickrout View Post
    For future reference you should share your modeline with the forum!

    Perhaps too the steps to get that modeline (your description is a little vague).
    Sure thing:

    Modeline "1280x720" 74.25 1280 1390 1430 1650 720 725 730 750 +hsync +vsync

    1) change driver to "nouveau" where it is currently "nvidia"
    2) restart system (or just X)
    3) check the Xorg.0.log file for a list of lines that contains "Modeline". It only found a few for my set, and it was after all the resolutions it tested.
    4) insert those modelines into the "Monitor" section of the xorg.conf
    5) Add this to the "Device" section:

    Option "UseEDID" "FALSE"
    Option "UseEdidFreqs" "FALSE"

    6) change driver back to "nvidia"
    7) Under SubSection "Display", add

    Modes "name of modeline you want to use (it's the resolution in quotes right after the word 'Modeline')"

    8) reboot (or restart X)

    That's what I did to get it working.

  6. #16
    Join Date
    Apr 2005
    Beans
    3

    Re: Nvidia display help

    Found this thread today after struggling with getting my new tv (same model as the OP) working last night. If you happen to still be monitoring this thread would you mind posting up your full xorg.conf file? I'll be trying your steps tonight. If I get it working I'll post up my full config too in case others have issues.

  7. #17
    Join Date
    Apr 2005
    Beans
    3

    Re: Nvidia display help

    I actually have the same motherboard as the OP. After trying the modeline in the last post on this thread I still get nowhere. The best I can get the nvidia driver to do is 640x480. This is in Ubuntu (mythbuntu i guess) 9.10.

  8. #18
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: Nvidia display help

    Quote Originally Posted by chong View Post
    I actually have the same motherboard as the OP. After trying the modeline in the last post on this thread I still get nowhere. The best I can get the nvidia driver to do is 640x480. This is in Ubuntu (mythbuntu i guess) 9.10.
    look in the log

  9. #19
    Join Date
    Apr 2005
    Beans
    3

    Re: Nvidia display help

    So after pouring through logs and documentation for the past 4 hours here's what I came up with. My problem was that for whatever reason the driver wouldn't honor the modeline. It kept bailing with the following error:

    Code:
    (WW) NVIDIA(0): No valid modes for "1280x720"; removing.
    So after pouring through google and the docs I found this little tidbit:

    Code:
    Option "ConnectedMonitor" "DFP"
    Option "ExactModeTimingsDVI" "TRUE"
    What those options do is to turn off the autodetect when the driver loads (I know I plugged it into HDMI, I don't need the driver to figure that out for me) and to actually force the Modeline that was posted above.

    For the most part the modeline makes sense with what's in the TV manual. What doesn't make sense is the +hsync +vsync options. The TV manual for our TV states that for 1280x720 that these options are extraneous. So far it doesn't appear to be hurting anything so I'll keep it.

    As promised here's my xorg.conf file:


    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildd@crested)  Sun Feb  1 20:25:37 UTC 2009
    
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
    # commented out by update-manager, HAL is now used and auto-detects devices
    # Keyboard settings are now read from /etc/default/console-setup
    #    InputDevice    "Keyboard0" "CoreKeyboard"
    # commented out by update-manager, HAL is now used and auto-detects devices
    # Keyboard settings are now read from /etc/default/console-setup
    #    InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "0"
    EndSection
    
    # commented out by update-manager, HAL is now used and auto-detects devices
    # Keyboard settings are now read from /etc/default/console-setup
    #Section "InputDevice"
    
    #    # generated from default
    #    Identifier     "Keyboard0"
    #    Driver         "kbd"
    #EndSection
    
    # commented out by update-manager, HAL is now used and auto-detects devices
    # Keyboard settings are now read from /etc/default/console-setup
    #Section "InputDevice"
    #    # generated from default
    #    Identifier     "Mouse0"
    #    Driver         "mouse"
    #    Option         "Protocol" "auto"
    #    Option         "Device" "/dev/psaux"
    #    Option         "Emulate3Buttons" "no"
    #    Option         "ZAxisMapping" "4 5"
    #EndSection
    
    Section "Monitor"
        Identifier     "Configured Monitor"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
    #    ModelName      "SHARP HDMI"
        HorizSync       15.0 - 46.0
        VertRefresh     59.0 - 61.0
            ModelName       "Samsung DLP"
            Modeline "1280x720"   74.25  1280 1390 1430 1650  720 725 730 750 +hsync +vsync
    #       Option "ModeDebug" "TRUE"
    EndSection
    
    #Section "Device"
    #    Identifier     "Configured Video Device"
    #    Driver         "nvidia"
    #    Option         "UseEvents" "1"
    #    Option         "DPI" "100x100"
    #    Option         "NoLogo" "1"
    #       Option  "UseDisplayDevice"      "DFP"
    #EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 9400"
    #       Option  "DPI"   "100x100"
            Option "UseEDID" "FALSE"
            Option "UseEdidFreqs" "FALSE"
    #       Option  "UseDisplayDevice"      "DFP"
    #       Option  "NoLogo"        "1"
    EndSection
    
    #Section "Screen"
    #    Identifier     "Default Screen"
    #    Device         "Configured Video Device"
    #    Monitor        "Configured Monitor"
    #    DefaultDepth    24
    #EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
            Option  "ConnectedMonitor"      "DFP"
            Option  "ExactModeTimingsDVI"   "TRUE"
    #    Option         "metamodes" "1280x720 +0+0"
        SubSection     "Display"
            Depth       24
            Modes   "1280x720"
    #       Modes   "1280x720_60.00"
        EndSubSection
    EndSection

  10. #20
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: Nvidia display help

    Quote Originally Posted by chong View Post
    So after pouring through logs and documentation for the past 4 hours here's what I came up with. My problem was that for whatever reason the driver wouldn't honor the modeline. It kept bailing with the following error:

    Code:
    (WW) NVIDIA(0): No valid modes for "1280x720"; removing.
    So after pouring through google and the docs I found this little tidbit:

    Code:
    Option "ConnectedMonitor" "DFP"
    Option "ExactModeTimingsDVI" "TRUE"
    What those options do is to turn off the autodetect when the driver loads (I know I plugged it into HDMI, I don't need the driver to figure that out for me) and to actually force the Modeline that was posted above.

    For the most part the modeline makes sense with what's in the TV manual. What doesn't make sense is the +hsync +vsync options. The TV manual for our TV states that for 1280x720 that these options are extraneous. So far it doesn't appear to be hurting anything so I'll keep it.

    As promised here's my xorg.conf file:
    Excellent information, thanks for posting

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •