Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: xrandr add screen resolution

  1. #1
    Join Date
    Apr 2006
    Location
    Chicago
    Beans
    97
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    xrandr add screen resolution

    when i go System -> Preferences -> Display

    I'm only offered :

    1360x768 (16:9)
    1152x864 (4:3)

    How do i add more screen resolutions?

    I tried adding more to /etc/X11/xorg.conf but its not showing up in the options box.

    Thanks

  2. #2
    Join Date
    Oct 2008
    Beans
    1

    Re: xrandr add screen resolution


  3. #3
    Join Date
    Apr 2006
    Location
    Chicago
    Beans
    97
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: xrandr add screen resolution

    Here are the steps

    1. Use xrandr to make sure that the new mode can fit within the maximum framebuffer size
      Code:
      xrandr | grep maximum
    2. Use gtf to create a mode line
      Code:
      gtf 1440 900 59.9
    3. Add new mode using xrandr
      Code:
      xrandr --newmode "1440x900_59.90"  106.29  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync
    4. Add this newly added mode to the desired output (VGA/LVDS etc)
      Code:
      xrandr --addmode VGA 1440x900_59.90
    5. Choose the new mode
      Code:
      xrandr --output VGA --mode 1440x900_59.90



    TO MAKE THE CHANGES PERSISTENT
    Code:
    sudo gedit /etc/X11/xorg.conf
    Find this: (yours might look different than from below)
    Section "Screen"
    Identifier "Primary Screen"
    Device "ATI Technologies, Inc. M22 [Radeon Mobility M300]"
    EndSection

    and add this to it

    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1024x768" "640x480"
    EndSubSection

    so it should all look similar to this:

    Section "Screen"
    Identifier "Primary Screen"
    Device "ATI Technologies, Inc. M22 [Radeon Mobility M300]"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1024x768" "640x480"
    EndSubSection
    EndSection


    MAKE SURE YOU ADD YOUR NEW RESOLUTION TO THE MODES LINE
    Modes "1280x1024" "1024x768" "640x480"


    Thanks to:
    https://wiki.ubuntu.com/X/Config/Res...%20resolutions

    http://www.arunviswanathan.com/node/53

  4. #4
    Join Date
    Mar 2008
    Beans
    4,715
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: xrandr add screen resolution

    Thank you for the nice write-up. =D>

  5. #5
    Join Date
    May 2007
    Location
    Buenos Aires
    Beans
    4
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: xrandr add screen resolution

    In case the frame buffer size is a limitation for the resolution you want to add (it happened to me), just modify/create the "Virtual" parameter in the "Display" subsection of your xorg.conf. Here's how mine looks after configuring the frame buffer size to use my 22' widescreen (resol: 1680x1050)...

    Code:
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    	SubSection "Display"
    		Virtual	2960 1050
    		Depth 24
    		Modes "1680x1050" "1280x800"
    	EndSubSection
    EndSection

  6. #6
    Join Date
    Oct 2010
    Beans
    2

    Re: xrandr add screen resolution

    I am extremely confused right now. I want my screen resolution
    To be 1280x1024 on 60.00mhz and I have an hp vs17e screen
    Any help would be appreciated

  7. #7
    Join Date
    Apr 2006
    Location
    Chicago
    Beans
    97
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: xrandr add screen resolution

    Quote Originally Posted by Alhenry View Post
    I am extremely confused right now. I want my screen resolution
    To be 1280x1024 on 60.00mhz and I have an hp vs17e screen
    Any help would be appreciated


    This is an old thread and the xrandr info might be out dated. I would suggest you start a new thread and mark it as a karmic question.

  8. #8
    Join Date
    Jan 2011
    Beans
    12

    Re: xrandr add screen resolution [tag: native custom]

    I would just like to add that these instructions worked for me with U10.10, after many attempts reading other posts.

    DO NOT, if using an NVidia 8400 GS graphics card, install the nvidia driver.

    I'm a little confused because my xorg.conf file does not exist. It did before I uninstalled the nvid driver, I need to see what happens when I reboot...

    -----------
    Rebooted
    -----------

    I found a backup, xorg.conf.backup (in /etc/X11). I'm guessing here but I think multiple installs/uninstalls of the nvidia driver must have lost the original xorg.conf that the ubuntu install would have created. Anyway, using the backup as a model, I tried my best to change it to match what max_power originally suggested. It hung at the . . u b u n t u . . splash screen so I obviously got that wrong. I've now removed the xorg.conf file (using recovery mode), allowing it to boot up without it, and have added the xrandr commands to a startup.sh shellscript which I already had anyway. This reports some errors/warnings but I get 1680x1050 so I'm happy for now.

    ----------
    Update
    Don't miss my comments re D-SUB cable that have tripped over onto page 2 of this thread...
    http://ubuntuforums.org/showthread.php?t=1112186&page=2
    ----------

    But.

    Does anyone know how to generate the xorg.conf file, as per the ubuntu install?

    Thanks,
    Cloink.
    Last edited by Cloink; April 12th, 2011 at 06:01 PM. Reason: Further update

  9. #9
    Join Date
    Jan 2011
    Beans
    12

    Re: xrandr add screen resolution

    Bump.

    Does anyone know how to generate the xorg.conf file, as per the ubuntu install?

    Mine has gone missing, probably owing to hoping an install of the nvidia driver would give me a native screen resolution option, which of course it didn't.

  10. #10
    Join Date
    Apr 2011
    Beans
    1

    Re: xrandr add screen resolution

    Quote Originally Posted by max_power View Post
    Here are the steps

    1. Use xrandr to make sure that the new mode can fit within the maximum framebuffer size
      Code:
      xrandr | grep maximum
    2. Use gtf to create a mode line
      Code:
      gtf 1440 900 59.9
    3. Add new mode using xrandr
      Code:
      xrandr --newmode "1440x900_59.90"  106.29  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync
    4. Add this newly added mode to the desired output (VGA/LVDS etc)
      Code:
      xrandr --addmode VGA 1440x900_59.90
    5. Choose the new mode
      Code:
      xrandr --output VGA --mode 1440x900_59.90



    TO MAKE THE CHANGES PERSISTENT
    Code:
    sudo gedit /etc/X11/xorg.conf
    Find this: (yours might look different than from below)
    Section "Screen"
    Identifier "Primary Screen"
    Device "ATI Technologies, Inc. M22 [Radeon Mobility M300]"
    EndSection

    and add this to it

    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1024x768" "640x480"
    EndSubSection

    so it should all look similar to this:

    Section "Screen"
    Identifier "Primary Screen"
    Device "ATI Technologies, Inc. M22 [Radeon Mobility M300]"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1024x768" "640x480"
    EndSubSection
    EndSection


    MAKE SURE YOU ADD YOUR NEW RESOLUTION TO THE MODES LINE
    Modes "1280x1024" "1024x768" "640x480"


    Thanks to:
    https://wiki.ubuntu.com/X/Config/Res...%20resolutions

    http://www.arunviswanathan.com/node/53
    Sir, you're the first to lay out so nicely how to work the mysterious xrandr option of adding a mode.

    Althoug using OpenSuSE myself, you helped me a lot. And then to realize you wrote this 2 years ago!!

    Wonder why there is so little out there about the new setup. It almost made me go back a few versions to be able to use the infamous SaX XOrg configurator...
    You saved me from that horror! I had to use CRT1 instead of VGA, but one finds that out pretty quickly...

    Thanks a bunch.
    Last edited by fnaaijkens; April 12th, 2011 at 11:58 AM. Reason: forgot 1 thing

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •