Results 1 to 5 of 5

Thread: fvwm + Mint 6 (Ubuntu 8.10) = no sound

  1. #1
    Join Date
    Feb 2009
    Beans
    37

    fvwm + Mint 6 (Ubuntu 8.10) = no sound

    Hey guys..

    i got a little problem here - i'm using Mint 6 (based on Ubuntu 8.10) with fvwm. but i don't have sound.

    with
    Code:
    AddToFunc StartFunction	
    + I Exec exec esd
    in my .fvwm2rc, i got mpd to actually start playing, but i still don't hear anything.


    on another note - my down-arrow key doesn't work, either..

    thanks for your help!
    HP DV5: Intel P7350 2x2.0GHz | 4GB RAM | GeForce 9600MGT 512MB | 500GB HDD | debian testing/sid
    » visit the|linuxian

  2. #2
    Join Date
    Aug 2005
    Location
    Fargo, ND, USA
    Beans
    1,499
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: fvwm + Mint 6 (Ubuntu 8.10) = no sound

    PulseAudio has replaced esd. Use
    Code:
    + I Exec pulseaudio -D
    It should be completely backward compatible with esd, and most Ubuntu packages offer the choice are now defaulted to PulseAudio.

    You probably want to add
    Code:
    audio_output {
            type    "pulse"
            name    "PulseAudio"
    }
    to your mpdconf.
    Help yourself: Search the community docs or try other resources.
    Quote Originally Posted by Henry Spencer
    Those who do not understand Unix are condemned to reinvent it, poorly.
    Let science use your computer when you aren't: Folding@Home.

  3. #3
    Join Date
    Aug 2005
    Location
    Fargo, ND, USA
    Beans
    1,499
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: fvwm + Mint 6 (Ubuntu 8.10) = no sound

    on another note - my down-arrow key doesn't work, either..
    Try running
    Code:
    xev
    and press your down arrow key. You should see something like this:
    Code:
    KeyPress event, serial 29, synthetic NO, window 0x3000001,
        root 0x88, subw 0x0, time 3613002304, (596,521), root:(601,548),
        state 0x0, keycode 104 (keysym 0xff54, Down), same_screen YES,
        XLookupString gives 0 bytes: 
        XmbLookupString gives 0 bytes: 
        XFilterEvent returns: False
    
    KeyRelease event, serial 32, synthetic NO, window 0x3000001,
        root 0x88, subw 0x0, time 3613002361, (596,521), root:(601,548),
        state 0x0, keycode 104 (keysym 0xff54, Down), same_screen YES,
        XLookupString gives 0 bytes: 
        XFilterEvent returns: False
    If not, take whatever keycode is in the xev output (104 above) and run the command
    Code:
    xmodmap -e "keycode 104 = Down"
    Help yourself: Search the community docs or try other resources.
    Quote Originally Posted by Henry Spencer
    Those who do not understand Unix are condemned to reinvent it, poorly.
    Let science use your computer when you aren't: Folding@Home.

  4. #4
    Join Date
    Feb 2009
    Beans
    37

    Re: fvwm + Mint 6 (Ubuntu 8.10) = no sound

    Quote Originally Posted by jpkotta View Post
    PulseAudio has replaced esd. Use
    Code:
    + I Exec pulseaudio -D
    It should be completely backward compatible with esd, and most Ubuntu packages offer the choice are now defaulted to PulseAudio.

    You probably want to add
    Code:
    audio_output {
            type    "pulse"
            name    "PulseAudio"
    }
    to your mpdconf.
    i added pulse to my mpdconf a looong time ago

    and
    Code:
    + I Exec pulseaudio -d
    didn't work either. solved it by putting
    Code:
    + I Exec gnome-settings-daemon
    probably not that elegant, but at least i can listen to some music now..


    solved the problem with the down-arrow, too. the creator of the fvwm2rc mapped it to the left super key just removed that line, and everything's perfect again.
    HP DV5: Intel P7350 2x2.0GHz | 4GB RAM | GeForce 9600MGT 512MB | 500GB HDD | debian testing/sid
    » visit the|linuxian

  5. #5
    Join Date
    Aug 2005
    Location
    Fargo, ND, USA
    Beans
    1,499
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: fvwm + Mint 6 (Ubuntu 8.10) = no sound

    Quote Originally Posted by k3ttc4r View Post
    Code:
    + I Exec pulseaudio -d
    didn't work either. solved it by putting
    '-d' doesn't do anything except cause a syntax error. It's case-sensitive.
    Help yourself: Search the community docs or try other resources.
    Quote Originally Posted by Henry Spencer
    Those who do not understand Unix are condemned to reinvent it, poorly.
    Let science use your computer when you aren't: Folding@Home.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •