Results 1 to 9 of 9

Thread: knetworkmanager not working after upgrade to 9.04 beta

  1. #1
    Join Date
    Oct 2005
    Location
    Newcastle NSW, Australia
    Beans
    111
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    knetworkmanager not working after upgrade to 9.04 beta

    After upgrading to Kubuntu 9.04, KNetworkManager no longer opens on startup.

    It also fails to configure wireless connections correctly.



    -- Edit 30/03/2009 @ 1:45pm --

    Manually configured wireless network through the network control panel. "knetworkmanager" is still broken.
    Last edited by deepspring; March 29th, 2009 at 03:45 PM. Reason: Fixed the problem with another solution
    DEEPSPRING ::.
    Links: OCAU ::.

  2. #2
    Join Date
    Mar 2009
    Beans
    1
    Distro
    Kubuntu Jaunty Jackalope (testing)

    Re: knetworkmanager not working after upgrade to 9.04 beta

    Hi
    I'm occuring your same issue..with gnome wifi work, with kde it doesn't start.
    Any adwise?

  3. #3
    Join Date
    Jul 2008
    Location
    Birmingham, England
    Beans
    2,400

    Re: knetworkmanager not working after upgrade to 9.04 beta

    Doesn't kubuntu jaunty come with a plasmoid for networkmanager?

  4. #4
    Join Date
    Oct 2005
    Location
    Newcastle NSW, Australia
    Beans
    111
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: knetworkmanager not working after upgrade to 9.04 beta

    Quote Originally Posted by SuperSonic4 View Post
    Doesn't kubuntu jaunty come with a plasmoid for networkmanager?
    Indeed it does, but mine was disabled for some reason and didn't show up until I manually created the Wireless connection.
    DEEPSPRING ::.
    Links: OCAU ::.

  5. #5
    Join Date
    Oct 2005
    Location
    Newcastle NSW, Australia
    Beans
    111
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: knetworkmanager not working after upgrade to 9.04 beta

    Quote Originally Posted by rinouw View Post
    Hi
    I'm occuring your same issue..with gnome wifi work, with kde it doesn't start.
    Any adwise?

    1. Go into "System Settings" -> "Network Settings" -> "Network Management", click on the "Wireless" tab. Click the "Add" button.
    2. When the "Add Network Connection" window opens, Enter a name for the connection, then select "Connect automatically".
    3. You can either manually enter your wireless networks SSID in the "SSID" box or you can use the "Scan" button to locate it.
    4. Click on the "Wireless Security" tab. Select the type of security (WEP, WPA-PSK, WPA-EAP) you have enabled on your network from the drop down list, enter in your security details.
    5. Click the "OK" button. Then click the "Apply" button on the "Network Settings - System Settings" window.
    6. Close the window.



    With any luck, and after a few seconds an icon should appear next to the clock widget on your panel (see attached screenshot, (hint: its the icon on the left)).
    Attached Images Attached Images
    DEEPSPRING ::.
    Links: OCAU ::.

  6. #6
    Join Date
    Sep 2007
    Location
    Pune, India
    Beans
    445
    Distro
    Kubuntu Development Release

    Re: knetworkmanager not working after upgrade to 9.04 beta

    Some apparent issues with network manager in KDE like no WPA2 for Wifi, VPN/PPTP missing, no static IP support etc.

    So I removed the plasmoid and installed network-manager-gnome (nm-applet) heh, after some fiddling around looks like everything works for me.

    I was going to abandon Kubuntu for Ubuntu due to these issues but now I can stay with KDE since 4.2 is the sweetness....
    Desktop: Unbranded, Q6600 2.4 ghz CPU, Intel DP35DP mobo, 4 GB RAM, 500 GB HDD, 128 GB SSD, NVIDIA 8800GT, Dell E248WFP LCD.
    Laptop: HP Pavilion tx1302au Turion64 X2 TL-58 1.9 ghz CPU, NVIDIA GeForce Go 6150, 2 GB RAM, 64 GB SSD, Broadcom 4321 Wifi.

  7. #7
    Join Date
    Apr 2009
    Beans
    2

    Re: knetworkmanager not working after upgrade to 9.04 beta

    Quote Originally Posted by deepspring View Post
    1. Go into "System Settings" -> "Network Settings" -> "Network Management", click on the "Wireless" tab. Click the "Add" button.
    2. When the "Add Network Connection" window opens, Enter a name for the connection, then select "Connect automatically".
    3. You can either manually enter your wireless networks SSID in the "SSID" box or you can use the "Scan" button to locate it.
    4. Click on the "Wireless Security" tab. Select the type of security (WEP, WPA-PSK, WPA-EAP) you have enabled on your network from the drop down list, enter in your security details.
    5. Click the "OK" button. Then click the "Apply" button on the "Network Settings - System Settings" window.
    6. Close the window.



    With any luck, and after a few seconds an icon should appear next to the clock widget on your panel (see attached screenshot, (hint: its the icon on the left)).
    On my Kubuntu 9.04 I have to follow those steps every time I restart my system.
    Even if I select the "Connect automatically" option, it doesn't.
    I have to go into the Network Manager, then click "Modify" on my last wi-fi connection and then click "Ok" (without changing anything) and the internet goes. The icon in the tray doesn't come up.
    Before upgrading from 8.10, it automatically connected to my home wi-fi, without doing anything.

    Any suggestions to make it work on 9.04 too? Thank you.
    Last edited by sparagnauss; April 19th, 2009 at 09:09 AM.

  8. #8
    Join Date
    Oct 2005
    Location
    Newcastle NSW, Australia
    Beans
    111
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: knetworkmanager not working after upgrade to 9.04 beta

    Quote Originally Posted by sparagnauss View Post
    Any suggestions to make it work on 9.04 too? Thank you.
    I sincerely wish I had a solution for you, but I don't.
    DEEPSPRING ::.
    Links: OCAU ::.

  9. #9
    Join Date
    Apr 2009
    Beans
    52
    Distro
    Kubuntu Jaunty Jackalope (testing)

    Re: knetworkmanager not working after upgrade to 9.04 beta

    The most reliable solution is
    sudo aptitude install wicd
    I here it will be included in KDE 4.3

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •