Results 1 to 2 of 2

Thread: screwed up GRUB royally

  1. #1
    Join Date
    Aug 2008
    Beans
    5
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    screwed up GRUB royally

    So yesterday I decided I was going to completely wipe my hard drive clean and repartition it for windows and ubuntu. First I compressed my (almost entire) current ubuntu filesystem and stored it on another computer. I then wiped the hard drive, repartitioned with partition manager live CD, installed windows on hd0,0, installed ubuntu's main file system on hd0,1, installed the swap partition on hd0,2, and installed a shared FAT32 partition on hd0,3. At this point the dual-boot was working just fine, then I decided I was going to restore my previous linux system, taking my archive and completely overriding the new install with the old one. I didn't think about the fact that GRUB was in the old filesystem but wasn't configured for the new partition scheme. Next time I booted up my computer, I was greeted with a friendly
    Code:
    grub>
    and I realized my error . I then tried who knows how many tricks of fixing/uninstalling/reinstalling/etc. GRUB to try and get it to recognize the new partitions. Most of the time I get fatal errors. I am able to boot to windows using a string of commands in GRUB but that is all the progress I have made. So, now the question is, do you have any ideas about how to fix my errors. The other question I was pondering was, should I have made a /boot partition?

    Thanks for any help,
    gseeli

  2. #2
    Join Date
    Apr 2008
    Beans
    3,317
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: screwed up GRUB royally

    In order to get a clearer picture of your setup, I suggest to boot from the Ubuntu LiveCD and download the Boot Info Script to your desktop:

    https://sourceforge.net/projects/bootinfoscript/

    Then open a terminal (Applications > Accessories > Terminal) and type:

    Code:
    sudo bash ~/Desktop/boot_info_script*.sh
    That will create a "RESULTS.txt" file in the same directory from where the script is run, namely your desktop; please copy/paste the contents of the RESULTS.txt file to your next post, highlight the copied text, and click the pound/hash sign "#" graphic button in the Ubuntu forum message box so that the text will get "code" tags put around it. The results of that script will help clarify your setup and hopefully what the solution to your booting problem might be.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •