Results 1 to 4 of 4

Thread: Howto change dependencies

  1. #1
    Join Date
    Dec 2005
    Beans
    32

    Cool

    While installing monkey audio .deb files from http://www.rarewares.org I found that they failed a minor dependency libstdc++6 (>= 4.0.2) was needed while I had 4.0.1-4ubuntu9, so I decided that I'll try whether it works -- the difference seemed minor. Warning: this may be dangerous to your system. You may end up with a system that is unrepairable. You are off all tracks and on your own if you try this. LIkely apt will awake Godzilla to eat you .

    With that said, dependency information is stored in a file called control. Follow the following simple steps;

    1. dpkg-deb -x foo.deb tmpdir
    2. dpkg-deb --control foo.deb tmpdir/DEBIAN
    3. nano tmpdir/DEBIAN/control
    4. dpkg -b tmpdir hacked.deb


    and there you are, your shiny new .deb file. And yes, monkey audio works

  2. #2
    Join Date
    May 2006
    Beans
    33

    Re: Howto change dependencies

    Thanks for this guide. I had to rebuild some deb files for my printer.

  3. #3
    Join Date
    Feb 2008
    Location
    Pennsylvania
    Beans
    45
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Howto change dependencies

    HOLY CRAP! You are my hero

    I had a problem with a package that needed libc6-i686. With the upgrade to Maverick, this package no longer exists per se (it's now just libc6).

    Followed your guide and voila - problem solved. God I love Linux.

    Thanks much (if you're still around from '05)!

  4. #4
    Join Date
    Oct 2007
    Location
    Kentucky, USA
    Beans
    731
    Distro
    Ubuntu

    Re: Howto change dependencies

    Thanks for THIS!! Boxee needed a dependency which was changed
    Which is more important in obtaining the truth, "what" or "why"? Trick question. They are of equal importance.
    Freely ye have received, freely give.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •