Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Default keyring prompt at startup

  1. #1
    Join Date
    Mar 2009
    Location
    Northern Ireland
    Beans
    175
    Distro
    Ubuntu 13.10 Saucy Salamander

    Post Default keyring prompt at startup

    Last query of the day...

    When I log in and immediately when the Desktop shows, I get the following message prompt (Ubuntu 8.10):

    Enter Password for default keyring to unlock

    The application "Network manager Applet" (/urs/bin/nm-applet) wants access to the default keyring, but is locked

    On a probably related note, I have a cabled ethernet connection to my wireless router but also have a wireless connection - every time I log in I've to untick the "enable wireless" button, as soon as I log out this seems to reset.

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: Default keyring prompt at startup

    Are you using automatic login or do you have to input your username and password before getting to the desktop?

    This problem is usually related to automatic login.

    I have the same problem on a notebook running 8.10 here. Unfortunately, I couldn't get rid of the keyring alert, even after using several methods suggested on other threads. Disabling automatic login is not an option in my case, but maybe is for you.

  3. #3
    Join Date
    Mar 2009
    Location
    Northern Ireland
    Beans
    175
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Default keyring prompt at startup

    I am using automatic log in (though for some reason it has only worked intermittently so far) - will try disabling it.

  4. #4
    Join Date
    Jun 2008
    Location
    Sweden
    Beans
    11
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Default keyring prompt at startup

    I have the same problem, but I'm not using automatic login.

    I did not have this problem until recently, when I changed my login password. I have to enter my old password everytime I want to conect to the internet, I havn't even found a way to change the password for my default keyring..
    Last edited by openess; March 21st, 2009 at 09:07 PM. Reason: enter instead of edit - misspell

  5. #5
    Join Date
    Mar 2009
    Location
    Northern Ireland
    Beans
    175
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Default keyring prompt at startup

    well disabling automatic login meant the prompts went away. Does this constitute a bug worth reporting?

  6. #6
    Join Date
    Aug 2005
    Beans
    Hidden!

    Re: Default keyring prompt at startup

    Goto Network Connections either by:
    1. Right-clicking on the network applet and selecting "Edit Connections"
    2. or selecting System -> Preferences -> Network Configuration

    The network manager may request access to your keyring upon login if you have modified or added network connections. In my case I had once tried to connect to a wireless network and couldn't but it configured it in network connections anyway and every time I logged in it would request access to the keyring and try to connect to the wireless network.

    Deleting the wireless connection in network manager solved the problem.

  7. #7
    Join Date
    Dec 2007
    Location
    Galway, Ireland
    Beans
    316
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Default keyring prompt at startup

    This is happening because when Network Manager is about to use your saved password to authenticate to your network it first needs your permission (to make sure it's you...)
    To get rid ("fix") of this:
    Go to Applications -> Accessories -> Passwords and Encryption Keys
    Click Edit -> Preferences
    Select the line that says:

    Code:
    login Automatically unlocked when user logs in.
    Click Change Unlock Password, type in your Old password and leave fields for new password empty. That's it!

    Don't worry, you are not changing your password really, you are just... let's say, lowering security. Something like turning those stupid messages that ask for your permission to do anything on Vista off....

  8. #8
    Join Date
    Jun 2008
    Location
    Sweden
    Beans
    11
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Default keyring prompt at startup

    Quote Originally Posted by aquascrotum View Post
    well disabling automatic login meant the prompts went away. Does this constitute a bug worth reporting?
    I'm not using automatic login and still have the problem.

    and I still wan't to keep my settings for the networks I'm using, there are a few of them and I wouldn't want to connect to everyone "for the first time" every time, especialy the one in school was a ******* to set up :/

  9. #9
    Join Date
    Dec 2007
    Location
    Galway, Ireland
    Beans
    316
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Default keyring prompt at startup

    Quote Originally Posted by openess View Post
    I'm not using automatic login and still have the problem.
    Automatic login has nothing to do with this. See my previous post for the fix.

  10. #10
    Join Date
    Jun 2008
    Location
    Sweden
    Beans
    11
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Default keyring prompt at startup

    thanx for the help lunatico, sound like a good temporary solution, but I'm not that hapy about lowering secutity, feels strange..

    What security am I lowering, and I don't really understand vista references.. Never used it

    sorry btw for posting on top of your post last time, I'm a slow writer.
    Last edited by openess; March 21st, 2009 at 09:33 PM.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •