Results 1 to 3 of 3

Thread: Two Dial-Up Problems with Network Manager and Gnomoe PPP0

  1. #1
    Join Date
    Jun 2005
    Location
    Wellington, New Zealand
    Beans
    38

    Two Dial-Up Problems with Network Manager and Gnomoe PPP0

    Hello

    I'd be grateful if someone could help me fix two dial-up problems that I seem to have created by fiddling with Network Manager and Gnome PPP0 settings (in an attempt to prevent our desktop computer from automatically dialing-up to the Internet during the boot process - not sure why/how that happened).

    Our system uses Hardy Heron, and an external serial modem.

    First Problem: I can no longer use the Network Monitor icon in the panel on the desktop to manually dial-in to the Internet. When I try to do so now, the following message appears: “SIOCGIFFLAGS error: No such device”.

    The /etc/network/interfaces file reads:

    auto lo
    iface lo inet loopback

    iface ppp0 inet ppp
    provider ppp0

    auto ppp0


    Second Problem: While dial-up through Gnome PPP0 works, the special Gnome PPP0 network monitor icon - the blue coloured one, with larger monitors than the “other” icon - that is required to disconnect from the Internet, has disappeared! The .wvdial.conf file in the /home/... directory includes the following lines:

    ;Minimize = on

    ;Dock = on

    I tried removing the semicolons to see if that would restore the icon, but the file appears empty when I open it in Terminal using sudo, even though I can read it in the File Browser.

    The Gnome PPP0 Connection Log includes the following messages:
    --> Ignoring malformed input line: ";Do NOT edit this file by hand!"

    --> WvDial: Internet dialer version 1.60

    --> Cannot set information for serial port.

    and

    --> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied

    --> --> PAP (Password Authentication Protocol) may be flaky.

    --> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied

    --> --> CHAP (Challenge Handshake) may be flaky.


    Thank you

  2. #2
    Join Date
    Nov 2005
    Location
    Washington State
    Beans
    2,324
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Two Dial-Up Problems with Network Manager and Gnomoe PPP0


  3. #3
    Join Date
    Aug 2008
    Location
    germany
    Beans
    857

    Re: Two Dial-Up Problems with Network Manager and Gnomoe PPP0

    Quote Originally Posted by Weta View Post
    Hello
    The .wvdial.conf file in the /home/ ....

    empty when I open it in Terminal using sudo,
    YOU SHOULD NOT OPEN A FILE IN YOUR HOME DIR AS root unless you know what your doing (this is, deleting the file)

    But this is not and by no means ever necessary, $HOME is the userspace of app configurations, while you may set GLOBAL configs in your /etc/ folder.

    Most apps allow for the default config done by root to be overwritten IF there's a config in userspace. Some few apps don't allow and your settings will be mandatory for all users.

    However, I'd suggest you keep it down to your home directory, and as I said, dont create or save a file to your home as root.

    It ain't the best idea to have the same theme for root and `whoami`, just because you could easily mess up your permissions and have your login rejected cause some files persmissions changed.

    So, you only need root if you wanna make a global setting, install apps which shall be available to all users, and so on.

    Mind, UNIX is a multiuser system, even if you're the only one using your desktop it's setup to be able to handle users and groups easily (as root = admin) and still provide different users with different priviledges and objects to refer to.

    Mind that, otherwise you'll be sudo'in yourself out of your box.

    To change permissions on files in your home folder in case some of them are already owned by root (pretty likely eh)
    chmod 755 $file

    This will make it rwx for you, and assuming you haven't changed you default mask read and executable for group members and other users.

    Note: there are non-human users on your system. Usually they're called system users, or system groups if its a group.
    I, for example, created a media group and another opt group.

    For groups, you may set the GID on some directory, which will make any created file be created with media as group.

    If you add yourself to the mediagroup and finally change modes and set gid:
    (assuming your media dir is somewhere else, so NOT in your home dir)
    sudo chmod g+swrx MyMedia/

    Upon login you should have write permissions in that folder as `whoami`, your user basically. Try avoiding root if possible.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •