Page 4 of 4 FirstFirst ... 234
Results 31 to 37 of 37

Thread: gmote - help installing a .sh file

  1. #31
    Join Date
    Nov 2007
    Beans
    6

    Re: gmote - help installing a .sh file

    I'm running 10.10 and found I had to add a 'sleep' delay in the gmote script:

    Code:
    #!/bin/sh
    sleep 10
    cd /home/USER/.gmote && ./GmoteServer.sh
    If I didn't do this the gmote server would not respond to gmote client commands and the JVM would start chewing up a lot of CPU cycles after freshly booting the machine. Unfortunately I don't really have an explanation to why this was happening but the sleep delay seemed to help. If anyone has an explanation I would really appreciate it. Thanks.

    Quote Originally Posted by Remanifest View Post
    It's a bit clunky, but I came up with a solution. For it to work properly, Gmote Server requires that you be inside of its directory when you start it.

    If you haven't done so already, move the Gmote Server folder to ~/.gmote or something similar, so it stays out of your way.

    Next, we'll create a file using nano.

    Code:
    nano gmote
    Once nano is open, insert the following, being sure to change the path to where Gmote lives:
    Code:
    #!/bin/sh
    cd /home/USER/.gmote && ./GmoteServer.sh
    Next, we'll make it executable and move it to /usr/bin
    Code:
    chmod +x ./gmote
    sudo mv ./gmote /usr/bin/gmote
    On the Gnome menu, go to System>Preferences>Sessions and click Add. Name it whatever you want, and under command, put "/usr/bin/gmote" (without quotes). Save it, and you're done.

  2. #32
    Join Date
    Jun 2009
    Beans
    12

    Re: gmote - help installing a .sh file

    Thank you very much. Problem solved for me..

  3. #33
    Join Date
    Jan 2008
    Location
    Coventry, UK
    Beans
    74
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: gmote - help installing a .sh file

    Quote Originally Posted by Remanifest View Post
    It's a bit clunky, but I came up with a solution. For it to work properly, Gmote Server requires that you be inside of its directory when you start it.

    If you haven't done so already, move the Gmote Server folder to ~/.gmote or something similar, so it stays out of your way.

    Next, we'll create a file using nano.

    Code:
    nano gmote
    Once nano is open, insert the following, being sure to change the path to where Gmote lives:
    Code:
    #!/bin/sh
    cd /home/USER/.gmote && ./GmoteServer.sh
    Next, we'll make it executable and move it to /usr/bin
    Code:
    chmod +x ./gmote
    sudo mv ./gmote /usr/bin/gmote
    On the Gnome menu, go to System>Preferences>Sessions and click Add. Name it whatever you want, and under command, put "/usr/bin/gmote" (without quotes). Save it, and you're done.
    Hi, I'm really struggling with this. Having followed these instructions I can now launch by:

    russ@russ-desktop:~$ cd /usr/bin/gmote
    russ@russ-desktop:/usr/bin/gmote$ sh GmoteLaunch.sh

    But Gmote still doesn't launch on startup. I used Gedit rather than nano - what should I call that file? And where should it be saved? Any help much appreciated

  4. #34
    Join Date
    Apr 2010
    Location
    /home
    Beans
    68
    Distro
    Ubuntu Development Release

    Re: gmote - help installing a .sh file

    Im sttill having the same error as the op. I updated java set sun java to be the default and still get the same error

    Edit: i get this error when attempting to play a song
    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    # SIGSEGV (0xb) at pc=0xb770b3a0, pid=2852, tid=2346515312
    #
    # JRE version: 6.0_24-b07
    # Java VM: Java HotSpot(TM) Server VM (19.1-b02 mixed mode linux-x86 )
    # Problematic frame:
    # C [libc.so.6+0xcd3a0] tfind+0x20
    #
    # An error report file with more information is saved as:
    # /home/xbmc/Desktop/GmoteServerLinux2.0.0/hs_err_pid2852.log
    #
    # If you would like to submit a bug report, please visit:
    # http://java.sun.com/webapps/bugreport/crash.jsp
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.
    #
    Last edited by arrimapirate; July 2nd, 2011 at 08:12 PM.

  5. #35
    Join Date
    Dec 2005
    Location
    capital of beer
    Beans
    547

    Re: gmote - help installing a .sh file

    Am getting similar error with openjdk7. Have tried all approaches in this thread bar installing Oracle's java (in which case it probably would work...).

    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    # SIGBUS (0x7) at pc=0x00007f31d102d7f8, pid=20267, tid=139850575496960
    #
    # JRE version: 7.0_03-b147
    # Java VM: OpenJDK 64-Bit Server VM (22.0-b10 mixed mode linux-amd64 compressed oops)
    # Derivative: IcedTea7 2.1
    # Distribution: Custom build (Wed Feb 15 14:16:08 UTC 2012)
    # Problematic frame:
    # C [libc.so.6+0xe07f8] tfind+0x18
    #
    # Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
    #
    # An error report file with more information is saved as:
    # /home/toad/.gmote/hs_err_pid20267.log
    #
    # If you would like to submit a bug report, please include
    # instructions on how to reproduce the bug and visit:
    # http://icedtea.classpath.org/bugzilla
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.
    #
    Also, the steps in post #18 don't make a lot of sense to me.
    If you haven't done so already, move the Gmote Server folder to ~/.gmote or something similar, so it stays out of your way.

    Next, we'll create a file using nano.


    nano gmote
    Once nano is open, insert the following, being sure to change the path to where Gmote lives:

    #!/bin/sh
    cd /home/USER/.gmote && ./GmoteServer.sh

    Next, we'll make it executable and move it to /usr/bin

    chmod +x ./gmote
    sudo mv ./gmote /usr/bin/gmote
    In which directory is the file gmote and in the example above are we not attempting to move the entire ~/.gmote folder to /usr/bin?
    Last edited by ingo; February 29th, 2012 at 11:50 AM.
    repartitioning your installation / forever noob / Desktop on Debian Lenny / IBM T41 purring along on bog Kubuntu

  6. #36
    Join Date
    Oct 2009
    Beans
    5

    Re: gmote - help installing a .sh file

    Quote Originally Posted by Remanifest View Post
    It's a bit clunky, but I came up with a solution. For it to work properly, Gmote Server requires that you be inside of its directory when you start it.

    If you haven't done so already, move the Gmote Server folder to ~/.gmote or something similar, so it stays out of your way.

    Next, we'll create a file using nano.

    Code:
    nano gmote
    Once nano is open, insert the following, being sure to change the path to where Gmote lives:
    Code:
    #!/bin/sh
    cd /home/USER/.gmote && ./GmoteServer.sh
    Next, we'll make it executable and move it to /usr/bin
    Code:
    chmod +x ./gmote
    sudo mv ./gmote /usr/bin/gmote
    On the Gnome menu, go to System>Preferences>Sessions and click Add. Name it whatever you want, and under command, put "/usr/bin/gmote" (without quotes). Save it, and you're done.
    Great advice - thanks for the guide. I had a bit of trouble getting it to work. After moving the gmote executable file into the bash directory, I tested it by typing 'gmote' in a terminal and kept getting an error message saying something like "Unable to open file GmoteServer.sh".

    I found that I could run GmoteServer.sh with the code:
    Code:
    cd /home/USER/.gmote
    sh ./GmoteServer.sh
    This would open the server. So, I adjusted the gmote script to:
    Code:
    #!/bin/sh
    cd /home/USER/.gmote && sh ./GmoteServer.sh
    And everything was hunky dorey. It now automatically starts on log in, or I can start it by typing 'gmote' in a terminal. I'm really impressed with this bit of software! Its really satisfying with it hooked up to my media pc in my lounge and I don't have to dig out a bulky keyboard and mouse when doing simple tasks.

    My next task is to find a similar thing that will work with an ipad and ubuntu.

  7. #37
    Join Date
    May 2010
    Beans
    9

    Re: gmote - help installing a .sh file

    Hi everybody,

    I have struggled for a couple of weeks on Gmote and its installation, and now that it runs correctly, I'll share my experience.

    I'm running Ubuntu 10.04 and had OpenJDK as a java machine.

    I found out that the Sun version of Java worked with Gmote - otherwise I had the java.awt.SystemTray error.

    I downloaded this version of Java.

    I let you follow the instructions there, I will only copy the code extracts - and adapt them to my case/choice
    Code:
    sudo cd /usr/java/
    sudo tar zxvf jre-7u7-linux-i586.tar.gz
    Then I found out here that the java machine had to be somehow registered in the system.

    Code:
    sudo update-alternatives --install "/usr/bin/java" "java" "/usr/lib/jvm/jdk1.7.0_04/bin/java" 1
    sudo update-alternatives --config java
    As GmoteServer must run in local, I changed the code in GmoteServer.sh: at the beginning of the file, I added the line
    Code:
    cd /usr/GmoteServerLinux2.0.0
    Delay on startup is needed, as said earlier in this thread, and in that one.
    So I created a file GmoteServerStartup.sh as a copy of GmoteServer.sh for the specific needs of the startup.
    at the beginning of GmoteServerStartup.sh, I added line
    Code:
    sleep 10
    Then I moved folder GmoteServerLinux2.0.0 to /usr/
    Code:
    sudo mv GmoteServerLinux2.0.0 /usr/GmoteServerLinux2.0.0
    To create shortcuts in the Main Menu and the Startup Applications list, I created links in /usr/bin
    Code:
    sudo cp -l /usr/GmoteServerLinux2.0.0/GmoteServer.sh /usr/bin/GmoteServer
    sudo cp -l /usr/GmoteServerLinux2.0.0/GmoteServerStartup.sh /usr/bin/GmoteServerStartup
    Then I added GmoteServer to the Main Menu, in Sound & Video, and added GmoteServerStartup to the Startup Applications with comment: Starts Gmote after a short delay to allow Java to start.

    In case of problem of permission for GmoteServerStartup, you have to change the ownership of the file (replace <user> by your user login)
    Code:
    sudo chown <user> /usr/GmoteServerLinux2.0.0/GmoteServerStartup.sh
    That's all I know! Hope it helps...

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •