Results 1 to 6 of 6

Thread: Another "basic help" thread

  1. #1
    Join Date
    May 2005
    Beans
    47

    Another "basic help" thread

    Okay, so I was on myspace loading pages when I noticed that xmms couldn't play wmv files. No idea how to GET IT to play wmv files (or make firefox notice a different browser...any help there is appreciated) but I did find some plugins on xmms' website to play avi files.

    So I downloaded the plug in, and got the buildessentials package and ran ./configure (from the directory that I extracted the files into) only to face this error:
    configure: error: *** GLIB >= 1.2.2 not installed - please install first
    I've seen this a LOT and read a lot of forums about it but none of them seemed to come to a resolution that helped me. Anyone got an idea on this?
    Thankx guys

  2. #2
    Join Date
    Mar 2005
    Beans
    6,040

    Re: Another "basic help" thread

    Why do you want to play wmv files with XMMS? Did you install the multimedia codecs? Also install the mozilla-mplayer package to view videos inside the browser.
    Previously known as 23meg

  3. #3
    Join Date
    Nov 2005
    Location
    Wellington, New Zealand
    Beans
    34
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Another "basic help" thread

    Ubuntu (like most Linux dirstibutions) separates development libraries from the run-time system.

    This error indicates that you need to install the development package that glib is associated with. Ubuntu has both 1.2 and 2.0 installed. The development libraries can be installed with
    Code:
     apt-get install libglib1.2-dev libglib2.0-dev
    NOTE: There are bound to be other libraries for which you need the development versions. Check the documentation for the plugin, to see what it needs, and install the "-dev" version of each such library.

  4. #4
    Join Date
    May 2005
    Beans
    47

    Re: Another "basic help" thread

    Okay so that much is working, and now I'm getting this error: "configure: error: *** GTK+ >= 1.2.2 not installed - please install first ***"

    Which packages do I need for this here? Is there an easier way to tell for the future other than posting on here? Basically I did an apt-cache search for gtk 1.2 and other miscellaneous GTK searches and got a whole lotta results that dinnae help.

  5. #5
    Join Date
    Jun 2005
    Location
    Malta
    Beans
    4,187
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Another "basic help" thread

    Why XMMS???? Mplayer, Xine and the like are all better suited to playing video files...and more modern too. XMMS is using GTK 1.2, years old.

  6. #6
    Join Date
    May 2005
    Beans
    47

    Re: Another "basic help" thread

    Well that's one of the questions I had as well, how DO I change the default video/file player for firefox? I was trolling through myspace one day and noticed that firefox was trying to load xmms to play the wmv files some people have embedded in their profiles.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •