Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 41

Thread: Installation crashes on the new early 2009 White Macbooks

  1. #21
    Join Date
    Aug 2005
    Location
    Huntsville, AL, USA
    Beans
    7,526
    Distro
    Ubuntu

    Re: Installation crashes on the new early 2009 White Macbooks

    Quote Originally Posted by sturuko View Post
    other issuses:
    -grub&lilo does not work
    -grub-pc (v. 1.95, from intrepid or from jaunty debs) freezes if i try to change the boot kernel in the grub boot menù or if i hit any button on the keyboard
    -instead, it works fine with the svn-compiled version

    can someone confirm these things?
    the grub2 sources were just heavily patched for Macs recently. The svn version has these fixes now. You would probably have the same problems on other Macs with v1.95

    See:
    http://ubuntuforums.org/showthread.php?t=995704

  2. #22
    Join Date
    Apr 2006
    Beans
    6

    Re: Installation crashes on the new early 2009 White Macbooks

    ACPI now works for me on my macbook 5.2!!!
    -i see battery charge, ac adapter, etc..
    -i see 2 cores for my cpu
    -i can change cpu freq and governor
    -sound & microphone works (only 2 speakers..
    -i can shutdown my macbook
    -i cannot reboot
    -i can enter sleep mode... but i can't wakeup

    but i can't use nvidia drivers so no 3d effects and accelerated graphics.


    here how to make things work:
    0.1 you have to use REFIT, or you have to bless grub.efi in [3] - but it's safer refit - download and install it from osx.
    0.2 boot into ubuntu in some way and install all the needed packages to compile theese things
    1a. checkout the last svn version of grub2 and compile it for the x86_64 efi platform - i followed http://grub.enbug.org/TestingOnMacbook and http://grub.enbug.org/TestingOnEFI..... or download the attached file. the config file is for kernel version 2.6.27-11-generic, but you can change it for your kernel versions
    1b. change, if you set it, in xorg.conf from nvidia to fbdev
    Code:
    Section "Device"
        Identifier     "Device0"
        Driver         "fbdev" #"nvidia"
    #    VendorName     "NVIDIA Corporation"
    EndSection
    1c. add the folling line in /etc/modprobe.d/blacklist
    Code:
    blacklist agpgart
    2. copy the compiled-or downloaded grub2_efi to an usbpen and reboot into osx
    3. paste grub2_efi into /efi/
    4. reboot
    5. now you should see another entry in refit: grub2_efi. boot


    1. here there is some code:
    Code:
    mkdir grub2_efi
    svn co svn://svn.savannah.gnu.org/grub/trunk/grub2 grub2
    cd grub2
    ./configure --with-platform=efi --target=i386
    make
    ./grub-mkimage -d . -o grub.efi gpt hfsplus fat ext2 normal chain boot configfile
    sudo cp grub.efi *.mod fs.lst command.lst ../grub2_efi
    create your own grub.cfg file, or take the mine, and put it into grub2_efi:
    Code:
    menuentry "linux-2.6.27-11-generic" {
      # Set the root device for Linux.
      root=(hd0,3)
      # Load the loader. - other options: video=vesafb noefi
      linux /boot/vmlinuz-2.6.27-11-generic root=/dev/sda3 video=efifb agp=off acpi=force
      initrd /boot/initrd.img-2.6.27-11-generic
    }
    
    menuentry "MacOSX" {
      # Search the root device for Mac OS X's loader.
      search --set /usr/standalone/i386/boot.efi
      # Load the loader.
      chainloader /usr/standalone/i386/boot.efi
    }
    
    menuentry "Boot from MBR" {
      appleloader HD
    }
    menuentry "Boot from CD" {
      appleloader CD
    }
    
    # this does not work for me
    menuentry "Boot from USB" {
      appleloader USB
    }
    
    
    #keymapping: remeber these keys when you boot, they can be helpful!!!
    #F1 = ctrl-x
    #F2 = ctrl-a
    #F3 = ctrl-e
    Attached Files Attached Files

  3. #23
    Join Date
    Aug 2005
    Location
    Huntsville, AL, USA
    Beans
    7,526
    Distro
    Ubuntu

    Re: Installation crashes on the new early 2009 White Macbooks

    Quote Originally Posted by sturuko View Post
    but i can't use nvidia drivers so no 3d effects and accelerated graphics.
    This is a known issue when booting via EFI. There is no work around... yet.

  4. #24
    Join Date
    Jun 2007
    Location
    Uruguay
    Beans
    239
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Installation crashes on the new early 2009 White Macbooks

    Here's a news article that reports the quiet change introduced in the white MacBook hardware (the new one being MacBook5,2).
    http://www.engadget.com/2009/01/21/a...unibody-specs/
    "First they ignore you, then they laugh at you, then they fight you, then you win."
    -- Mahatma Gandhi
    ubuntu Linux for human beings

  5. #25
    Join Date
    Apr 2009
    Beans
    2

    Re: Installation crashes on the new early 2009 White Macbooks

    Hi,

    Thanks a lot for this thread. I have been able to install ubuntu on my new Macbook 5.2. But, there are a few nuisances. There are problems with my touchpad. Two finger gestures don't work. I can't scroll or right click with two finger taps. Moreover, the palm sensitivity on the touch pad is way too high.

  6. #26
    Join Date
    Jun 2007
    Location
    Uruguay
    Beans
    239
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Installation crashes on the new early 2009 White Macbooks

    Did you install the touchpad driver?
    Follow this guide [1] Almost all of it works for the MacBook5,2.

    [1] https://help.ubuntu.com/community/MacBook5-1/Intrepid
    "First they ignore you, then they laugh at you, then they fight you, then you win."
    -- Mahatma Gandhi
    ubuntu Linux for human beings

  7. #27
    Join Date
    Apr 2009
    Beans
    2

    Re: Installation crashes on the new early 2009 White Macbooks

    Yes, I had followed all the instructions from that link. I had updated the repositories and installed the apple touchpad software using apt-get.

    The instructions on that link says that two touch tap works out of the box, when it doesn't (5.2 vs 5.1 macbooks?).

  8. #28
    Join Date
    Apr 2006
    Beans
    6

    Re: Installation crashes on the new early 2009 White Macbooks

    try this:
    sudo gedit /etc/hal/fdi/policy/11-x11-synaptics.fdi

    Code:
    <?xml version="1.0" encoding="ISO-8859-1"?>
    <deviceinfo version="0.2">
      <device>
        <match key="info.capabilities" contains="input.touchpad">
          <match key="info.product" contains="appletouch">
            <merge key="input.x11_driver" type="string">synaptics</merge>
           <merge key="input.x11_options.Device" type="string">/dev/psaux</merge>
           <merge key="input.x11_options.Protocol" type="string">auto-dev</merge>
           <merge key="input.x11_options.SendCoreEvents" type="string">true</merge>
           <merge key="input.x11_options.LeftEdge" type="string">100</merge>
           <merge key="input.x11_options.RightEdge" type="string">1120</merge>
           <merge key="input.x11_options.TopEdge" type="string">50</merge>
           <merge key="input.x11_options.BottomEdge" type="string">310</merge>
           <merge key="input.x11_options.FingerLow" type="string">5</merge>
           <merge key="input.x11_options.FingerHigh" type="string">20</merge>
           <merge key="input.x11_options.MaxTapTime" type="string">100</merge>
           <merge key="input.x11_options.MaxTapMove" type="string">150</merge>
           <merge key="input.x11_options.MaxDoubleTapTime" type="string">180</merge>
           <merge key="input.x11_options.VertScrollDelta" type="string">20</merge>
           <merge key="input.x11_options.HorizScrollDelta" type="string">50</merge>
           <merge key="input.x11_options.MinSpeed" type="string">0.49</merge>
           <merge key="input.x11_options.MaxSpeed" type="string">0.78</merge>
           <merge key="input.x11_options.AccelFactor" type="string">0.0010</merge>
           <merge key="input.x11_options.LockedDrags" type="string">false</merge>
           <merge key="input.x11_options.TapButton1" type="string">1</merge>
           <merge key="input.x11_options.TapButton2" type="string">3</merge>
           <merge key="input.x11_options.TapButton3" type="string">2</merge>
           <merge key="input.x11_options.VertTwoFingerScroll" type="string">true</merge>
           <merge key="input.x11_options.HorizTwoFingerScroll" type="string">false</merge>
           <merge key="input.x11_options.FastTaps" type="string">true</merge>
           <merge key="input.x11_options.VertEdgeScroll" type="string">false</merge>
           <merge key="input.x11_options.HorizEdgeScroll" type="string">false</merge>
           <merge key="input.x11_options.SHMConfig" type="string">true</merge>
    
          </match>
        </match>
      </device>
    </deviceinfo>
    save and reboot

  9. #29
    Join Date
    Jun 2007
    Location
    Uruguay
    Beans
    239
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Installation crashes on the new early 2009 White Macbooks

    Quote Originally Posted by sturuko View Post
    try this:
    sudo gedit /etc/hal/fdi/policy/11-x11-synaptics.fdi
    ...
    This worked for me. Thank you.

    On a different note, someone said you can actually have ACPI enabled if you boot with nosmp or maxcpus=1 in the boot flags. It was posted in the kernel bug report here: http://bugzilla.kernel.org/show_bug.cgi?id=13170

    I still can't change display brightness though. Anyone had any luck with this?
    "First they ignore you, then they laugh at you, then they fight you, then you win."
    -- Mahatma Gandhi
    ubuntu Linux for human beings

  10. #30
    Join Date
    Jul 2009
    Beans
    5

    Re: Installation crashes on the new early 2009 White Macbooks

    disabling acpi is the cause that the number of core is one?
    i noticed my macbook recognize cpu to be single core today trying to figure out what causes slow playback of mkv file, 720p video.

    $grep -i core /proc/cpuinfo
    model name : Intel(R) Core(TM)2 Duo CPU P7350 @ 2.00GHz
    core id : 0
    cpu cores : 1

    even though that result say there's one core, both cores are actually working or not?
    if not, what should i do to solve this? any solution?
    i want 2 cores.
    with one core, of course, it plays 720p hd video. but it eats 100% cpu usage..

Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •