Page 9 of 30 FirstFirst ... 789101119 ... LastLast
Results 81 to 90 of 297

Thread: HowTo: Install the very latest MPlayer under Jaunty Jackalope

  1. #81
    Join Date
    Dec 2006
    Beans
    6,979

    Re: HowTo: Install the very latest MPlayer under Jaunty Jackalope

    Hi,

    It may be of little interest to Jaunty users but I have spent a little time reorganizing my MPlayer guides on these forums. Courtesy of a push in the right direction by FakeOutdoorsman I am now running Hardy Heron, Intrepid Ibex and Jaunty Jackalope in VirtualBox and I have just finished a little spring cleaning of the 3 guides I now aim to support until their official 'end-of-life' dates:

    [Howto] Successfully install the svn MPlayer under Hardy Heron
    http://ubuntuforums.org/showthread.php?t=558538

    [Howto] Install the svn Mplayer under Intrepid Ibex
    http://ubuntuforums.org/showthread.php?t=1024592

    HowTo: Install the very latest MPlayer under Jaunty Jackalope
    http://ubuntuforums.org/showthread.php?t=1081070

    Just needs a final spring-clean of each guide, which I shall undertake over the next few weeks, and following the release of Jaunty a move to the tutorial section of the forums for the Jaunty guide.

    And I think that will do me for the svn MPlayer under Ubuntu in terms of disk space for virtual machines and time needed on the forums for support/tinkering of/with the guides. My apologies to the Karmic Koala .

    Now for that guide I would like to write on 'find'....

    Andrew
    Last edited by andrew.46; March 27th, 2009 at 01:01 AM.

  2. #82
    Join Date
    Oct 2006
    Beans
    34
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: HowTo: Install the very latest MPlayer under Jaunty Jackalope

    Thanks a lot for the guide, andrew. Works great for me.

    I have one problem, though: in every .mkv i have that has embedded SSA/*** subtitles (which, by coincidence, are pretty much all of them ) I can't switch off subtitles anymore. Usually this works with mplayer by pressing 'v' during playback, but not anymore. Presing 'v' now only adds another layer of subtitles over the already shown one. Anyone has a hint on what I'm doing wrong?

    TiA

    EDIT:
    Looks like we're not supposed to use that other abbreviation for subtitles in sub station alpha format.

    EDIT #2:
    Okay, looks like they're gone when I disable them via smplayer GUI, but then they can't be switched on when I'm launching mplayer via command-line. Better than nothing, I suppose.
    Last edited by NorQue; March 30th, 2009 at 09:35 PM.

  3. #83
    Join Date
    Dec 2006
    Beans
    6,979

    Re: HowTo: Install the very latest MPlayer under Jaunty Jackalope

    Hi NorQue,

    Quote Originally Posted by NorQue View Post
    Thanks a lot for the guide, andrew. Works great for me.
    Great news, especially since I cannot get Jaunty beta running in VirtualBox at the moment and cannot test any Jaunty related problems .

    I have one problem, though: in every .mkv i have that has embedded SSA/*** subtitles (which, by coincidence, are pretty much all of them ) I can't switch off subtitles anymore. Usually this works with mplayer by pressing 'v' during playback, but not anymore. Presing 'v' now only adds another layer of subtitles over the already shown one. Anyone has a hint on what I'm doing wrong?
    My knowledge of subtitles and MPlayer is next to zero but I have used the following file:

    http://samples.mplayerhq.hu/Matroska...vorbis-ssa.mkv

    and using this file I can turn the subtitles on and off using the 'v' key and cycle through the available subtitles using the 'j' key, all from the commandline. Can you test this file?

    I am using the following:

    Code:
    andrew@skamandros~$ mplayer | head -n 1
    MPlayer SVN-r29078-4.2.4 (C) 2000-2009 MPlayer Team
    and I attach a couple of screenshots of the crazy Japanese anime with subtitles on and off.

    All the best,

    Andrew
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	disabled.png 
Views:	26 
Size:	341.4 KB 
ID:	108104   Click image for larger version. 

Name:	enabled.png 
Views:	29 
Size:	385.4 KB 
ID:	108105  

  4. #84
    Join Date
    Oct 2006
    Beans
    34
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: HowTo: Install the very latest MPlayer under Jaunty Jackalope

    Strange. Today I can't replicate that issue, neither with your file, nor with my own. Yesterday every single time the SSA rendered subtitles were displayed when they were switched on in smplayer, no chance to turn them off when run from comand line. Today it woks like a charm. Sorry for bothering you, seems like all that was needed was a reboot (or some sleep, or me excessively swearing, no idea...). Best to file it under "Layer 8 problem".

  5. #85
    Join Date
    Sep 2008
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HowTo: Install the very latest MPlayer under Jaunty Jackalope

    sometimes mplayer wont close and stays on processes, i do not know this too is that sound hissing sometimes caused by mplayer or alsa (i use smplayer always for GUI)

    i have fresh complete mplayer offline .deb-s too
    Last edited by forcecore; March 31st, 2009 at 01:07 PM.
    tox.im - Future open source Skype alternative.
    n2n VPN - Hamachi alternative for Linux, Win, Mac

  6. #86
    Join Date
    Dec 2006
    Beans
    6,979

    Re: HowTo: Install the very latest MPlayer under Jaunty Jackalope

    Hi forecore,

    Quote Originally Posted by forcecore View Post
    sometimes mplayer wont close and stays on processes, i do not know this too is that sound hissing sometimes caused by mplayer or alsa (i use smplayer always for GUI)

    i have fresh complete mplayer offline .deb-s too
    I am afraid that I cannot reproduce your problem and I am not sure how to troubleshoot this issue. Apologies!

    Andrew

  7. #87
    Join Date
    Nov 2006
    Beans
    161

    Re: HowTo: Install the very latest MPlayer under Jaunty Jackalope

    Today i've got this problem:
    Code:
    make[1]: Entering directory `/home/gianluca/auto/mplayer/libavcodec'
    cc -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I.. -I.. -Wundef -Wdisabled-optimization -Wno-pointer-sign -Wdeclaration-after-statement -std=gnu99 -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -O4 -march=native -mtune=native -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -I.  -I/usr/include/directfb -I/usr/include/  -I/usr/include/SDL  -D_REENTRANT   -D_REENTRANT   -Ilibdvdread4  -I/usr/include/freetype2 -I/usr/include   -I/usr/include/schroedinger-1.0 -I/usr/include/liboil-0.3   -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include     -c -o allcodecs.o allcodecs.c
    allcodecs.c: In function 'avcodec_register_all':
    allcodecs.c:57: error: 'CONFIG_H263_VAAPI_HWACCEL' undeclared (first use in this function)
    allcodecs.c:57: error: (Each undeclared identifier is reported only once
    allcodecs.c:57: error: for each function it appears in.)
    allcodecs.c:58: error: 'CONFIG_MPEG2_VAAPI_HWACCEL' undeclared (first use in this function)
    allcodecs.c:59: error: 'CONFIG_MPEG4_VAAPI_HWACCEL' undeclared (first use in this function)
    make[1]: *** [allcodecs.o] Error 1
    make[1]: Leaving directory `/home/gianluca/auto/mplayer/libavcodec'
    make: *** [libavcodec/libavcodec.a] Error 2
    I hope next release can fix it
    I've tried "./configure --codecsdir=/usr/lib/codecs --confdir=/etc/mplayer --disable-vdpau" without change/success.
    Last edited by psychok9; April 2nd, 2009 at 05:44 PM.

  8. #88
    Join Date
    Dec 2006
    Beans
    6,979

    Re: HowTo: Install the very latest MPlayer under Jaunty Jackalope

    Hi psychik9,

    Quote Originally Posted by psychok9 View Post
    Today i've got this problem
    I missed that one but revision 29134 compiled ok for me. Perhaps this fixed the problem:

    Code:
    andrew@skamandros~/source/mplayer/mplayer$ svn log -r 29130
    ------------------------------------------------------------------------
    r29130 | cehoyos | 2009-04-03 05:38:15 +1100 (Fri, 03 Apr 2009) | 1 line
    
    Fix compilation with libavcodec's HWACCEL.
    ------------------------------------------------------------------------
    I wish the web interface for the MPlayer svn would come back up!!

    Andrew

  9. #89
    Join Date
    Nov 2006
    Beans
    161

    Smile Re: HowTo: Install the very latest MPlayer under Jaunty Jackalope

    Quote Originally Posted by andrew.46 View Post
    Hi psychik9,



    I missed that one but revision 29134 compiled ok for me. Perhaps this fixed the problem:

    Code:
    andrew@skamandros~/source/mplayer/mplayer$ svn log -r 29130
    ------------------------------------------------------------------------
    r29130 | cehoyos | 2009-04-03 05:38:15 +1100 (Fri, 03 Apr 2009) | 1 line
    
    Fix compilation with libavcodec's HWACCEL.
    ------------------------------------------------------------------------
    I wish the web interface for the MPlayer svn would come back up!!

    Andrew
    I'll try it tomorrow, very thank you andrew

  10. #90
    Join Date
    Apr 2006
    Beans
    7
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HowTo: Install the very latest MPlayer under Jaunty Jackalope

    thanks! worked 100%!

Page 9 of 30 FirstFirst ... 789101119 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •