Results 1 to 5 of 5

Thread: mac osx can't access symlinks in samba share

  1. #1
    Join Date
    Jan 2009
    Beans
    2

    mac osx can't access symlinks in samba share

    Samba running in Ubuntu, windows can access it's share without any problems. Mac osx Finder can access the share but can't seem to use any of the symlinks in it, unlike in Windows Explorer the symlinks are just like folders.

    Thnx in advance!

  2. #2
    Join Date
    Jun 2006
    Location
    Canada
    Beans
    516

    Question Re: mac osx can't access symlinks in samba share

    (taking a big leap here)
    Mac OSX 10.4 I assume... have you tried 10.5?

    Also, this may help:
    https://bugs.launchpad.net/ubuntu/+s...41/comments/20
    "turning off the Unix Extensions isn't an ideal answer as you lose things like symlinks."
    My Top Bugs - Launchpad Profile - Wiki Page

    Appreciate what the severe effort of many converging wills has produced.

  3. #3
    Join Date
    Jan 2009
    Beans
    2

    Re: mac osx can't access symlinks in samba share

    Im using version 10.5.6.

  4. #4
    Join Date
    Mar 2009
    Beans
    1

    Re: mac osx can't access symlinks in samba share

    It turns out that 10.5 tries to implement the Unix Extensions but it doesn't quite work out. So on your server you have to disable them as not to confuse your Mac. In your smb.conf:

    unix extensions = no

    Found this thread while struggling with same, props to this blogger guy:
    http://www.rc.au.net/blog/2007/11/19...x-105-leopard/

  5. #5
    Join Date
    Mar 2007
    Beans
    14

    Re: mac osx can't access symlinks in samba share

    I am still having this same problem:

    in smb.conf:

    Code:
    [files]
        path = /home/dwiel/files
        browseable = yes
        read only = no
        writeable = yes
        guest ok = yes
        public = yes
        unix extensions = no
        follow symlinks = yes
        wide symlinks = yes
    on the mac (10.5.7) all I can see are the broken links. I have also tried putting the "unix extensions = no" into the general body of the file rather than under the specific folder defn. Any ideas about what is going on?

    Thanks!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •