Results 1 to 3 of 3

Thread: Qt 4.3.4 and OpenFOAM 1.5

  1. #1
    Join Date
    Feb 2009
    Beans
    1

    Post Qt 4.3.4 and OpenFOAM 1.5

    Hi,

    i'm new linux user and i need to run OpenFOAM-1.5. I was only possible to make OpenFOAM directory in Home (/HOME/OpenFOAM/) with "su" and "mkdir" commands. But i don't know how to install Qt (wich is required for OpenFOAM operation) and when i uncompressed OpenFOAM downloaded files with "tar -xzf" command gives me an error.

    freddy@Sony-Ubuntu:~$ tar xzf /home/OpenFOAM/OpenFOAM-1.5.General.gtgz

    gzip: stdin: not in gzip format
    tar: Child returned status 1
    tar: Salida con error demorada desde errores anteriores
    freddy@Sony-Ubuntu:~$ DD

    according with files properties "/home/OpenFOAM/OpenFOAM-1.5.General.gtgz"

    i don't know what i'm doing wrong, please help...

    My OS: Ubuntu 8.10 64bit

  2. #2
    Join Date
    May 2006
    Beans
    26

    Re: Qt 4.3.4 and OpenFOAM 1.5

    You would typically want to install OpenFOAM in YOUR home directory, not /home (see http://www.opencfd.co.uk/openfoam/linux.html).

    Try (as yourself, no su):
    mkdir $HOME/OpenFOAM
    Then tar xzf the files downloaded. In my case:
    cd $HOME/OpenFOAM
    tar xzf OpenFOAM-1.5.General.gtgz
    tar xzf OpenFOAM-1.5.linuxGccDPOpt.gtgz
    tar xzf ThirdParty.General.gtgz
    tar xzf ThirdParty.linuxGcc.gtgz

    I'm still investigating installing qt 4.3 as intrepid has 4.4 in the repos.

  3. #3
    Join Date
    Jul 2005
    Beans
    39

    Re: Qt 4.3.4 and OpenFOAM 1.5

    crmccreary,

    Have you found Qt4.3.x for Ubuntu 9.04? I am trying to install OpenFOAM 1.5 but missed this lib package.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •