Page 3 of 13 FirstFirst 12345 ... LastLast
Results 21 to 30 of 125

Thread: ATTENTION HP dvX laptop owners with speaker sound issues ...

  1. #21
    Join Date
    Mar 2009
    Beans
    3

    Re: ATTENTION HP dvX laptop owners with speaker sound issues ...

    The following steps will enable sound on the internal speakers for the HP dv4-1225dx

    sudo gedit /etc/modprobe.d/alsa-base

    Add the following lines:

    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    options snd-hda-intel model=dell-m4-1

    perform sudo reboot after saving your changes


    Thank you, NaplesBill, for your posting on this fix!

  2. #22
    Join Date
    Apr 2009
    Beans
    2

    Re: ATTENTION HP dvX laptop owners with speaker sound issues ...

    Hi, I'm relatively new to Ubuntu and would be thrilled for any assistance anyone can provide me with this problem. I have an HP DV4 1228ca. Just like everyone, I did have sound through my front audio jack and could listen to with headphones. Unfortunately after trying all of your helpful suggestions, I don't even have audio in my front jack anymore. If I go into my sound properties, it doesnt seem to recognize my sound card anymore. I beleive this has to do with the entry in the alsa base file.
    Here are my results:

    "[CODE]#> ./configure --enable-dynamic-minors
    #> make"


    winblows@ubuntu:~/Desktop/AlsaDriver/alsa-driver$ make
    make dep
    make[1]: Entering directory `/home/winblows/Desktop/AlsaDriver/alsa-driver'
    make[2]: Entering directory `/home/winblows/Desktop/AlsaDriver/alsa-driver/acore'
    copying file alsa-kernel/core/info.c
    /home/winblows/Desktop/AlsaDriver/alsa-driver/utils/patch-alsa: 24: patch: not found
    make[2]: *** [info.c] Error 1
    make[2]: Leaving directory `/home/winblows/Desktop/AlsaDriver/alsa-driver/acore'
    make[1]: *** [dep] Error 1
    make[1]: Leaving directory `/home/winblows/Desktop/AlsaDriver/alsa-driver'
    make: *** [include/sndversions.h] Error 2

    #> sudo make install-modules

    This is where my noobishness may shine through. I wasn't quite sure what to take from the make process above so I continued...
    winblows@ubuntu:~/Desktop/AlsaDriver/alsa-driver$ sudo make install-modules
    [sudo] password for winblows:
    find /lib/modules/2.6.27-11-generic/kernel/sound -name 'snd*.*o' | xargs rm -f
    find /lib/modules/2.6.27-11-generic/kernel/sound -name 'snd*.*o.gz' | xargs rm -f
    find /lib/modules/2.6.27-11-generic/kernel/sound -name 'ac97_bus.*o' | xargs rm -f
    find /lib/modules/2.6.27-11-generic/kernel/sound -name 'ac97_bus.*o.gz' | xargs rm -f
    make[1]: Entering directory `/home/winblows/Desktop/AlsaDriver/alsa-driver/acore'
    mkdir -p /lib/modules/2.6.27-11-generic/kernel/sound/acore
    cp snd-hrtimer.ko snd-hwdep.ko snd-page-alloc.ko snd-pcm.ko snd-rawmidi.ko snd-timer.ko snd.ko /lib/modules/2.6.27-11-generic/kernel/sound/acore
    cp: cannot stat `snd-hrtimer.ko': No such file or directory
    cp: cannot stat `snd-hwdep.ko': No such file or directory
    cp: cannot stat `snd-page-alloc.ko': No such file or directory
    cp: cannot stat `snd-pcm.ko': No such file or directory
    cp: cannot stat `snd-rawmidi.ko': No such file or directory
    cp: cannot stat `snd-timer.ko': No such file or directory
    cp: cannot stat `snd.ko': No such file or directory
    make[1]: *** [modules_install] Error 1
    make[1]: Leaving directory `/home/winblows/Desktop/AlsaDriver/alsa-driver/acore'
    make: *** [install-modules] Error 1


    #> sudo vim /etc/modprobe.d/alsa-base
    [add 'options snd_hda_intel model=hp-dv5' sans quotes to the bottom of the file, even if you have a dv4, etc.]



    I have tried each of the following, rebooting in between them:

    options snd_hda_intel model=hp-dv5

    options snd_hda_intel model=hp-dv4

    # Keep snd-pcsp from beeing loaded as first soundcard
    options snd-pcsp index=-2
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    options snd-hda-intel model=dell-m4-1
    options snd-hda-intel enable_msi=1

    # Keep snd-pcsp from beeing loaded as first soundcard
    options snd-pcsp index=-2
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    options snd-hda-intel model=hp=dv4
    options snd-hda-intel enable_msi=1

    I have also tried using the 3.4 compiler and "unstable" alsa snapshot package recommended by uticamarco.

    If anyone has any suggestions, I would be most grateful. Thank you very much.

  3. #23
    Join Date
    Jan 2009
    Beans
    4

    Re: ATTENTION HP dvX laptop owners with speaker sound issues ...

    same problem as above, but that was after upgrading to Jaunty, I had it fixed in 8.10

  4. #24
    Join Date
    Apr 2009
    Beans
    2

    Re: ATTENTION HP dvX laptop owners with speaker sound issues ...

    GREAT NEWS!!

    I was finally able to get my sound to work perfectly on my HP DV4-1228ca.

    My first problem was that I did not have "patch" installed and that was giving me the problem listed in my previous post. I installed this "patch" and tried to compile. I then got an error similar to this:

    config.status: include/version.h is unchanged
    config.status: creating include/autoconf-extra.h
    config.status: include/autoconf-extra.h is unchanged
    Hacking autoconf.h...
    make dep
    make[1]: Вход в каталог `/usr/src/Alsa-1.0.19/alsa-driver-1.0.19'
    make[2]: Вход в каталог `/usr/src/Alsa-1.0.19/alsa-driver-1.0.19/acore'
    copying file alsa-kernel/core/info.c
    patching file info.c
    Hunk #2 FAILED at 155.
    Hunk #3 succeeded at 162 (offset -5 lines).
    Hunk #4 succeeded at 172 (offset -5 lines).
    Hunk #5 succeeded at 203 (offset -5 lines).
    Hunk #6 succeeded at 490 (offset -5 lines).
    Hunk #7 FAILED at 530.
    Hunk #8 FAILED at 994.
    Hunk #9 succeeded at 1018 (offset -10 lines).
    3 out of 9 hunks FAILED -- saving rejects to file info.c.rej
    make[2]: *** [info.c] Ошибка 1
    make[2]: Выход из каталога `/usr/src/Alsa-1.0.19/alsa-driver-1.0.19/acore'
    make[1]: *** [dep] Ошибка 1
    make[1]: Выход из каталога `/usr/src/Alsa-1.0.19/alsa-driver-1.0.19'
    make: *** [include/sndversions.h] Ошибка 2
    alsa-driver-1.0.19 make failed

    I contacted the alsa dev's and they had me do several different diagnostics. They then suggested using the latest snapshot found here: http://ftp.kernel.org/pub/linux/kern...apshot.tar.bz2

    I was finally able to compile this snapshot, restart (using the following in my alsa base):
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    options snd-hda-intel model=m4

    Once up, I made sure the audio was not muted and behold, SOUND

    I hope this helps someone.

    -Jesse

  5. #25
    Join Date
    Mar 2009
    Location
    Ithaca, NY
    Beans
    21
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: ATTENTION HP dvX laptop owners with speaker sound issues ...

    @mal2104
    The problem in Jaunty is solved if you use the latest alsa driver http://ftp.kernel.org/pub/linux/kern...090415.tar.bz2
    Then the steps are same as mentioned by jstalnak in the beginning of this thread.

  6. #26
    Join Date
    Dec 2008
    Beans
    13

    Re: ATTENTION HP dvX laptop owners with speaker sound issues ...

    Interesting. Until a few days ago, sound on my dv5z "just worked". Apparently an update to alsaplayer-alsa 0.99.80-3ubuntu1, alsaplayer-gtk 0.99.80-3ubuntu1, alsaplayer-common 0.99.80-3ubuntu1 borked my sound (i.e., speaker could be made to work by plugging in the headphones).

    I'll look into this new alsa-driver.

  7. #27
    Join Date
    Apr 2007
    Location
    Denmark
    Beans
    134
    Distro
    Ubuntu Development Release

    Re: ATTENTION HP dvX laptop owners with speaker sound issues ...

    Sorry to say...

    I am having a hard time understanding how this works, because I do not have an intel chipset. I have an AMD/ATI something I cant recall. Even though it specificly specifies "intel" in the line ...

    A little note, I had to add ".conf" and change vim to gedit

    But none the less, it works.

    Thanks!
    Ubuntu user: #19306 | Device: HP DV5-1150eo

  8. #28
    Join Date
    Apr 2009
    Beans
    4

    HP Pavilion dv6 laptop owners with speaker sound issues ...

    Hi.
    I had a problem. NO SOUND from my Pavilion DV6 laptop. The laptop works perfect with UBUNTU 8.10 Everething WAS PERFECT (sound, web camera, bluetooth, graphics, cd-rom) I had only a small problem with camera's mic , but it was ok to me.
    After upgrade the new release ( 9.02 ) there was no sound at all. If I press esc during boot and choose 2.6.27-11 generic kernel then the sound works fine, but cpu works only at the maximum speed. By choosing the 2.6.28-11 option, the sound does not work but CPU clock changes to consume buttery power (on demand option). So, I have to choose between sound or cpu_power_save.

  9. #29
    Join Date
    Apr 2007
    Location
    Denmark
    Beans
    134
    Distro
    Ubuntu Development Release

    Re: ATTENTION HP dvX laptop owners with speaker sound issues ...

    Uhm... now I get no sound from my headphones.

    Does it matter that I do not have an intel chipset? My soundcard is called IDT something.
    Ubuntu user: #19306 | Device: HP DV5-1150eo

  10. #30
    Join Date
    Apr 2009
    Beans
    4

    Re: ATTENTION HP dvX laptop owners with speaker sound issues ...

    Hi.

    Totally new to Linux.

    I have a HP DV7 and when I installed Ubuntu 8.1 I had "bongo drums" from the login page. After it bootet into the OS i was still there just had to turn the volume up to 100% to hear it. (By Bongo drums I mean, it sounds like a bongo drum beeing hit rapidly)

    Then I tried 9.02 and now the "bongo drums" goes away after a little while, but still no sound.

    This is both in the build in speakers and the headphone jack.

    SO, I tried what was decriped in the first post in this thread. BUT my alsa-base file is completly empty... Seeing that all of you say "add this 'XXXX' at the end of the file" I'm guessing it's not suppose to be empty?

    Do I reinstall?
    And when this bug has been known for some time, why isn't it fixed in 9.02?
    ------------------------------------
    Hope you understand my english

Page 3 of 13 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •