Page 1 of 5 123 ... LastLast
Results 1 to 10 of 45

Thread: Ubuntu 8.10 and ZTE USB MF636

  1. #1
    Join Date
    Jan 2007
    Beans
    2

    Ubuntu 8.10 and ZTE USB MF636

    Hi, I have a Rogers USB wireless stick. I am able to connect and get an IP address but am unable to do anything after that.

    Copy of wvdial config file.
    ------------------------------------------------
    [Dialer Defaults]
    Modem = /dev/ttyUSB0
    ISDN = off
    Modem Type = USB Modem
    Baud = 460800
    Init = ATZ
    Init2 = AT&F &D2 &C1
    Init3 = ATS7=60 S30=0 S0=0
    Init4 = AT+CGDCONT=1,"IP","internet.com"
    Init5 =
    Init6 =
    Init7 =
    Init8 =
    Init9 =
    Phone = *99#
    Phone1 =
    Phone2 =
    Phone3 =
    Phone4 =
    Dial Prefix =
    Dial Attempts = 1
    Dial Command = ATM1L3DT
    Ask Password = off
    Password = off
    Username = na
    Auto Reconnect = off
    Abort on Busy = off
    Carrier Check = off
    Check Def Route = off
    Abort on No Dialtone = off
    Stupid Mode = on
    Idle Seconds = 0
    New PPPD = yes
    Auto DNS = on
    ;Minimize = off
    ;Dock = off
    ;Do NOT edit this file by hand!
    -------------------------------------------------

    Output of sudo wvdial:

    --> Cannot get information for serial port.
    --> Initializing modem.
    --> Sending: ATZ
    ATZ
    OK
    --> Sending: AT&F &D2 &C1
    AT&F &D2 &C1
    OK
    --> Sending: ATS7=60 S30=0 S0=0
    ATS7=60 S30=0 S0=0
    OK
    --> Sending: AT+CGDCONT=1,"IP","internet.com"
    AT+CGDCONT=1,"IP","internet.com"
    OK
    --> Modem initialized.
    --> Cannot get information for serial port.
    --> Initializing modem.
    --> Sending: ATZ
    ATZ
    OK
    --> Sending: AT&F &D2 &C1
    AT&F &D2 &C1
    OK
    --> Sending: ATS7=60 S30=0 S0=0
    ATS7=60 S30=0 S0=0
    OK
    --> Sending: AT+CGDCONT=1,"IP","internet.com"
    AT+CGDCONT=1,"IP","internet.com"
    OK
    --> Modem initialized.
    --> Sending: ATDT*99***1#
    --> Waiting for carrier.
    ATDT*99***1#
    CONNECT
    --> Carrier detected. Starting PPP immediately.
    --> Starting pppd at Tue Feb 10 10:23:19 2009
    --> Pid of pppd: 6195
    --> Using interface ppp0
    --> pppd: ����[10]
    --> pppd: ����[10]
    --> pppd: ����[10]
    --> pppd: ����[10]
    --> pppd: ����[10]
    --> pppd: ����[10]
    --> pppd: ����[10]
    --> local IP address 172.28.1.186
    --> pppd: ����[10]
    --> remote IP address 10.64.64.64
    --> pppd: ����[10]
    --> primary DNS address 207.181.101.4
    --> pppd: ����[10]
    --> secondary DNS address 207.181.101.5
    --> pppd: ����[10]
    --------------------------------------------------

    Any help would be appreciated.

    Thanks

  2. #2
    Join Date
    Jan 2007
    Beans
    2

    Re: Ubuntu 8.10 and ZTE USB MF636

    Anyone??

  3. #3
    Join Date
    Aug 2008
    Location
    Athens Greece
    Beans
    971
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 8.10 and ZTE USB MF636

    Hi, from your data everything seems to be OK.
    Try to untick "work offline" in Firefox Menu:
    File > Work Offline (ALT-F W)

    Regards,
    George

  4. #4
    Join Date
    Apr 2008
    Location
    ireland
    Beans
    540
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu 8.10 and ZTE USB MF636

    i have the zte mf622 modem which i tried and got it working. for some reason it didnt work under the preset "3" option it always was trying through the "cdma" option with dial num #777 so i just right clicked the wireless icon (top panel) > edit connections > mobile broadband > click on auto mobile (CDMA) connection > edit > tick connect automatically .and in number type *99# exit and right click wireless icon again and untick wireless (restart or logout may be required) and try to connect oh and keep "enable networking" ticked on
    Last edited by neu2buntu; February 16th, 2009 at 04:07 PM. Reason: info
    using.... ACER ASPIRE ONE and ACER ASPIRE 5332
    running.... Ubuntu 12.04

  5. #5
    Join Date
    Dec 2005
    Beans
    2

    Re: Ubuntu 8.10 and ZTE USB MF636

    Just a suggestion because I had a similary problem with the MF636 usb modem from Rogers :
    verify that your /etc/resolv.conf have read permissions for all. If you don't understand this point, just run in a shell :
    chmod 644 /etc/resolv.conf

    As GeorgeVita said, you are well-connected on Rogers Network.

  6. #6
    Join Date
    Mar 2009
    Beans
    4

    Re: Ubuntu 8.10 and ZTE USB MF636

    Hi, any chance you could point me towards step by step directions for installing and using my Rogers stick? All of the instructions I have found so far are for other models and don't seem to work!

    Cheers,
    Cheyenne

  7. #7
    Join Date
    Aug 2008
    Location
    Athens Greece
    Beans
    971
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 8.10 and ZTE USB MF636

    Hi CArrowsm,
    I have a ZTE MF636 and using it on Ubuntu 8.04. The main problem with theese modems is that respond to the system by default as CD drive or USB hub (19d2:2000 on lsusb command) but we need the actual modem which selected after issuing a special AT command AT+ZCDRUN=8 (then it responds 19d2:0031).

    Note that above numbers are the Manufacturer and the Product Identification number which is shown when you execute the command lsusb from a terminal window.

    At first try the lsusb command and copy paste the results to follow up. Also read my post#2 at http://ubuntuforums.org/showthread.php?t=1005910

    Regards,
    George

  8. #8
    Join Date
    Aug 2008
    Location
    Athens Greece
    Beans
    971
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu 8.10 and ZTE USB MF636

    I have JUST installed an Ubuntu 8.10 from an alternative installation CD (ISO i386) to my Toshiba Satellite L30-113. I did some modifications found on various posts (most in ubuntuforums.org) and I am connected with my ZTE MF636 3g modem via Network Manager 0.7 (I have already downloaded over 250MB of updates before posting this note!).

    Below are the steps you may follow to work with your ZTE MF636:

    1. Boot without the MF636, wait for the system to stabilize, open a terminal window, plug in the modem, wait 10-15 seconds and run the command: lsusb

    If among the responds you see 19d2:0031 go to step 3.

    2. The modem responds 19d2:2000 (as the internal CD drive or USB hub) but we need the actual modem (19d2:0031). You may use a special program called usb_modeswitch (see http://ubuntuforums.org/showthread.php?t=1017630) but I preferred to send the AT command AT+ZCDRUN=8 from a Windows PC to the modem (use hyperterminal or add it as an extra init command through control panel).
    This command turns off the AUTO RUN function of the internal CD, if you want to return to default you have to send AT+ZCDRUN=9 (info taken from www.matt-barrett.com).

    Test again the terminal command lsusb to be sure you have 19d2:0031

    3. Make a new "rule" for MF636 to create the usbserial communication port (/dev/ttyUSBx).
    From terminal run: sudo gedit /etc/udev/rules.d/90-zte.rules
    copy paste the following lines (according to post#4 of http://ubuntuforums.org/showthread.php?t=665332):

    ACTION!="add", GOTO="ZTE_End"
    #
    SUBSYSTEM=="usb", SYSFS{idProduct}=="0031",
    SYSFS{idVendor}=="19d2", GOTO="ZTE_Modem"
    #
    LABEL="ZTE_Modem"
    RUN+="/sbin/modprobe usbserial vendor=0x19d2 product=0x0031",
    MODE="660", GROUP="dialout"
    #
    LABEL="ZTE_End"

    Save and Exit from gedit.

    4. Edit HAL info to see MF636 instead of MF628. From a terminal window:
    sudo gedit /usr/share/hal/fdi/information/10freedesktop/10-modem.fdi
    Search (ctrl-F) for 19d2, go to line after "<!-- ZTE MF628 HSDPA USB dongle -->" and change usb.product_id from 0015 to 0031
    Save and exit from gedit.
    NOTE: this edit must be done again if an Ubuntu update restores the file 10-modem.fdi to defaults!

    5. Remove modem from USB port, reboot, wait for the system to stabilize, plug in the modem. After a while a message will appear over the Network Manager icon (2 PC screens up right) and help you create a Mobile Broadband connection. After created click to Network Manager icon, and click to your provider.

    Some debugging notes:
    - If at step 5 the "message" not appears, try to make the setup manually (right click on icon and "Edit Connections")
    - From terminal the command ls /dev/ttyU* will show you the usbserial ports for the modem. There must be four (4) up to /dev/ttyUSB3 which is our modem. If you boot with the modem attached you may have up to /dev/ttyUSB2 and this needs extra modification to the 10-modem.fdi file (the parameter usb.interface.number" int="3" must be changed to2).

    Post any question to test it and follow up.

    Regards,
    George

  9. #9
    Join Date
    Mar 2009
    Beans
    3

    Re: Ubuntu 8.10 and ZTE USB MF636

    Thanks dude. Great work.But after all i cannt opn my microsd. Any way to open it
    Last edited by zabudarda; March 24th, 2009 at 03:41 PM.

  10. #10
    Join Date
    Mar 2009
    Beans
    4

    Re: Ubuntu 8.10 and ZTE USB MF636

    Hi again,

    After running lsusb this is the output:

    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 002: ID 19d2:2000
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    Now what? I still can't get my computer to recognize it at all even after following all the instructions I can find!

    Arrrgh.


    Cheers
    Cheyenne

Page 1 of 5 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •