View Poll Results: Did this work for you?

Voters
3. You may not vote on this poll
  • Yes - On an abit AirPace

    3 100.00%
  • No - Not on my abit AirPace

    0 0%
  • Yes - On somehting else

    0 0%
  • No - Not at all

    0 0%
Results 1 to 8 of 8

Thread: HOWTO: abit AirPace without ndiswrapper

Threaded View

  1. #1
    Join Date
    Oct 2007
    Location
    $HOME (Cambridge, UK)
    Beans
    97
    Distro
    Ubuntu 10.04 Lucid Lynx

    HOWTO: abit AirPace without ndiswrapper

    Right! By reading until my eyes went square, I've found a way to use the abit AirPace PCI-e WiFi card under Linux with native drivers.
    Standard disclaimer: I'm not a genius, just lucky. Don't take my word as law. This may break your system. That's not my fault.

    Big thanks to luks911 who started me down the right track!

    This HowTo assumes ethernet internet access and an otherwise working installation of any flavour of Ubuntu 8.10 Intrepid Ibex. I've used it on Mythbuntu 64 bit and Ubuntu.
    If you've been playing with Wicd, remove it and reinstall the standard network manager through Synaptic Package Manager.

    It ought work for any card with an Atheros AR242x chipset, but is untested.

    1) First thing to do is disable the suggested drivers; go to the Restricted Drivers Manager wherever it is on your system (Applications>System>Hardware Drivers on Mythbuntu) and disable "Support for Atheros 802.11 wireless LAN cards". There may be something else relating to HAL and Atheros based cards, but I didn't have it.
    Reboot.

    2) We need to blacklist the usual drivers, so open up your editor of choice (I use nano):
    Code:
    sudo nano /etc/modprobe.d/blacklist
    We need to add the suggested driver to this list to prevent it being loaded. Add the following to the bottom of this file:
    Code:
    # This is the wrong driver for the AirPace WiFi card
    blacklist ath9k
    If you've been mucking about with MadWifi and/or ndiswrapper then add the relevant lines also:
    Code:
    blacklist ath_pci
    blacklist ndiswrapper
    Save the file and exit the editor (<Control-x>, <y>, <Enter> in nano)

    3) Now, we can find and install the driver which works.
    Install the backported modules:
    Code:
    sudo apt-get install linux-backports-modules-intrepid
    Go back to the Restricted Drivers Manager and "Support for 5xxx series of Atheros 802.11 wireless LAN cards" should be "Activated but not in use" if you click on it.

    4) We can now load the driver.
    Check that none of the blacklisted drivers are running:
    Code:
    sudo rmmod ath9k
    sudo rmmod ath_pci
    sudo rmmod ndiswrapper
    Load the new driver:
    Code:
    sudo modprobe ath5k
    Right-click on the network manager applet in the notification area, disable wireless, enable it again. If you now left-click on it, your network should show up on the list. Click your network and if it connects, then we've just got to make it permanent. If it doesn't, sorry but I can't help

    5) Time to make it permanent.
    Add it to the list of kernel modules loaded at boot:
    Code:
    sudo nano /etc/modules
    Delete any line which is one of the modules blacklisted earlier (ndiswrapper, ath9k or ath_pci) and add the following line to the bottom:
    Code:
    ath5k
    Save and exit.
    Reboot and check your WiFi still works!
    Last edited by canoemoose; March 9th, 2009 at 03:13 PM. Reason: Added more info
    Here be sarcasm/humour/even good ideas!
    Server: 2.7GHz Athlon 64, 2GB RAM, 80GB boot drive, 4.5TB RAID 5 for backups
    Desktop: 3.06GHz Core 2 Duo, 4GB RAM, 500GB HDD, ATI Radeon HD 5770
    Netbook: Lenovo Ideapad S10e, Ubuntu Netbook Edition

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •