Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Intrepid TP-Link WN821N on an old laptop

  1. #1
    Join Date
    Feb 2008
    Beans
    239
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Intrepid TP-Link WN821N on an old laptop

    This is a problem I come back to once every couple of weeks to try to solve. As yet I have had no luck. So I just put up with no wireless

    I have an old laptop (Lenevo Sunrise 410L) with no built in wireless capability. You may not have heard of it as it was made and bought in China.

    Here in China there is basically not a lot of choice when it comes to wireless cards. The choice boils down to TP-Link or D-Link usually.

    I ended up with a TP-Link TL-WN821N, it's a USB dongle. lsusb gives:
    Code:
    Bus 001 Device 002: ID 0cf3:9170 Atheros Communications, Inc.
    For this device.

    I checked on the supported wireless cards wiki (amongst other places) and couldn't find anything about my usb wireless card being supported.

    So I have gone down the ndiswrapper road. I set it up as per the usual instructions apart from I found that the XP drivers didn't work. All choices except the Vista drivers came up "invalid driver". So i went with the X86 Vista drivers.

    It didn't work still, so I started working through pytheas22's very wonderful and user-friendly Comprehensive ndiswrapper troubleshooting guide (thanks to him for that!!). Anyway, I won't run you through everything that happened there, but I complete steps 1&2 and then 3 gives me a problem.

    When I run
    Code:
    lshw -C Network
    I get
    Code:
    WARNING: you should run this program as super-user.
      *-network               
           description: Ethernet interface
           product: BCM4401-B0 100Base-TX
           vendor: Broadcom Corporation
           physical id: 7
           bus info: pci@0000:05:07.0
           logical name: eth0
           version: 02
           serial: 00:16:36:ce:f3:fb
           width: 32 bits
           clock: 33MHz
           capabilities: bus_master cap_list ethernet physical
           configuration: broadcast=yes driver=b44 driverversion=2.0 ip=192.168.1.100 latency=32 module=ssb multicast=yes
      *-network DISABLED
           description: Ethernet interface
           physical id: 1
           logical name: pan0
           serial: 2a:db:ab:fd:ec:ab
           capabilities: ethernet physical
           configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A multicast=yes
    There seems to be no mention of my USB dongle here. According to the trouble shooting guide I have two options, but neither apply to my situation.

    Can somebody please help out at this point? I would LOVE to get this solved.
    I pity the fool.

  2. #2
    Join Date
    Feb 2008
    Beans
    239
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Intrepid TP-Link WN821N on an old laptop

    Nobody have any idea? Need some more information perhaps? Please ask.
    I pity the fool.

  3. #3
    Join Date
    Nov 2007
    Beans
    12
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Intrepid TP-Link WN821N on an old laptop


  4. #4
    Join Date
    Jul 2006
    Location
    Poland, Bydgoszcz
    Beans
    9
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Intrepid TP-Link WN821N on an old laptop

    Jimmy9pints did you successfuly run this card on Ubuntu without ndiswrapper?

  5. #5
    Join Date
    Feb 2008
    Beans
    239
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Intrepid TP-Link WN821N on an old laptop

    Sorry for taking a long time to reply. I didn't see any replies for a while and kind of gave up. I'll try madwifi again.
    I pity the fool.

  6. #6
    Join Date
    Mar 2008
    Beans
    266

    Re: Intrepid TP-Link WN821N on an old laptop

    Apparently one could make it work.

    If I can get it to work I'll let you know.

    edit:

    Ok so I don't have enough knowledge to get it to work.
    otus driver <- if anybody gets it to work ... please write a howto.
    ar9170 driver based on otus

    Howto for OpenSuse 10.3/11.0 (german)
    Last edited by excogitation; April 9th, 2009 at 10:46 PM.

  7. #7
    Join Date
    Feb 2008
    Beans
    239
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Intrepid TP-Link WN821N on an old laptop

    That'd be amazing if someone could help out on that.
    I pity the fool.

  8. #8
    Join Date
    Mar 2008
    Beans
    266

    Re: Intrepid TP-Link WN821N on an old laptop

    I could only get it to work with non-encrypted networks - but it's a start. An os driver would be better though.

    Quote Originally Posted by rogues29 View Post
    [...]
    Anyway, I just figured out a way to get the adapter to work.

    [...]

    Firstly you need to use ndiswrapper [...]

    Code:
    sudo apt-get install ndisgtk
    once that is installed it should put a link in System->Administration called Windows Wireless Drivers

    What that program requires is the windows drivers for the device. unfortunately the drivers for the TP-Link device don't work in ndiswrapper, at least all the ones i could find from TP-Link. There are a few other Wireless USB dongles that come with the same chip set, and it is one of these that i got to work 10 minutes ago. The drivers you need to download are for a IOGear device and are available at GWU623.zip [...]

    the only things you need are the files in GWU623.zip/drivers/XP and then whichever architecture you are running i can only verify that the 32-bit ones worked because i don't have 64-bit. so extract the 3 files in either of those directories all to the same directory (i don't think it matters where).

    Then go into the Windows Wireless Drivers app and click Install New Driver find the folder you extracted the files to and select the file ending in .inf click Install and that should be it. Wait a couple of seconds to let the device start up and then Left click the network icon in the system tray to connect to wireless networks in range.

  9. #9
    Join Date
    Mar 2008
    Beans
    266

    Re: Intrepid TP-Link WN821N on an old laptop

    Code:
    [ 6560.088150] usb 1-2: new high speed USB device using ehci_hcd and address 4
    [ 6560.269289] usb 1-2: configuration #1 chosen from 1 choice
    [ 6560.858177] ndiswrapper version 1.54 loaded (smp=yes, preempt=no)
    [ 6561.157861] usb 1-2: reset high speed USB device using ehci_hcd and address 4
    [ 6561.407830] ndiswrapper: driver arusb_xp (,02/04/2008,3.0.0.99) loaded
    [ 6561.849098] wlan1: ethernet device 00:21:27:cf:05:21 using NDIS driver: arusb_xp, version: 0x40700, NDIS version: 0x501, vendor: 'Atheros OTUS Wireless Network Adapter', 0CF3:9170.F.conf
    [ 6561.849351] wlan1: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
    [ 6561.849441] usbcore: registered new interface driver ndiswrapper
    [ 6565.915061] ADDRCONF(NETDEV_UP): wlan1: link is not ready
    [ 6571.443584] ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
    [ 6581.708040] wlan1: no IPv6 routers present
    @pytheas22: is this "wlan1: no IPv6 routers present" hinting to a problem with ipv6? (I only use ipv4 with my router, afaict).
    ° pro: better future °
    ° against: corrupt corporations °

  10. #10
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Intrepid TP-Link WN821N on an old laptop

    @pytheas22: is this "wlan1: no IPv6 routers present" hinting to a problem with ipv6? (I only use ipv4 with my router, afaict).
    No, don't worry about this; dmesg always says stuff about ipv6 routers not being present, unless you're one of the (seemingly) three people in the world who actually owns an ipv6 router

    If you want to try to connect from the command line, the first step is to edit your /etc/wpa_supplicant.conf file. You can open it by typing:
    Code:
    sudo gedit /etc/wpa_supplicant.conf
    Erase whatever's in it now (if anything), and add this:

    Code:
    ap_scan=1
    ctrl_interface=/var/run/wpa_supplicant 
    
    network={
            ssid="myhomenetwork"
            scan_ssid=0
            proto=WPA
            key_mgmt=WPA-PSK
            psk="ASCII PSK Password in Quotes"
            pairwise=TKIP
            group=TKIP
    }
    Then save and close the file.

    To connect, run these commands:
    Code:
    sudo wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -dd
    iwconfig
    sudo dhclient wlan0
    Don't be surprised if it doesn't work on the first try. Please post all your output so we can try to figure out what went wrong. Usually you have to play around with the wpa_supplicant.conf file for a while before you hit the right settings.

    By the way, this is based on kevdog's guide to command-line wireless.
    Last edited by pytheas22; April 19th, 2009 at 08:01 PM.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •