Page 5 of 10 FirstFirst ... 34567 ... LastLast
Results 41 to 50 of 100

Thread: Update error

  1. #41
    Join Date
    Dec 2004
    Location
    Barcelona
    Beans
    264
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Update error

    w00t! Works fine. Many thanks for the nice script.
    Registered Linux User #371167

  2. #42
    Join Date
    Dec 2008
    Location
    Greece
    Beans
    105
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Update error

    Thanks yanick for the idea! Here is the final version of the script.

    Changes:
    -Scans all sources from /etc/apt
    -menu to choose release name
    Attached Files Attached Files
    Last edited by blackgr; January 29th, 2009 at 07:06 PM.

  3. #43
    Join Date
    Oct 2008
    Location
    Sydney | Shanghai
    Beans
    5
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Update error

    Thanks blackgr for the script. I don't need to run my own command again once new source is added.

    Great job!

  4. #44
    Join Date
    Oct 2008
    Beans
    93

    Re: Update error

    Quote Originally Posted by mb_webguy View Post
    What you can do is click on the string, which will take you do a search results page. On that page are two links. Right click the first (under keyID) and save the link to your computer. Now go to the Authentication tab in Software Sources, click the Import Key File button, and select the file you just downloaded to import the key.

    And yes, it still seems like there should be an easier way to do this.
    Hi, I have had two failures to configure due to missing pub keys. I followed the instructions. I copied the script to a text file and saved it in the documents folder. I went to Software sources, authentication tab and clicked import Key file but don't know how to select the file. All I can do is select the folder it is in, but I expected the script to then appear in the list under authentication and there is no change. What should I do to complete this process?

  5. #45
    Join Date
    Dec 2008
    Location
    Greece
    Beans
    105
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Update error

    Just download the script and execute it with sudo.
    example:

    sudo ./launchpad-update intrepid

  6. #46
    Join Date
    Jul 2008
    Location
    Huntsville, AL
    Beans
    6
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Update error

    sweet... THANKS blackgr!

  7. #47
    Join Date
    Jun 2006
    Beans
    20

    Re: Update error

    @Blackgr

    A minor correction to your script:

    * Original:

    wget -q --no-check-certificate `wget -q --no-check-certificate https://launchpad.net/~$i/+archive -O- | grep "http://keyserver.ubuntu.com:11371/pks/" | cut -d'"' -f2 ` -O- | grep "pub " | cut -d'"' -f2 >> keyss

    * Modified:

    wget -q --no-check-certificate `wget -q --no-check-certificate https://launchpad.net/~$i/+archive/ppa -O- | grep "http://keyserver.ubuntu.com:11371/pks/" | cut -d'"' -f2 ` -O- | grep "pub " | cut -d'"' -f2 >> keyss

    Only this way your script worked on my Ubuntu Hardy installation.

    JFYI.

    Regards,

    Danpos.

  8. #48
    Join Date
    Dec 2008
    Location
    Greece
    Beans
    105
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Update error

    Quote Originally Posted by danpos View Post
    @Blackgr

    A minor correction to your script:

    * Original:

    wget -q --no-check-certificate `wget -q --no-check-certificate https://launchpad.net/~$i/+archive -O- | grep "http://keyserver.ubuntu.com:11371/pks/" | cut -d'"' -f2 ` -O- | grep "pub " | cut -d'"' -f2 >> keyss

    * Modified:

    wget -q --no-check-certificate `wget -q --no-check-certificate https://launchpad.net/~$i/+archive/ppa -O- | grep "http://keyserver.ubuntu.com:11371/pks/" | cut -d'"' -f2 ` -O- | grep "pub " | cut -d'"' -f2 >> keyss

    Only this way your script worked on my Ubuntu Hardy installation.

    JFYI.

    Regards,

    Danpos.
    :-O this is something i didnt notice! Thanx Danpos for the feedback

  9. #49
    Join Date
    Nov 2008
    Location
    Omicron Persei 8
    Beans
    Hidden!

    Re: Update error

    Worked like a charm
    "All right amatuer hour's over. Let me show you why they call me the Velour Fog...."
    .:GitHub:.|.:Dropbox:.

  10. #50
    Join Date
    Dec 2007
    Beans
    183
    Distro
    Xubuntu 11.04 Natty Narwhal

    Re: Update error

    I got this working but now I have openoffice updates in update manager and I cant select them ...

    Whats wrong ?


    EDIT: Works now. Dont know why and dont know how but I just updated for 100th time and I can select all updates ...
    Last edited by mad_max0204; January 31st, 2009 at 12:16 PM.
    " If you aint first, your last " - Rees Bobby

    from the movie : " Talladega Nights: The Ballad of Ricky Bobby "

Page 5 of 10 FirstFirst ... 34567 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •