Page 2 of 10 FirstFirst 1234 ... LastLast
Results 11 to 20 of 100

Thread: Update error

  1. #11
    Join Date
    Aug 2007
    Location
    Cape Town, South Africa
    Beans
    10
    Distro
    Ubuntu Development Release

    Re: Update error

    Thanks a lot for the script. I'm just having a problem with the key for Banshee though. When using Update Manager it throws out the following error message:

    Code:
    W: GPG error: http://ppa.launchpad.net intrepid Release: The following signatures were invalid: BADSIG 4874D3686E80C6B7 Launchpad PPA for Banshee Team
    Any ideas?

  2. #12
    Join Date
    Oct 2007
    Beans
    740
    Distro
    Ubuntu Development Release

    Re: Update error

    I had that too, all you have to do is input the key " manually"

    go to http://keyserver.ubuntu.com:11371/pk...74D3686E80C6B7
    actually to make things easier I will just post the text here

    Code:
    -----BEGIN PGP PUBLIC KEY BLOCK-----
    Version: SKS 1.0.10
    
    mI0ESXWDEQEEAMoYQN5/6HptUWokWxGPNrJL8BtixSVpAjOMpNyzN27I6Ofl+5FWf+OidUpI
    2brAq8uspnvCxdRU7nYNJjaEZU3lyS1R48SpeCXi4ynP5o4nOHv4wXnjTesszbimXLWfnOjN
    G32rI+fMLuXderCU3ZMoHLqnhm/0o3JHVjwswkCLABEBAAG0HkxhdW5jaHBhZCBQUEEgZm9y
    IEJhbnNoZWUgVGVhbYhGBBARAgAGBQJJeqdKAAoJEEF/tkJIIf4k20MAoISSdMjpHlPQgWmq
    a+4hcuOhoCkFAJ9KabMOR6M/t9b1GidzRKvT+5IJx4i2BBMBAgAgBQJJdYMRAhsDBgsJCAcD
    AgQVAggDBBYCAwECHgECF4AACgkQSHTTaG6AxrcH8gP/XXQHv1WTXfRSXvd4xykkLy+BEIZz
    ImdTM8qyAoLtMsZFOKPEer1yfdB59AQXxnpm541YEn2hUmGhUgzz0XyTg+HCXQs8Go1AC4ie
    7Mdl1uMnD144T6x+G/VVojXpJ4RswNS3r6ZVoVTxQm75EBoYqOwOByzh4oq1vE5VL6dNoqE=
    =dWkD
    -----END PGP PUBLIC KEY BLOCK-----
    then copy the text.

    go to gedit (text editor) and paste it. I saved the file as banshee.asc, do the same on your desktop or home folder (your call)

    then go to software sources (System>Admin>Soft. Sources), and at the Authentication tab, click on the " Import Key File" button, select the file you have just saved. close the software sources GUI and refresh (sudo apt-get update)
    Last edited by waspbr; January 26th, 2009 at 05:59 PM.

  3. #13
    Join Date
    Aug 2007
    Location
    Cape Town, South Africa
    Beans
    10
    Distro
    Ubuntu Development Release

    Re: Update error

    Thanks waspbr. I followed your instructions, but I'm still getting the BADSIG error. I've resorted to installing Banshee via the deb file for the time being.

  4. #14
    Join Date
    Apr 2005
    Location
    Glasgow, Scotland
    Beans
    1,642

    Re: Update error

    Wouldn't it be better if the script used wget, as it's installed already?
    A Fedora user

  5. #15
    Join Date
    Dec 2008
    Location
    Greece
    Beans
    105
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Update error

    well i use curl in general as it prints page by default to the output. It can be also done with wget but i found it easier with curl
    Last edited by blackgr; January 25th, 2009 at 08:35 PM.

  6. #16
    Join Date
    Aug 2005
    Beans
    182
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Update error

    Script worked great! Thanks!
    Linux User #395848
    Blog: http://digitalnotions.net

  7. #17
    Join Date
    Aug 2008
    Location
    germany
    Beans
    857

    Re: Update error

    Script worked for me after some slight modifications.

    1.) At first it stopped after the sudo apt-get install curl part cause curl was already installed on my system.
    So I commented this part out.

    2.) I have my custom repo sources in a file in
    /etc/apt/sources.list.d/custom.list
    so I had to change the path from /etc/apt/sources.list accordingly.


    Thanks.

  8. #18
    Join Date
    Apr 2006
    Beans
    175

    Re: Update error

    Quote Originally Posted by blackgr View Post
    I made this small bash script. it will check you intrepid system for all launchpad sources and will download and install the keys for you!

    Who ever wants this for Hardy. Just edit the script and change intrepid to hardy

    edit:
    You have to run this with sudo
    Thanks buddy... much appreciated.

  9. #19
    Join Date
    Jan 2009
    Beans
    2

    Re: Update error

    Thanks alot for the script it worked great, although for some reason i still cant install the latest banshee, if any of you have any idea i would be very greatfull, it appears as an update but i get a messege telling me that i need to update alot of dependencies, and i have been looking for them, but it has shown to be pretty much impossible, thanks for the attention and in advance for the help!!!

  10. #20
    Join Date
    Jan 2009
    Beans
    2

    Re: Update error

    Quote Originally Posted by psy-kami View Post
    Thanks alot for the script it worked great, although for some reason i still cant install the latest banshee, if any of you have any idea i would be very greatfull, it appears as an update but i get a messege telling me that i need to update alot of dependencies, and i have been looking for them, but it has shown to be pretty much impossible, thanks for the attention and in advance for the help!!!
    Problem solved!!
    It was a stupidity, I was using the apt sources.list entry for intrepid instead of hardy which is the one I was suppose to use!!!

Page 2 of 10 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •