Page 10 of 10 FirstFirst ... 8910
Results 91 to 100 of 100

Thread: Update error

  1. #91
    Join Date
    Feb 2010
    Beans
    1

    Re: Update error

    Thanks!!

  2. #92
    Join Date
    Dec 2008
    Location
    Kent, UK
    Beans
    26
    Distro
    Ubuntu

    Re: Update error

    Unfortunately, this script would not work if one has a little hacked repos and for some is using ifferent distro, like, in my case, I must use "jaunty" for "synapse", which didn't get a release for Karmic yet:
    Code:
    root@czchown0009352:/etc/apt/sources.list.d# grep jaunty *
    synapse-ppa.list:deb http://ppa.launchpad.net/firerabbit/ppa/ubuntu jaunty main
    I would recommend to strip the "karmic" part out of the regexp. Also, soon, in April after there is a new ubuntu released (10.4), one would need to rewrite the script, so if you want to only process your current release repos, you should anyway use a variable provided by system, not a fixed string.

    CePal

    Quote Originally Posted by swajime View Post
    Many Thanks !
    The curl command would not work for me without the -L option.
    I made some other changes just to fit my personal OCD-taste:
    Code:
    #!/bin/bash
    #sudo aptitude install curl
    LIST_FILES=$(ls /etc/apt/sources.{list,list.d/*.list})
    LIST=$(cat $LIST_FILES |
       grep '^deb .*ppa\.launchpad.*karmic' |
       cut -d/ -f4)
    for i in $LIST; do 
       KEY_PAGE=$(curl -sL https://launchpad.net/~$i/+archive |
          grep 'http://keyserver.ubuntu.com:11371/pks/' |
          cut -d'"' -f2)
       KEYSS=$(curl -sL "$KEY_PAGE"|grep '^pub  ' |
          cut -d'"' -f2)
       for j in "$KEYSS"; do
          curl -sL "http://keyserver.ubuntu.com:11371$j" | 
             sed -ne '/BEGIN/,/END/p' |
             apt-key add -
       done
    done
    Now if I could just fix "W: GPG error: http://dell-mini.archive.canonical.com karmic-dell-mini Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F9FDA6BED73CDC22", I'd be really really pleased!

    j

  3. #93
    Join Date
    Oct 2009
    Location
    Everywhere
    Beans
    18
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Arrow Re: Update error

    Is there update for Karmic Koala or maybe even Lucid Lynx ???

    Thanks. Much appreciated!

    Respect to scripters!

  4. #94
    Join Date
    Feb 2007
    Beans
    4,045
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Update error

    Quote Originally Posted by HX_unbanned View Post
    Is there update for Karmic Koala or maybe even Lucid Lynx ???

    Thanks. Much appreciated!

    Respect to scripters!
    No need in Karmic and Lucid, it automatically downloads the keys when you add the repository.

    Code:
    sudo add-apt-repository ppa:reposname/ppa

  5. #95
    Join Date
    Jun 2010
    Beans
    5

    Re: Update error

    Quote Originally Posted by waspbr View Post
    I had that too, all you have to do is input the key " manually"

    go to http://keyserver.ubuntu.com:11371/pk...74D3686E80C6B7
    actually to make things easier I will just post the text here

    Code:
    -----BEGIN PGP PUBLIC KEY BLOCK-----
    Version: SKS 1.0.10
    
    mI0ESXWDEQEEAMoYQN5/6HptUWokWxGPNrJL8BtixSVpAjOMpNyzN27I6Ofl+5FWf+OidUpI
    2brAq8uspnvCxdRU7nYNJjaEZU3lyS1R48SpeCXi4ynP5o4nOHv4wXnjTesszbimXLWfnOjN
    G32rI+fMLuXderCU3ZMoHLqnhm/0o3JHVjwswkCLABEBAAG0HkxhdW5jaHBhZCBQUEEgZm9y
    IEJhbnNoZWUgVGVhbYhGBBARAgAGBQJJeqdKAAoJEEF/tkJIIf4k20MAoISSdMjpHlPQgWmq
    a+4hcuOhoCkFAJ9KabMOR6M/t9b1GidzRKvT+5IJx4i2BBMBAgAgBQJJdYMRAhsDBgsJCAcD
    AgQVAggDBBYCAwECHgECF4AACgkQSHTTaG6AxrcH8gP/XXQHv1WTXfRSXvd4xykkLy+BEIZz
    ImdTM8qyAoLtMsZFOKPEer1yfdB59AQXxnpm541YEn2hUmGhUgzz0XyTg+HCXQs8Go1AC4ie
    7Mdl1uMnD144T6x+G/VVojXpJ4RswNS3r6ZVoVTxQm75EBoYqOwOByzh4oq1vE5VL6dNoqE=
    =dWkD
    -----END PGP PUBLIC KEY BLOCK-----
    then copy the text.

    go to gedit (text editor) and paste it. I saved the file as banshee.asc, do the same on your desktop or home folder (your call)

    then go to software sources (System>Admin>Soft. Sources), and at the Authentication tab, click on the " Import Key File" button, select the file you have just saved. close the software sources GUI and refresh (sudo apt-get update)
    Confirm. thanks a lot!

    You've save my day.

  6. #96
    Join Date
    Aug 2010
    Beans
    1

    Smile Re: Update error

    thanks all.

  7. #97
    Join Date
    Jan 2010
    Beans
    2

    Re: Update error - added karmic and lucid

    Just my 2 cents...

    I've only added Karmic and Lucid to the selection screen. For me is working fine!

    Thanks!
    Attached Files Attached Files

  8. #98
    Join Date
    Jan 2011
    Beans
    3

    Re: Update error

    Quote Originally Posted by blackgr View Post
    Ok ppl! here is the final version.
    -Auto detects ubuntu version
    -Scans all repos and not just sources.list

    To execute it Just do the following after you extract it

    sudo ./launchpad-update
    What am I doing wrong?

    Code:
    me@myhost:/tmp$ sudo ./launchpad-update
    Release: precise
    Please Wait...
    cat: keyss: No such file or directory
    rm: cannot remove `keyss': No such file or directory

  9. #99

    Smile Re: Update error

    Quote Originally Posted by blackgr View Post
    Ok ppl! here is the final version.
    -Auto detects ubuntu version
    -Scans all repos and not just sources.list

    To execute it Just do the following after you extract it

    sudo ./launchpad-update
    I've tried putting in /bin /opt /tmp /etc and several other places and executing it each time, but no dice when I try the sudo /.launchpad-update cmd in Terminal.

    I'm at the limits of my Linux knowledge at this point.

    can anyone tell me the specific path to put file in ?

    I'm a bit lost.

    thank you!

  10. #100
    Join Date
    Oct 2006
    Location
    Ayrshire
    Beans
    40,277
    Distro
    Ubuntu Development Release

    Re: Update error

    Old thread closed.

    Feel free to start a fresh one.

Page 10 of 10 FirstFirst ... 8910

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •