Page 4 of 4 FirstFirst ... 234
Results 31 to 39 of 39

Thread: no rule to make target kernel/bounds.c

  1. #31
    Join Date
    Jun 2007
    Location
    Germany
    Beans
    26

    Re: no rule to make target kernel/bounds.c

    The package mirror archive you are using (in.archive.ubuntu.com) is not reachable. Try using a different mirror. In GNOME, just use System => Administration => Software Sources and select a different mirror in the field "Download from".

  2. #32
    Join Date
    Mar 2010
    Beans
    3

    Smile Re: no rule to make target kernel/bounds.c

    Thanks. It works.
    I m able to compile my hello world module.

  3. #33
    Join Date
    Jun 2007
    Location
    Germany
    Beans
    26

    Re: no rule to make target kernel/bounds.c

    You're welcome

  4. #34
    Join Date
    Apr 2007
    Beans
    16

    Re: no rule to make target kernel/bounds.c

    Quote Originally Posted by HubertB View Post
    You're running Karmic, right? Then this is what you need:

    Code:
    $ sudo apt-get install linux-source-2.6.31
    I thought the purpose of the linux-headers package was to build drivers without the full kernel source. Is it broken? If so, can someone file a bug report?

    I really enjoyed compiling my drivers on hardy (without linux-source).

  5. #35
    Join Date
    Mar 2010
    Beans
    9

    SOLUTION Re: no rule to make target kernel/bounds.c

    Quote Originally Posted by l_Thorium View Post
    Hello,

    I must compile my kernel for my webcam driver. But after the command "make prepare", I've got that :

    make[1]: *** No rule to make target `kernel/bounds.c', needed by `kernel/bounds.s'. Stop.
    make: *** [prepare0] Error 2

    so I've try sudo apt-get --reinstall install linux-headers-`uname -r` and I've installed the kernel source, but without any success...

    It's the same error with other kernel version.

    Can you help me please ?

    $(uname -r) is 2.6.27-9-server

    Hey buddy,

    I had the same problem and just found the solution:

    you're trying to compile the linux header directory.

    if it looks something like


    /usr/src/linux-headers-YOUR-KERNEL-VERSION
    - eg. mine is linux-headers-2.6.32-21

    you're trying to compile the wrong folder.

    Just go to www.kernel.org and download the kernel of your choice.

    To uncompress the compressed source archive, be sure use the command they specify in the readme file and not the uncrompress command that comes up in the contextual menu when you right click on the archive in your file manager (eg. if you use Dolphin, don't right click on the file and select an option from the contextual menu like "Extract Archive Here" as that will give you errors when trying to compile).

    Open a command prompt window. To extract the source code from the archive, go to the directory that has your compressed archive and use:

    gzip -cd linux-2.6.XX.tar.gz | tar xvf -

    or
    bzip2 -dc linux-2.6.XX.tar.bz2 | tar xvf -

    (where XX is your version of linux, include the minus sign in the command)

    After that:

    make menuconfig

    (if you want to turn on certain modules in the kernel, I used this menu to turn on support for HFS+ and mac partitions as well as Virtualization so that my Virtualbox application can run faster).

    make
    (go have a coffee, it takes a while)

    for anything else, check the readme file, it's very complete.

  6. #36
    Join Date
    Oct 2009
    Location
    Leesville, Louisiana, USA
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: no rule to make target kernel/bounds.c

    I had to do
    Code:
    apt-get removebuild-essential linux-headers-$(uname -r)
    to get it to install the drivers. I'm rebooting now

  7. #37
    Join Date
    Oct 2009
    Location
    Leesville, Louisiana, USA
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: no rule to make target kernel/bounds.c

    seems to have worked

  8. #38
    Join Date
    Jan 2011
    Location
    india
    Beans
    29
    Distro
    Kubuntu

    Re: no rule to make target kernel/bounds.c

    Hi all,

    Here is the simplest solution.
    use "make -C $(KDIR) M=$(PWD) modules" instead of "make -C $(KDIR) SUBDIR=$(PWD) modules"

    and it works ...!!!

  9. #39
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: no rule to make target kernel/bounds.c

    Closed, please don't bump old threads.

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •